Ribbon behavior

  • 1
  • Idea
  • Updated 5 years ago
Menu / Ribbon behavior is making me crazy!
Photo of Bill Fischer

Bill Fischer

  • 2 Posts
  • 1 Reply Like
  • Sad that a great tool is starting to wear on me.

Posted 5 years ago

  • 1
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey Bill,

Any specifics you can go into that would enable us to help you out a bit?
Photo of Bill Fischer

Bill Fischer

  • 2 Posts
  • 1 Reply Like
HA! That was just a vent... I am pleased it prompted a reply from Techsmith.

The Snagit Editor ribbon is counter intuitive to me:
  1. Initiate a capture via Hot Key and accept.
  2. Snagit Editor opens and the Tools ribbon is active and displayed.
However, if you should change focus to another window on your desktop, the ribbon minimizes. If you want to do anything with the capture, you have to reselect from the menu bar and get whatever ribbon you want to use. Inevitably, I will focus on another window (word doc, whatever) to see just how I am going to use the capture. When I go back to Snagit editor the ribbon has minimized again.

I believe that earlier versions of Snagit would leave the active ribbon open even if you changed focus to another window. When you returned, it would still be active.

Photo of taustin

taustin

  • 4 Posts
  • 1 Reply Like
I'm now on Snagit 12.2.2 (after resisting upgrade from Snagit 11 for a year or so, but now the interface is tolerable again).  I agree with Bill Fischer's comment made way back 8 months ago, why hasn't TechSmith fixed this big usability issue  over the intervening months? It should be a development priority.

The ribbon minimizes as soon as you remove focus from it, a silly design oversight! There should be an option to pin it open (like in Windows Explorer's ribbon, as just one example) so that multiple consecutive actions can be taken without your having to repeatedly re-open the ribbon.

How about fixing this ASAP, in Snagit 12.2.3 or 12.3 or whatever?
Photo of Tim

Tim, Snagit for Windows Software Developer

  • 89 Posts
  • 44 Reply Likes
It sounds like you may have accidentally turned on the option to Minimize the ribbon.  If you right click on the ribbon, you can uncheck the "Minimize the Ribbon" option and it should stay open all the time.  You can also toggle this by double clicking on one of the ribbon tabs (which might be how you turned it on).
Photo of taustin

taustin

  • 4 Posts
  • 1 Reply Like
You're right Tim, that's what happened. But because the ribbon kept closing automatically I did not notice this situation therefore did not have the ready opportunity nor even think of right-clicking on the option to turn it off.

This behavior, IMHO, is quite rather perplexing and counter-intuitive, a.k.a. a bad UI design decision. I strongly recommend that -- ASAP of course -- you use exactly the same permanently-visible icon as does Windows Explorer and other Microsoft products. It's a tiny and icon and not at all "in your face" and using the same icon as Microsoft is good from a commonality perspective.

In these Microsoft products  I  have the ribbon closed most of the time, and a quick click of the visible icon is all that's need to pin the ribbon open, followed by another click on the icon once I've completed the ribbon-based task and want to reclaim the display real estate.

I hope the Snagit team agrees with me and modifies this implementation.
(Edited)

This conversation is no longer open for comments or replies.