Screen zooms to max magnification when I initiate a Snagit Capture

  • 7
  • Question
  • Updated 8 months ago
  • Answered
HELP! When I try to capture anything on my screen by initiating Snagit, my screen (no matter if an app is running or not) zooms to maximum magnification. This hides about 3/4 of the screen from view and I can't find a way of getting to the rest of the screen, short of doing a desktop capture and then cutting out a part of that. What is wrong?
Photo of Jim

Jim

  • 2 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 7
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 94 Reply Likes
Hi Jim,

By chance are you running Snagit on one of the new Retina display MacBook Pros? If so, we are in the process of fixing a number of Retina-related bugs and releasing an update in the next week or so.

Thanks,

Jason
Photo of Jim

Jim

  • 2 Posts
  • 0 Reply Likes
Yes, Jason, I'm running MacBook Pro with Retina display. Thank you for letting me know. In the mean time I'll just take full screen captures and crop in the editor.

Crossing my fingers that the fix won't take too long.

Jim
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 632 Posts
  • 94 Reply Likes
Hi Jim,

We released version 2.1.1 today! If you open Snagit and choose the "Check for Updates" menu item under the Snagit main menu, you should be prompted to update your Snagit.

I hope this helps out. Here is a different post with more information about our plans for Retina support: http://feedback.techsmith.com/techsmi...

Thanks,

Jason
Photo of Steve Yacovelli

Steve Yacovelli

  • 1 Post
  • 0 Reply Likes
Hi ... I have 1.0.4 and it says "up to date!" when I try and rectify this situation. I guess it's forcing me to buy yet another license?!!?!? Grrrrrrr ... no bueno TechSmith.
Photo of Sally Townsend

Sally Townsend

  • 1 Post
  • 2 Reply Likes
I am using a PC running Windows and i am having the same problem. Do you know how I can fix it?
Photo of Jason Eagleston

Jason Eagleston, Employee

  • 628 Posts
  • 90 Reply Likes
Hi Sally,

We are unaware of a similar problem on the Windows platform. This problem was isolated to Snagit on Mac with the new Macbook Pro Retina Displays. If you are seeing a similar issue with Snagit Windows, please contact our technical support team for assistance as they will be able to better troubleshoot the problem.

A support ticket can be opened here: http://techsmith.custhelp.com/app/ask

Thanks,

Jason
Photo of rox.john

rox.john

  • 1 Post
  • 0 Reply Likes
I have windows 8 and the same problem is happening to me.
Photo of Kol Birke

Kol Birke

  • 1 Post
  • 0 Reply Likes
me too
Photo of Jacob

Jacob

  • 2 Posts
  • 2 Reply Likes

I have found a fix for this reoccurring issue on my Windows 8.1 machine... uninstall and use a new program. After altering my resolution and display sizes for 6 months to accommodate SnagIt... I finally learned that help is not on the way.


Photo of Jeremy Schembri

Jeremy Schembri

  • 1 Post
  • 0 Reply Likes
i am having this same problem..
Photo of todd.woodstra

todd.woodstra

  • 1 Post
  • 1 Reply Like
I have a Lenovo 910 running on an external monitor and have the same problem. I just upgraded to 13 and did not have this problem with 12. Help!
Photo of tbeane

tbeane

  • 4 Posts
  • 2 Reply Likes
Got this to work with SnagIt 11 on Windows 10.   Make sure the Windows display/magnification setting is 150% or lower. If using multiple monitors, make sure they have the same magnification setting.  After making the changes, you may need to log out of Windows and log back in again.
(Edited)
Photo of rashid

rashid

  • 1 Post
  • 0 Reply Likes
This worked. I had to change the Windows 10 magnification settings from 150% to 100%. Thanks for the tip! @tbeane
Photo of romans12.9.heart

romans12.9.heart

  • 1 Post
  • 0 Reply Likes
I have an older version of Snagit (1.0.4) and it is saying that I do not have a paid license for the new version, is there a way I can update to work on my Macbook Pro Retina Display without having to purchase it again? Thanks!
(Edited)
Photo of Garett

Garett

  • 1 Post
  • 0 Reply Likes
Hello,

I have SnagIt on my Mac with exactly the problem first described described above by Jim. I also have a  Mac with Retina Display.

I have SnagIt through a corporate license. When I click on SnagIt > Check For Updates... It tells me that I have the most recent release. However, About SnagIt tells me I have version 1.0.4.

I would love to have a working SnagIt on my Mac. Should I download the newest version from the web site?  Will my corporate license work?

Thanks!
Photo of Angela Terry

Angela Terry

  • 1 Post
  • 0 Reply Likes
I have used snagit regularly on my windows 8.1 machine and have not had this problem until today. Nothing has changed. Why all of a sudden is my screen zooming when I choose print screen!?
Photo of talktoshahid

talktoshahid

  • 1 Post
  • 0 Reply Likes
I am facing the exact same issue. :(
Photo of ppeterson

ppeterson

  • 1 Post
  • 1 Reply Like
I just received a new computer and Have the same issue I can no longer use Jing because the screen zooms so large it distorts my image. Since there is no help has anyone found another program that works? I have used this for years what a shame. 
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2839 Posts
  • 615 Reply Likes
Hello,
I'm sorry you are having trouble. Since the reason can be many things, please contact tech support and let them help you sort this out.

Technical support is a Free Service and you can submit a ticket here:

https://support.techsmith.com/hc/en-us/requests/new

Or call, 1.517.381.2300
Toll Free: 800.517.3001 (U.S. & Canada Only)
8:00 AM to 7:00 PM EST Monday through Friday

Kelly
User Assistance
TechSmith
(Edited)
Photo of rzegarra

rzegarra

  • 1 Post
  • 0 Reply Likes
I am getting this error on a SUrface Pro 3 that I just reinstalled. It was working fine before.
Photo of JimM

JimM

  • 1 Post
  • 0 Reply Likes
I have this intermittent problem as well running a MacBook Air with a Retina display. Frustrating enough to look for a different screen capture software. 
Photo of Michael Anderson

Michael Anderson, Developer

  • 115 Posts
  • 27 Reply Likes
Retina support for Snagit for Mac was added in 2.1.7 so you will have to be on that version or later for it to work correctly.  

No current problems are known with Retina in our current version (3.3.4) so if you are running into issues please contact Tech Support (here: https://support.techsmith.com/hc/en-us ) so we can collect some more information.

Thanks!
Photo of Theresia Mallia

Theresia Mallia

  • 1 Post
  • 1 Reply Like
HI I am having this problem on WINDOWS 8.1 any help please. as soon as I hit my 'printscreen' button it launches snagit and it zooms in I can't work any longer with snagit in this way pls help.
Photo of Adam Marks

Adam Marks, Software Developer

  • 124 Posts
  • 13 Reply Likes
Hello Theresia,

Can you check the Help-About dialog to see what version of Snagit you have?

I ask because in the latest versions of Snagit ( 12.4.1 is what I have ) we should be handling this better.

If you have a significantly older version of Snagit like 10 or you may need to turn off DPI scaling in Windows 8.1 via the workaround listed here :
https://feedback.techsmith.com/techsm...

Thanks,
Adam Marks
Developer, TechSmith
Photo of mhofert

mhofert

  • 1 Post
  • 2 Reply Likes
I am running Windows 10 on a new HP Elitebook and having the problem of the Screen zooming to magnification when I start SnagIt.   How can I correct?
Photo of tbeane

tbeane

  • 4 Posts
  • 2 Reply Likes
Got this to work with SnagIt 11 on Windows 10.   Make sure the Windows display/magnification setting is 150% or lower. If using multiple monitors, make sure they have the same magnification setting.  After making the changes, you may need to log out of Windows and log back in again.
(Edited)
Photo of Mike Brown

Mike Brown

  • 1 Post
  • 0 Reply Likes
I only have version 9 of snagit and was forced to upgrade my company computer to windows 10.  am i now forced to pay for a snagit upgrade to work with this new os?
Photo of twilder

twilder

  • 1 Post
  • 0 Reply Likes
I am having this same issue. I am using JING version 2.9.15255 on a Surface 4, new windows 10.
Photo of Fernando Alvarez

Fernando Alvarez

  • 1 Post
  • 0 Reply Likes
Windows 10
  1. Right click on your Desktop and choose Display Settings
  2. Move the slider to the left so it is set to 150% or lower
Windows 8
  1. Open the Control Panel and open the Display category
  2. Check the box to "Let me choose one scaling level for all my displays
  3. Set to 150% or lower
Windows 7
  1. Open the Control Panel and open the Display category
  2. Set to 150% or lower
Photo of Becky

Becky

  • 1 Post
  • 0 Reply Likes
New laptop with Windows 10 build 10240. The magnifier setting is 125, still having the issue.  
Photo of Tiffani

Tiffani

  • 1 Post
  • 0 Reply Likes
Thank you for your post. You helped me. I have Windows 8. I did not understand what was wrong. Thanks to you now everything works.
Best regarts, Tiff
Photo of Janice Zimbro Rittgers

Janice Zimbro Rittgers

  • 1 Post
  • 0 Reply Likes
I am using a Dell. The recommended resolution was set to 250. If I lower it to 150 or lower, I need a magnifying glass to read the screen. This is not an option for the newest Windows 10. I do not want to destroy my laptop just so I can use SnagIt. Any recommendations for another program?
(Edited)
Photo of Glenn Colby

Glenn Colby

  • 1 Post
  • 0 Reply Likes
I was just able to fix this problem on my Windows 10 machine. I think it originally started when I hooked my laptop up to a projector and some of the display settings went haywire.  Everything went back to normal when I connected to my regular dual monitors, except Snagit editor for some reason kept popping up with a scale of something like 250% and I could not get it back to normal.  So...

I right-clicked on the desktop then selected 'Display Settings'.  The scale was set to 100%, but I noticed that if I changed the scale (e.g., to 125%), there was a little message in red saying that for some applications the scale would not be changed until I logged out.  So...  I did this...

1. changed scale to 125%
2. logged out
3. logged back in and changed scale back to 100%
4. logged out
5. logged back in and snagit editor is back to normal (scale 100%)
Photo of James Bailey

James Bailey

  • 2 Posts
  • 0 Reply Likes
This is BS way of fixing the issue. C'mon Snag it people, I'm not going to change my resolution for everything I do just to get Snag It to stop magnifying. The issue is 6 years old.
Photo of annelewson

annelewson

  • 8 Posts
  • 1 Reply Like
I agree with @James Bailey.  This is not an acceptable Solution.   PLS Snagit People. Fix it
Photo of annelewson

annelewson

  • 8 Posts
  • 1 Reply Like
I agree with @James Bailey.  This is not an acceptable Solution.   PLS Snagit People. Fix it
Photo of atmcmurray

atmcmurray

  • 1 Post
  • 0 Reply Likes
Yes this is BS - I have 3 screen running and cant afford to set magnification at 100% - it was nt an issue yesterday but arises intermittently