Screencast.com Currently Experiencing Performance Issues

  • 3
  • Announcement
  • Updated 3 years ago
Screencast.com is experiencing performance issues.

Services impacted:
  • Content that requires a password is unavailable
  • Uploading content from the web
We've got all hands on deck to get the service fully functional as soon as possible.
Photo of Chris Larson

Chris Larson, Snagit Technical Product Manager

  • 590 Posts
  • 319 Reply Likes

Posted 3 years ago

  • 3
Photo of leybova

leybova

  • 1 Post
  • 1 Reply Like
Thank you for you hard work, guys, and for excellent product!
Photo of jurisnaturalis

jurisnaturalis

  • 1 Post
  • 0 Reply Likes
Well, now I know it's not just me. Thanks for the heads up.
Photo of nancy5809

nancy5809

  • 2 Posts
  • 0 Reply Likes
When I go to print my screencast it has a large space at the top of the page, which cuts off part of what I need to print.  I must have this because I need to fax this paperwork to various chargeback centers, as part of my job.
Photo of Missy

Missy

  • 1 Post
  • 0 Reply Likes
Any update when this will be resolved?
Photo of Chris Larson

Chris Larson, Snagit Technical Product Manager

  • 590 Posts
  • 319 Reply Likes
We are still working on a fix. But do not have a estimated time to fix just yet. We believe we've narrowed down the issue though and are testing out a fix on our development servers right now.
Photo of chris.mannion-james

chris.mannion-james

  • 1 Post
  • 0 Reply Likes
Thanks great work
Photo of SheyRover

SheyRover

  • 3 Posts
  • 0 Reply Likes
I have also not been able to upload content from my computer. I didn't see that noted in your list there, so thought I'd let you know. None of the files I'm trying to upload are working. Thank you.
Photo of Chris Larson

Chris Larson, Snagit Technical Product Manager

  • 590 Posts
  • 319 Reply Likes
Hmm, thanks for the heads up. We haven't seen that yet.

Is this with the Desktop Uploader or from Jing, Snagit, or Camtasia?

If it's with Jing, Snagit, or Camtasia, it would be best to contact support so we can get more information: https://support.techsmith.com
Photo of jsheeley

jsheeley

  • 1 Post
  • 0 Reply Likes
I've also been experiencing issues uploading today through Jing. 
Photo of Chris Larson

Chris Larson, Snagit Technical Product Manager

  • 590 Posts
  • 319 Reply Likes
That could be due to a slowdown between 11am-1:30pm Eastern. If it's still happening, it would be best to contact support so we can get more information: https://support.techsmith.com
Photo of SheyRover

SheyRover

  • 3 Posts
  • 0 Reply Likes
Yes, it was through Jing, and I'm uploading the Jing screencasts that have been saved to my computer. I'll contact support if the issues is still happening now when I try to upload again. Thank you!
Photo of SheyRover

SheyRover

  • 3 Posts
  • 0 Reply Likes
Whatever the issue was, it is now working properly and I'm no longer experiencing the problem.
Photo of OceanWalker

OceanWalker

  • 2 Posts
  • 0 Reply Likes
Ah great - thanks for posting this. Will look forward to it all being resolved :)
Photo of Cedeno

Cedeno

  • 10 Posts
  • 0 Reply Likes
Download feature is also not working for videos.
Photo of Chris Larson

Chris Larson, Snagit Technical Product Manager

  • 590 Posts
  • 319 Reply Likes
We haven't seen that yet either.

It would be best to contact support so we can get more information, specifically the the view page that was encountering the problem so we can try and reproduce it: https://support.techsmith.com
Photo of nancy5809

nancy5809

  • 2 Posts
  • 0 Reply Likes
Is this one of the issues you are working on?  --> When I go to print my screencast it has a large space at the top of the page, which cuts off part of what I need to print.  I must have this working because I need to fax this paperwork to various chargeback centers, as part of my job.  This is in Snagit.  
(Edited)
Photo of Chris Larson

Chris Larson, Snagit Technical Product Manager

  • 590 Posts
  • 319 Reply Likes
We are also seeing this, it is not related to the current outages, but we will investigate ways to fix this in the future.
Photo of Chris Larson

Chris Larson, Snagit Technical Product Manager

  • 590 Posts
  • 319 Reply Likes
Alright! We’ve found and deployed a potential fix to the problem.

If you are still seeing issues related to:
  • Uploading from the website
  • Accessing content that is password protected
Please let us know here.

If you are experiencing any other issues, please contact support as normal: https://support.techsmith.com
Photo of anna_smith

anna_smith

  • 3 Posts
  • 0 Reply Likes
Just posted a video 30 minutes ago, public.  at the 7:58 mark, the video is gone, but audio remains.  Reposting and hope it was just a glitch.  The video is fine on my timeline.
Photo of anna_smith

anna_smith

  • 3 Posts
  • 0 Reply Likes
I have had issues with content not requiring a password also not appearing over the last 8 weeks.  I assumed it was our in house network security settings.
Photo of Chris Larson

Chris Larson, Snagit Technical Product Manager

  • 590 Posts
  • 319 Reply Likes
Official Response
Looks like we are all clear on these issues! Thank you for your patience.

Again, if you are experiencing any other issues, please contact support as normal: https://support.techsmith.com

This conversation is no longer open for comments or replies.