Share Single Content Embedding

  • 1
  • Problem
  • Updated 2 years ago
What happened to "Share Single Content - Embed on Your Page" I checked Beta Support and it indicates that it is there, but I only get Share a Link and Embed a Link.
Photo of gmvideos

gmvideos

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Guy Larcom

Guy Larcom, Instructional Designer

  • 118 Posts
  • 23 Reply Likes
Hi gmvideos,

The "Embed on Your Page" option is only available in hidden and public folders. I am wondering if the folder your content is currently in is set to Password Protected or Authenticated.

The folder settings dialog will allow you to check and change the privacy of your folders: https://support.techsmith.com/hc/en-us/articles/235678608

Does this help? Please let me know if this is not the right solution, and I'll continue to provide advice.

Thanks for reaching out!

Guy
Photo of gmvideos

gmvideos

  • 2 Posts
  • 0 Reply Likes
Thanks for responding so quickly.  I do have the folder as hidden and when I click on share for a single file within the folder, I still do not get "Embed on your page" as an option - only shares as links.  Your beta support page indicates I should get this option in addition to the email link and embed link options.  I do get Embed Medial Roll for a folder when set to public, but that shows all files within a folder then.  I did do a work around for embedding a video (as I had Screen Cast codes from a few years ago for Embedding a single video file on a web page( by replacing the file location and embed source within the embed code with the new location and new embed source for the new video.  I need to have the video play within the web page, so embedding the link does not do this, as all it does is give a link to Screen Cast to play directly within Screen Cast rather than within my course web page.  Any ideas why I am not getting an "Embed on Your Page" as was done a few years ago and also showing as an option in the support section?  Am I missing something or have something not set correctly? I was using a Chrome browser and tried Edge with the same result.  George
Photo of Guy Larcom

Guy Larcom, Instructional Designer

  • 118 Posts
  • 23 Reply Likes
Hi George,

Sorry my first idea wasn't the right solution. I now want to make sure you're selecting the right Share button. The one in the upper right corner displays the folder Share options. To see the options for sharing a single piece of content, select it by clicking the checkbox and then click the button pointed out in the image below.



The dialog displayed after clicking that button should not include MediaRoll embedding and should have the "Embed on your page" option available.

Here is an article, which you may have already looked at, for more information: https://support.techsmith.com/hc/en-us/articles/235747787

Do let me know if this does not solve the issue!

Thanks,

Guy
Photo of gmvideos

gmvideos

  • 2 Posts
  • 0 Reply Likes
Thanks Guy.   I was trying to embed a swf file so I thought I would see if a different file or file format made a difference.  Here is what I found.  For swf files, when I click on share, the "embed on page" option does not show.  However, when I tried my MP4 files, the "embed on page" does appear.  I know HTML5 or MP4 is more favored than Flash, but I was still needing to embed swf for a little longer for some folks with older browsers and OS.  As mentioned previously, I was able to embed SWF by tweaking some old ScreenCast embed code I had earlier and swf plays fine from ScreenCast.  George