Shift is not mapping as a keystroke in Camtasia 2 for Mac

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Whenever I try to use a hotkey with shift in it, it doesn't show in the keystroke mapper. It doesn't even allow me to show shift when I manually try and do an annotation. Does anyone have a solution for this?
Photo of Peter Dowsett

Peter Dowsett

  • 2 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 7250 Posts
  • 3954 Reply Likes
On windows machines if you hold down shift first, then click your next key stroke. It can work with manual annotations.
Same with "Ctrl+Shift+H" or similar commands. The key is don't release any of the keys before you hit the last key.
 I don't even own a Mac. So I hope this still helps. I accidently ended up on this page somehow. 
Regards, Joe
Photo of Stephen Wagner

Stephen Wagner, Employee

  • 650 Posts
  • 175 Reply Likes
The keystroke capture in Camtasia for Mac was designed with menu shortcuts in mind, which usually include the command, option or control key.  It was not designed to capture all all the keystrokes, particularly keystrokes, such as just pressing shift, which do not generate text.  We understand that there are cases where it would be useful to capture all the keystrokes, but currently it is limited to typical menu shortcuts.  

One way to create a keystroke annotation of just a shift key is to use cropping.  For example, add a keystroke annotation, set it to be 'Shift A', and then crop out the 'A'.  Here is a short silent video demonstrating how to do it:

This conversation is no longer open for comments or replies.