Shure PG42usb Microphone Static Issues?

  • 1
  • Problem
  • Updated 9 months ago
Whenever I talk my Shure PG42-USB makes very annoying static sounds. If I can post a link I will. Only happens whenever I talk. It's at random too. I use a Foam Windscreen and a shock mount as well as a desk stand. I use Xsplit to record. Posting anything I can think of, would love some help if possible.

Edit!: Looked over and sounds more like a crackle? Not to sure what to do, just started happening too.


Photo of Peter Gregory

Peter Gregory

  • 3 Posts
  • 1 Reply Like
  • sad, annoyed, troubled

Posted 3 years ago

  • 1
Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes

Hello,

Chances are that's your only USB mic? First step would be to reverse troubleshoot signal chain starting with mic, then cable then interface box unless direct to PC USB port. If it worked properly before, try re-seating the connections, try a different USB connection. Disconnect anything that is not required while you record.


Photo of Peter Gregory

Peter Gregory

  • 3 Posts
  • 1 Reply Like
It is, so far only things I have plugged in would be my camera, my mouse and microphone. I removed all and even plugged in the microphone in different USB ports just now. It works for the first time recording but then as soon as I test it for a second time the crackling sound comes back again.
Photo of Timbre4

Timbre4, Champion

  • 680 Posts
  • 273 Reply Likes
Wondering if something temporary is created and interfering on the second go around. Try a test, then close the program and see if the subsequent "first pass" stays clean or goes noisy.
Photo of Joe Morgan

Joe Morgan

  • 7222 Posts
  • 3912 Reply Likes
type "Voice Recorder" into your computers search panel.

Use the Windows voice recorder and see if you encounter the same recording problems. Run a few tests. See what happens.

Regards, Joe
Photo of Peter Gregory

Peter Gregory

  • 3 Posts
  • 1 Reply Like
Hello Joe, 

Turns out Xsplit might be the problem, done this for 2 times and no issue with the sound.
My only issue now is that I do YouTube videos and record with face cam, Couldn't get OBS to work. However I am glad that the microphone was not at fault. Thank you for the help.

Peter
Photo of Joe Morgan

Joe Morgan

  • 7222 Posts
  • 3912 Reply Likes
Great, that's half the battle. Good luck with the rest.

Photo of Aldridge Lima

Aldridge Lima

  • 1 Post
  • 0 Reply Likes
hi i need help my mic is picking level is very low..close tonone ,nomatter how much i boost the volume its still the same and also clipping.