Smart player - First_Frame.png stretches over the entire browser.

  • 1
  • Question
  • Updated 1 year ago
When I produce with the Smart Player - The First_Frame.png stretches over the entire browser and gets cut off. Also the play / rewind buttons are too big. Using Camtasia 9.0.3



Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of kayakman

kayakman, Champion

  • 8063 Posts
  • 2785 Reply Likes
re the button, where are you hosting? or viewing locally?

make your own start button from a image of the normal button, sized as you want, as a hotspot; I've done this thousands of times; hotspot callout is placed at start of project, configured as stop at end/click to continue, 2 seconds in duration; when production set to not pause at start, the hotspot will give the viewer the impression that all looks normal; just click hotspot to play

same with the rewind button

issue is that browsers now try to force pause at start behaviors; this can be overridden in Chrome [by each user], but can interfere with desired behavior; video will still pause at start, click the enforced start button will then start play but pause at 2 sec

re the png, have you tried making/setting your own, using a saved frame?

are you launching using the xxx.html or the xxx_player.html?  
Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
Thank you kayakman, I am self-hosting the video and using player.html to launch it. The main problem now is it simply will not play on an iPhone, it asks to download a player making it a deal-breaker. Do you know of a workaround?
Photo of kayakman

kayakman, Champion

  • 8063 Posts
  • 2785 Reply Likes
sorry ira; but I have no experience with iPhone and Camtasia

hopefully Ben can assist further
Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
Thank you.
Photo of Ben Rhodes

Ben Rhodes, Employee

  • 429 Posts
  • 154 Reply Likes
Hi Ira,

The Smart Player want to fill the entire width of the player with the poster image.  If you make your image wider with empty space it will fit ok.  I've modified it for you if it helps.



For the play button image sizes, you'd have to modify the SVG images that are embedded in the css file.

Ben
Photo of Fred Grover

Fred Grover, Champion

  • 2445 Posts
  • 386 Reply Likes
Great advice Ben and thanks for sharing and keep up the great work.
Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
Thank you Ben, yes that does work!  The main problem now is it simply will not play on an iPhone, it asks to download a player making it a deal-breaker. Do you know of a workaround?
Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
One more question, when I resize the poster image it works but is not responsive, so it fails on phones. Any ideas?
Photo of Ben Rhodes

Ben Rhodes, Employee

  • 429 Posts
  • 154 Reply Likes
Make sure you update Camtasia 9 to the latest version which should be 9.1.4.  You can get that here https://www.techsmith.com/download/oldversions. The version of the Smart Player that is shipped with that version no longer needs a separate iOS app for playback as long as the iPhone is running iOS 10 or greater.
One more question, when I resize the poster image it works but is not responsive, so it fails on phones. Any ideas?
Are you referring to the size of the video player or just how the first frame is displayed?

Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
Hi Ben,

Thank you! I updated and we are good. When my video ends I have it set to go to another url.

Right before it goes to that url it shows me a black page with a rewind button for 2 seconds than sends me to the correct url.

Can I remove or disable that black page with a rewind button?

Also I am using a hot-spot to start the video so I no longer need a poster image.

Thank you for all of your help.


Photo of Ben Rhodes

Ben Rhodes, Employee

  • 429 Posts
  • 154 Reply Likes
Ira,

The newest version of the Smart Player does not display the replay button when opening a URL at the end of the video.  Unfortunately we are only shipping new versions of the Smart Player with Camtasia 2018.  However if you want to manually update the player I've written a support article on how to update the Smart Player

Ben

Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
Thank you Ben for all of your help, I appreciate you and your patience.
Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
Hi Ben,
Okay so I updated the smart player and that removed the rewind icon, but I am getting a rogue play icon and black start screen start screen. It varies on different devices so I am going to show you some screenshots. Here is a link to a pdf that has all of the information: http://kryptonitehost.com/Ben.pdf

If this is very complicated, can I hire you guys to customize this for me? The file is not getting embedded, I will be using the player and files as is, so you would not be installing it on a website or need access to anything. It could be built locally. It is going along side a website.

Thanks again for your time,
ira


Photo of Ben Rhodes

Ben Rhodes, Employee

  • 429 Posts
  • 154 Reply Likes
Ira, 

Unfortunately we can not support you with manually modifying the Smart Player.  I'm always interested in your use cases for the player and may lead to other custom configurations.

Ben
Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
Hi Ben,

I understand, do you know how I can just remove the play Icon? It only shows up on mobile.

Thanks again,
ira



Photo of Ben Rhodes

Ben Rhodes, Employee

  • 429 Posts
  • 154 Reply Likes
By mobile, you mean iOS devices?  The play icon may be the native video element icon?
Photo of ira

ira

  • 10 Posts
  • 0 Reply Likes
Hi Ben, I believe you are right on the IOS that icon does not look like the Techsmith icon, but the Chrome on Android or Windows the Techsmith play icon is showing up, can you tell me how to remove these?

Thank you,
Ira