Snag-It v2019.0.1 very, VERY Slow on Windows 10 Pro (64-bit)

  • 6
  • Problem
  • Updated 3 weeks ago
There was a 3-5 second delay in v2018 that I had been living with, but I was excited to upgrade to v2019 hoping that they had fixed this issue. It's not fixed. It's way worse.

Takes 5-8 seconds for the capture cross-hairs to activate after pressing "Print Screen" and another 3-5 seconds for the capture toolbar to appear. This is making the software almost un-useable.

Has anyone figured out a way to fix this on their Surface?

I have entered a maint ticket today and I'm waiting for a response.
Photo of jennlibera

jennlibera

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 months ago

  • 6
Photo of patt_thomasson

patt_thomasson

  • 32 Posts
  • 11 Reply Likes
I see that same delay on all my devices as well (2 laptops and 1 tower system), so it is NOT just on Surface systems. It is quite annoying to find you lost a screen capture because the item disappeared before Snagit became active!
Photo of Ronnie West

Ronnie West

  • 51 Posts
  • 4 Reply Likes
I agree with Patt, this bug is on my PC as well. It really is annoying!
Get it sorted Snagit! please.
Photo of AS

AS

  • 10 Posts
  • 2 Reply Likes
Yes but pay an annual maintenance fee for all the latest and best updates!

It's almost unusable (in fact it is unusable).
Photo of Tom Scharf

Tom Scharf

  • 8 Posts
  • 2 Reply Likes
For what it's worth, I rebuilt my PC recently and this problem disappeared, even after reinstalling all the same software.  It's some sort of Windows conflict with other software.  Unfortunately it is almost impossible for a user to diagnose what this conflict is.  It's still not as fast at Snagit 2013 was, but it is at least tolerable.  They need to work on response times.
Photo of AS

AS

  • 10 Posts
  • 2 Reply Likes
It took me 15 mins to get a scrolling screen cap for a web-page right... It's not just the load time to start, the drag area takes forever and is intermittent, so it becomes very difficult to achieve.
Photo of Rick Stone

Rick Stone

  • 5144 Posts
  • 2420 Reply Likes
I've noted many issues reported for scrolling captures. Curious if you have tried the Panoramic capture? That seems to be way more efficient than the older scrolling captures.
Photo of Paul

Paul

  • 1543 Posts
  • 1151 Reply Likes
I agree. Panoramic is the way to go.
Photo of Tom Scharf

Tom Scharf

  • 8 Posts
  • 2 Reply Likes
I have the same problem.  I upgraded from the version two years ago (13?) and this problem just started.  I have 2 4K displays and a 5K display.  Not sure if this is related.  But it takes over 3 seconds sometimes for this to engage and it was almost instantaneous previously.  W10 x64.

This is definitely a downgrade.  Humorously I only upgraded because the previous version's auto-updater had a horrible bug with a memory leak and excessive CPU after it ran a long time.


Photo of Tom Scharf

Tom Scharf

  • 8 Posts
  • 2 Reply Likes
So ... In another thread someone reported a conflict with Realtek HD Audio Manager.  I removed that and performance got much better.   So you might try that.

Another crazy Windows conflict.  Not exactly intuitive that audio and screen capture can't coexist.  Not sure who's fault it is.  The HD Manager software was pretty bad and I don't need it like I need SnagIt.  Perhaps upgrading it might help, but I didn't try that.

Photo of tporto1031

tporto1031

  • 1 Post
  • 0 Reply Likes
Tom,

This is incredible, Thank you!!  Not only did disabling Realtek HD Audio Manager increase my Snag-It performance, it sped up my entire system (Windows 10, 64-bit) performance, including faster web-page loading and faster MS Excel launching  (I guess audio manager sucks up RAM as well?)

I also had trouble overall with my mouse (E.g., delayed click & drag/highlight).  I would have never thought all these problems were caused by audio manager.  I'm still in awe that after disabling audio manager, it's like I have a new PC. 

THANK YOU!!

Tom
(Edited)
Photo of Melissa Bailey

Melissa Bailey

  • 3 Posts
  • 0 Reply Likes
I hate that I am not the only person with this issue, but also relieved that it is not just me!
Photo of Paul

Paul

  • 1545 Posts
  • 1152 Reply Likes
+1 for performance issues.  Not as extreme as others have reported, but still not good.
Photo of jennlibera

jennlibera

  • 2 Posts
  • 0 Reply Likes
It's the monitors/displays. If I unplug my monitors and run Snagit on just the Surface display, it's much faster. Unfortunately I can't work without my additional monitors, so I'm out of luck. I'll be searching for a different product I suppose. It's a shame, because Snag-It has been amazing for me for years.
Photo of will

will

  • 1 Post
  • 0 Reply Likes
Same here. I'd say it's a good 5 to 10 seconds on my PC. I have 7 monitors - all HD - but I've also got 32G of RAM and two AMD 580 video drivers -- so my background processing is top tier. 

Agree fully with all comments above. The delay is a real problem in a number of desired applications / interfaces.
Photo of Ronnie West

Ronnie West

  • 57 Posts
  • 4 Reply Likes
So what is Snagit doing about this problem? Before others desert the software!