Snagit 13 Lockups

  • 2
  • Problem
  • Updated 1 year ago
Big Snagit fan for many, many years but version 13 lockups so bad that one can't even restart Windows 10 unless killing processes within TaskManager. Yes, I keep installing the latest builds but the problem continues.
Photo of david

david

  • 3 Posts
  • 1 Reply Like

Posted 1 year ago

  • 2
Photo of Joe Morgan

Joe Morgan

  • 5623 Posts
  • 2919 Reply Likes
I've been running SnagIt 13 on Windows 10 ever since SnagIt 13 was released.
 I've never encountered the issue you are reporting. If I were you I would contact tech support.

This is a Free Service...............You can Submit a ticket

       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

Photo of david

david

  • 3 Posts
  • 1 Reply Like
No thanks. All I'm trying to do is capture a portion of the screen and add a border. I'm an IT guy and don't have the time to go through the tech support routine with people that knows less than me. I'll just downgrade to an older version or switch to another vendor and never recommend anyone ever buy a new version of Snagit.
Photo of Rick Grunwald

Rick Grunwald

  • 1249 Posts
  • 856 Reply Likes
I understand your frustration,  but if you are having a problem that neither Joe nor I are having then the problem may be deeper but still fixable
I think what I would do is
  • Copy the datastore folder to somewhere (desktop)
  • Totally remove Snagit from your system including all the folders including ti program files and your APPDATA
  • Reboot
  • Reinstall Snagit
  • With snagit closed dump the contents of the datastore on your desktop to the newly created location 
  • Start snagit and go from there

I have had this issue with other programs. Then contact tech support if you still have an issue on the off chance that they see this occasionally and have a quick fix

Good luck with it
Photo of Daniel Foster

Daniel Foster, Snagit strategy lead

  • 861 Posts
  • 192 Reply Likes
Hi David - if you work in IT you also know how difficult it can be to track down an elusive bug. We test against a variety of configurations here at TechSmith and prioritize fixing anything that would cause a severe issue like you describe. Our tech support agents know the products inside and out and have a direct line to the engineering staff. So any info you can provide will be helpful in reproducing, diagnosing, and ultimately fixing the issue.