Snagit 13 - mouse pointer randomly captured even with Capture Cursor turned off

  • 6
  • Problem
  • Updated 3 weeks ago
I have Capture Cursor turned off, but the mouse pointer is frequently included in the captured image. It shows up in seemingly random locations within the captured region. I initiate the captures from the OneClick bar. In the Image capture settings, Selection is set to Region with "Select region at capture". The Preview in Editor setting is on; the Copy to Clipboard, Capture Cursor, and Time Delay are off. Snagit 13.0.1, Windows 10 Pro 64-bit.
Photo of rborup

rborup

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 6
Photo of vtancs

vtancs

  • 2 Posts
  • 2 Reply Likes
Yes. As an ex user of tech smith 13, I encountered this behavior. It's a really annoying feature and very unproductive having to redo the capture or edit away the cursor manually. Hope they get it fixed for you.
(Edited)
Photo of rborup

rborup

  • 4 Posts
  • 0 Reply Likes
It appears the workaround is to not move the cursor over the region to be captured for a couple of seconds before selecting the region. Hope they get this fixed in 13.0.2.
Photo of rborup

rborup

  • 4 Posts
  • 0 Reply Likes
Re the workaround, the appropriate delay time after clicking the capture button seems to be to wait until the magnifier shows up. It appears that if the mouse is within the planned capture region before the magnifier appears, that's when the mouse pointer is captured even with Capture Cursor turned off. After the magnifier appears, this doesn't happen.
Photo of Dany_jim

Dany_jim

  • 215 Posts
  • 55 Reply Likes
Remove hotkey to up click on the "x"
and put in second here.
Put the "Capture Cursor" to OFF

or
"Presets" - what do you like

I hope to fix on it.
and Editor is full of bugs me despairing.
It has many minuses.




(Edited)
Photo of Dany_jim

Dany_jim

  • 215 Posts
  • 55 Reply Likes
in "OneClicK" - I think that is permanently set to "All-in-one"
for me is not help much.

https://feedback.techsmith.com/techsmith/topics/snagit-13-integration-the-main-window-in-oneclick-wi...
(Edited)
Photo of rborup

rborup

  • 4 Posts
  • 0 Reply Likes
> in "OneClicK" - I think that is permanently set to "All-in-one"

You are correct. I should have mentioned that I have Capture Cursor turned off in the All-in-One settings as well.
Photo of Dawson

Dawson

  • 5 Posts
  • 3 Reply Likes
Hello,

I am using the latest version of Snagit 13.1.3 and the problem still exists for me. Same OS as the original poster. Windows 10. Every time I use Snagit from One Click, the mouse cursor is captured. despite the that capture cursor is disabled in both All in One and Image. Has Snagit still not fixed this even after so many updates? Is anyone listening to this bug at Snagit tech???
Photo of rwhitacre

rwhitacre

  • 1 Post
  • 0 Reply Likes

I was able to fix this issue (finally). In the bottom left corner of the SnagIt window, click on Presets. Then click on the "gear" icon to the far right of Image then choose Edit. I discovered that "Capture Cursor" was set to On. I didn't realize that it was a separate setting than the All-in-One Image setting. This instantly removed the cursor during a capture.

I don't know if this will fix everyone's problem, but hopefully it will at least help some!

Photo of PSG

PSG

  • 2 Posts
  • 0 Reply Likes
In the All-in-One, make sure "Capture Cursor" is turned off. Then at the bottom there is preset name, click on it, after clicking the preset name, cursor will not be visible when capturing. Hope this helps, it worked for me.
Photo of ylandrum

ylandrum

  • 2 Posts
  • 0 Reply Likes
I can confirm that as of 18.2.1 this is still an issue. I have just uninstalled 2018 and have gone back to 12.4.1. Yeah, the OneClick button is still not configurable, but at least it does not capture the cursor nor does it have an annoying 5 second delay. It is a lot snappier and responsive than 2018 as well. I can live with those defaults.
Photo of jaydorsey

jaydorsey

  • 1 Post
  • 0 Reply Likes
This same issue occurs with macOS 10.14.4, snagit build 2019.1.3 (94036)

What I've done:

- Turned off capture cursor on all in one
- Turned off capture cursor on image
- Turned off capture cursor on video
- Turned off these 3 settings in the 1 preset I have, which has no shortcuts and I don't even use

The only resolution was to build a new preset, per comment from rwhitacre above and turn those settings off. I re-mapped my shortcut to my preset and it now works as expected.

Very disappointing that this one minor, but very common use case, is still an issue after 3 years

Photo of Kevin Carmony

Kevin Carmony

  • 4 Posts
  • 0 Reply Likes
I am on 2019.1.6 and it still has this problem.  I tried all the suggestions above, and no matter what I did, it captures the cursor. 

THEN...

Because I figured there was just no way to get it not to capture the cursor, I went to my Mac's Accessibility Settings and made the cursor as small as possible...and guess what?  It no longer captured the cursor!  I even then set my cursor to larger, and it kept working, and didn't capture the cursor.  So, apparently, just changing the cursor size in the Mac's Accessibility Settings AFTER having told Snagit not to capture the cursor jogged something to make it start working.

Try it, see if it helps you too.
(Edited)