Snagit 2018 elephantiasis

  • 1
  • Problem
  • Updated 11 months ago
I have a mutli-screen setup. I recently got a new laptop with Windows 10 and 1920x1080 resolution ... and I also recently upgraded to Snagit 2018, but this is also a problem with Snagit 13.  When Snagit opens, it is too big! To fix the problem, I need to change the Scale and Layout setting on my Laptop to 100% which makes everything else really small on my laptop screen, but Snagit now is normal size on my two desktop monitors. NOTE: The Windows Display Settings dialog 150% is the Recommended setting for the Scale and Layout setting for my laptop display ... which makes other stuff on the laptop screen look normal, i.e., readable. FYI: changing the setting for Make this my main display has no effect on this problem. AFAICT, the only fix is setting the resolution of my Laptop display. (This may be too much info, but, you can kind of replicate this "too big" effect on a webpage by using the web browser's "zoom" feature, i.e., in Chrome, hit Ctrl-+ a few times to see the fonts and pictures grow. I was hoping there would be a similar "zoom" command for the Snagit app.)
Photo of ricksevans

ricksevans

  • 8 Posts
  • 1 Reply Like

Posted 11 months ago

  • 1
Photo of Ken Whitaker

Ken Whitaker

  • 40 Posts
  • 10 Reply Likes
Yeah, Rick, I noticed that too. Good advice on how you fixed it. It used to be that apps HAD to ensure that all windows (panels, dialog boxes, ...) had to fit within 800 x 600 and maybe that should now be 1024 x 768 but to see a 1920 x 1080 screen which is the default for most Windows laptops not hold the Snagit UI is horrible. I am hopeful that this can be prioritized to be corrected and I'm surprised that there hasn't been a massive user uprising. (Maybe there has been but Trump tweets have taken over the airwaves.)