Snagit 2018 video length limited to 5 seconds

  • 1
  • Problem
  • Updated 1 year ago
Hello folks,
I'm a real Snagit fan and I almost use it every day. A few days ago I updated to Snagit 2018 and somehow I can't make videos longer than 5 seconds anymore. I can successfully record a video of any length but in the Snagit Editor the video will always be cropped to 5 seconds.

What am I missing here? Am I doing it wrong?
Meanwhile I'm using Camtasia to record and share videos but it's a quite a lot more of a hassle for just some 20 seconds "this is how you do it" videos.

I'd appreciate any help on this.
Photo of joel

joel

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of Rick Grunwald

Rick Grunwald

  • 1253 Posts
  • 861 Reply Likes
I have seen this issue posted before with 2018. It is an issue that is not universal. If someone posts back with the answer today .. great. If not You can Submit a ticket
       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Chat Support Hours.

You can reach the “CHAT” Support Team for assistance from

 6:00 AM to 9:00 PM ET, Monday-Friday

 Saturday from 12:00 PM to 4:00 PM ET.
Photo of Joe Morgan

Joe Morgan

  • 5669 Posts
  • 2938 Reply Likes
Yeah, I just ran a test.

I don't usually use SnagIt for video.I use Camtasia. I recorded a 8+ video without issue and it opened in the editor in it's entirety.



If you have a graphic card, I would check it for updates.

It wouldn't hurt to check Windows for updates as well.

Regards,Joe
Photo of joel

joel

  • 2 Posts
  • 0 Reply Likes
Joe,

Thank you a lot for your test.

The reason I use Snagit for short videos instead of Camtasia is the ease of use: Just record and hit the share button. With Camtasia there's a bit more overhead invovled (I know, it's not that much, but if you make 10 to 12 short twenty seconds video a day to show users what to do it adds up).

I'm running the latest version of Windows 10 64-bit. Latest updates.
I'm using an nVidia Quadro M4000 with the latest driver.


Best regards,
~ Joel
Photo of Dubie

Dubie

  • 901 Posts
  • 681 Reply Likes
This was issue also in Snagit 12 and a fix offered. Supposedly all fixed in 13-on.
https://support.techsmith.com/hc/en-us/articles/226088987?_ga=1.266098506.491561552.1474131736

I would run a Snagit repair or do a clean re-install.
You may just have a corrupt file.

You can download the latest version here
https://www.techsmith.com/download/oldversions