SnagIt 2018 (Windows): Enable editor window to stay open after a capture

  • 1
  • Question
  • Updated 1 year ago
How do I enable the SnagIt Editor window to automatically open after a capture. Clicking the Open Editor button in the lower right corner after each capture is getting old. I know older SnagIt versions did this, but SnagIt 2018 for Windows seems to have lost this feature. Please tell me this didn't go away!
Photo of lynn.nichols

lynn.nichols

  • 7 Posts
  • 1 Reply Like

Posted 2 years ago

  • 1
Photo of Joe Morgan

Joe Morgan

  • 7137 Posts
  • 3873 Reply Likes
Preview in Editor need to be enabled.

Regards,Joe

Photo of Annik Stahl

Annik Stahl

  • 10 Posts
  • 1 Reply Like
I have tried setting All-in-One to Preview.. I've also tried deselecting preview. No matter what I do, once I capture an image using my preferred hotkey (Alt + 1), the capture just sits there until I click the Camera icon. There has to be another setting I'm missing to get the capture to auto-open in the editor?
Photo of Danny Wittenborn

Danny Wittenborn, Product Strategy Manager - Cloud Services

  • 18 Posts
  • 10 Reply Likes
@Annik, from the Screenshot that Joe included above, make sure you also have "Image" selected on the left side, instead of "All-in-one". If you leave it on "all-in-one" it will bring up the menu that asks what type of capture you want to do after dragging the region. If you switch it to "image" though, it should go straight to the editor after dragging the region. Hope that helps!
Photo of Annik Stahl

Annik Stahl

  • 10 Posts
  • 1 Reply Like
That did it. Thanks.
Photo of Paul

Paul

  • 1637 Posts
  • 1220 Reply Likes


Option 1 in presets
Photo of lynn.nichols

lynn.nichols

  • 7 Posts
  • 1 Reply Like
Thanks, Joe! Sometimes the solutions are right in front of your face. :)
I recently had my system re-imaged and had SnagIt 2018 installed and was looking in Preferences. Argh. Thanks again!
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 7131 Posts
  • 3871 Reply Likes
I wish more things were that simple, like finding my TV's remote control.
Photo of Paul

Paul

  • 1637 Posts
  • 1220 Reply Likes
In our house that's easy.  The dog's got it, again.
Photo of Joe Morgan

Joe Morgan

  • 7131 Posts
  • 3871 Reply Likes
That can't be good
Photo of Rick Stone

Rick Stone

  • 5510 Posts
  • 2600 Reply Likes
My dog has taught me things about my remote that I never knew were possible. She's small and steps on the buttons on the couch.
Photo of Paul

Paul

  • 1637 Posts
  • 1220 Reply Likes
In our house that's my wife's role.  You know how some TV remotes you can reset if you press the most extreme set of buttons. so formidable a combination that you need your nose to press one of them?  No need.  Just give it to my wife and she will wipe it it one simple act.

I routinely get called to her PC to fix a problem and ask in wonder, "How TF did you do that?  I have NEVER seen that before!"
Photo of Rick Stone

Rick Stone

  • 5510 Posts
  • 2600 Reply Likes
LOL, with my wife when there's a computer issue, it normally resolves itself at the moment I get up out of my chair to come look at it. My wife then always jokes about her "threatening" the computer with my presence.
Photo of Paul

Paul

  • 1637 Posts
  • 1220 Reply Likes
If computer misbehaves:

1. Start pressing keys randomly, rapidly and in increasingly complex combinations in the vain hope that chaotic inputs may correct the previous wrong input.
2. Ignore / shut down all error message boxes without taking a note of what they say
3. Even if you understood the message don't carry out the suggested action because it's just stupid
4. Slam the lid closed
5. Erase all memories of what you were trying to do when the error occurred
6. Use standard error report "It's not working"
Photo of Rick Stone

Rick Stone

  • 5510 Posts
  • 2600 Reply Likes
I think many of these are known as the following errors.

I D Ten T errors (ID10T)
PICNIC errors (Problem In Chair Not In Computer)
PEBKAC errors (Problem Exists Between Keyboard And Chair)
Photo of Dubie

Dubie

  • 1446 Posts
  • 1169 Reply Likes


And my computer is always doing this to me



:)
Photo of Dubie

Dubie

  • 1446 Posts
  • 1169 Reply Likes


And my computer is always doing this to me



:)
Photo of Dubie

Dubie

  • 1446 Posts
  • 1169 Reply Likes
Don't know why it posted twice ?

That's what happens when I try do to it myself. Damn computer.

:)
Photo of wilzons

wilzons

  • 2 Posts
  • 0 Reply Likes
I found this post while looking for how to turn that feature "off". It's a real nuisance if you need to do many screen captures in a row.

The setting confused me because it doesn't seem like a "preview" in the editor. After you capture, the image opens in the editor -- nothing "preview" about it. But I can see where "open capture in editor" is sort of clumsy label.

I turned it off, can now capture as many images as I want without the editor interrupting, so all is good.