Snagit 2019 and Mojave working slowly and crashing, taking 2 miniutes to actually engage!

  • 2
  • Problem
  • Updated 6 days ago
Snagit 2019 and Mojave working slowly and crashing, taking 2 miniutes to actually engage! 

OS Majave 10.14.1 
Snagit 2019.0.1 (94005)

crossfire take sometime to load up
Output source constantly being lost... currently I have three screencast!! See here:https://www.screencast.com/t/wvcuQhrql

It is getting worse that JING was and that is saying something. 
Photo of rob

rob

  • 5 Posts
  • 2 Reply Likes

Posted 2 months ago

  • 2
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 841 Posts
  • 212 Reply Likes
Hi,

Sorry about this! I would open a ticket with our Tech Support team (https://support.techsmith.com/hc/en-us) so they can look into why it's behaving like this for you.
Photo of rob

rob

  • 5 Posts
  • 2 Reply Likes
Crickeys I didn't even see the chat option... nothing like hiding it :) 
Photo of SactoBob

SactoBob

  • 128 Posts
  • 45 Reply Likes
I agree.. there should be a direct link from these forums. Anyway, click on Support in the top menu then choose Support on the resulting page. (Yes, silly as heck!) On the next resulting page, choose the product you need support for.
Photo of eglobal

eglobal

  • 3 Posts
  • 1 Reply Like
Rob- any insights on this? I'm having the same. Extraordinarily slow on capture and processing.
Photo of rob

rob

  • 5 Posts
  • 2 Reply Likes
NOne that I am aware off. I will check to see if I ever got any support. 

The issue had got better, but just in the last couple of days it has worsened again! 

Mojave seems to be a right nightmare.
Photo of jayrodin

jayrodin

  • 1 Post
  • 0 Reply Likes
Same issue - extremely slow on Mojave. I have to resort to the native Screenshot app, I remember when Snagit was just as fast  
Photo of SactoBob

SactoBob

  • 128 Posts
  • 45 Reply Likes
A thought from an old IT support guy: Based on the adoption rate of Mojave, there are probably many thousands of Snagit users that have updated AND most, like myself, apparently have experienced no problems related to Snagit. That usually would lead me to speculate that the few users with one similar problem, as here, have something in common with each other that most of the thousands don't have. The trick, sometimes very difficult, is to discover that common item.

Ideally, all those with the slowness problem should have open tickets and one TechSmith staff person should handle all of the tickets as one. Just saying.....
Photo of eglobal

eglobal

  • 3 Posts
  • 1 Reply Like
Totally agree. My current hypothesis is around antivirus/internet security. Is anyone else experiencing this that is running some AV software?
Photo of mibsfo

mibsfo

  • 2 Posts
  • 1 Reply Like
Terribly slow capture. Wish I had stuck with Snagit 12 instead of upgrading. :-(
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 841 Posts
  • 212 Reply Likes
Hi rob,

I missed the part about losing outputs the first time i read your post. That issue is fixed in our 2019.1.0 update.

As for the performance issues, are folks seeing this during capturing, processing, or editing? If it's during capture, are you using All-In-One or direct to Image?
Photo of mibsfo

mibsfo

  • 2 Posts
  • 1 Reply Like
I saw the performance issue during capture (more than 60 seconds to go from grey screen capture to the new capture window). I was using the All-In-One option. I switched back to Snagit 12 and it works flawlessly on Mojave.
Photo of David Cintron

David Cintron

  • 1 Post
  • 1 Reply Like
What if one has already updated to 2019.1.0 and still seeing the lag. Support ticket?
Photo of rob

rob

  • 5 Posts
  • 2 Reply Likes
I Can wait for 3 or 4 minutes waiting for the capture to start to work. 

I have moved back to using a Win10 machine over the holidays and back to Jing... instant fast and working!! 

Not looking forward to moving back to MojaveOS and Snagit..  I would never have moved to Mojave if I had known.  i would never have moved to Snagit if Jing hadn't stopped working with previous MAC OS...

it is all a bit of a bind really.
Photo of llovthomp

llovthomp

  • 1 Post
  • 1 Reply Like
Same here.  I wish I could switch back to the old version of Snagit I have never had problems.  I purchased Snagit 2019.  It needs a fix!!!
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 841 Posts
  • 212 Reply Likes
Hi,

If you're seeing freezing problems when capturing on Mojave, open up System Preferences > Security & Privacy > Automation and make sure Safari and/or Chrome are checked under Snagit2019 and SnagitHelper2019. We're also working on a fix so you won't have to do this in the future.

Photo of Luke Griffioen

Luke Griffioen, Employee

  • 841 Posts
  • 212 Reply Likes
Are you running into the capture freezing issue? If not, then it's not a problem that this is empty.
Photo of eglobal

eglobal

  • 3 Posts
  • 1 Reply Like
I have had those permissions enabled for both and still have the issue.
Photo of brianrush

brianrush

  • 2 Posts
  • 0 Reply Likes
Yes, I'm running into the capture freezing. It happens once I click the camera icon.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 841 Posts
  • 212 Reply Likes
Interesting. I would open up tickets with our support team. It looks like your situations are a little different from what other users are seeing.
Photo of rob

rob

  • 5 Posts
  • 2 Reply Likes
None of the solutions work, no matter what anyone says. 

I just downgraded to High Sierra -  All problems gone. 

My advice never never never upgrade to Mojave.