snagit 2020 blocks system audio

  • 1
  • Problem
  • Updated 6 months ago
whenever i start snagit with video capture, it blocks all system audio. So i am not able to hear any songs or get any alerts from my other softwares. 
Photo of traderkarnik

traderkarnik

  • 7 Posts
  • 0 Reply Likes

Posted 6 months ago

  • 1
Photo of slenehan

slenehan

  • 17 Posts
  • 6 Reply Likes
I haven't used Snagit's video capture feature but that makes sense to me. Much like on my phone, anything else that I may have been watching or listening to stops/pauses. The device cannot generate and record sound at the same time. I don't think that it would be any different on a computer.
Photo of traderkarnik

traderkarnik

  • 7 Posts
  • 0 Reply Likes
Not the same. Snag it is recording so needs to be passive listener. Its not outputting anything.
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 9084 Posts
  • 4787 Reply Likes
Do you have system audio enabled?



The Icon will be Green when enabled.

Regards,Joe
Photo of traderkarnik

traderkarnik

  • 7 Posts
  • 0 Reply Likes
Yes i do. However i cant hear any sound .
Photo of traderkarnik

traderkarnik

  • 7 Posts
  • 0 Reply Likes
Also, device should be able to input and output at same time. Almost all devices sre full duplex these days
Photo of traderkarnik

traderkarnik

  • 7 Posts
  • 0 Reply Likes
I am using headphines with mic. I was referring to someone comment above that we can inly do ine or other.

What i dint get it is why does snagit have to block the sound in order to record it.
Photo of Ed Covney

Ed Covney

  • 1042 Posts
  • 524 Reply Likes
" . . why does snagit have to block the sound in order to record it."

That's the natural order of things if you were using speakers (to prevent feedback).  Is the headset recognized by windows as a headset? A headset with mic are two devices, headphones and a mic- its NOT one device.

What does Windows see as far as you sound goes? [Control Panel], [Sound],
[Playback Tab] - I have to disable most devises listed, monitor speakers and virtual devices.
(You should see your headphones here and are default)
[Record Tab] - Again all but two are disabled. Disable, rt-click on the device, select disable.
(You should see your mic here it is also default)

Go back to the Playback tab, and leave it open when you record video in Snagit. Is Snagit turning off or changing the playback device?



(Edited)
Photo of traderkarnik

traderkarnik

  • 7 Posts
  • 0 Reply Likes
Headset gets recognized my windows alright. As soon as i exit snag it sound comes on.

Thats not “natural order of things” if i am recording a meeting then it implies i cant hear the sound,? Thats unacceptable.

Cisco and plenty other solutions record the meeting and sound is on. I get the feedback prevention part but this is just a bad design as a product if i am using headsets.
Photo of traderkarnik

traderkarnik

  • 7 Posts
  • 0 Reply Likes
Thank you for suggestion to disBle other playback devices. Although windows does srt my pkayback device to headset. . I will try that.
Photo of Ed Covney

Ed Covney

  • 1042 Posts
  • 524 Reply Likes
#1 - Re-read my post - its the natural order IF you use SPEAKERS. Would you want speakers pumping sound into your mic? That's called feedback.
#2 - What does Windows see [Playback tab], when you launch and start a Snagit video. Please follow the my instructions.