Snagit after Mojave upgrade

  • 1
  • Problem
  • Updated 1 year ago
I have always used the Mac key combination of Shift-Command-4 to grab screen captures. Before I upgraded to Mojave, I did the capture, and the image opened immediately in the Snagit editor. That was great.

Then I upgraded to Mojave. Since then, I use the same key combination to capture, but it takes about 7-8 seconds for the editor to open.

After working with TechSmith tech support for about a month, the tech support team decided that the issue was a change in Mojave in how it handles native Mac screen captures with the key combination of Shift-Command-4.

The workaround is to use Control-Shift-C. It is not a solution, but it is truly a workaround. I'd truly love to keep doing what I'd done for so long, but now I'll have to learn to use the Snagit key combo and ignore the crosshairs functionality.

Here's hoping both the new key combo and the ignoring of the cross hairs guess ing where I want to capture will become second nature and my new normal. But I'd rather avoid the change.

Support suggested I post here in the community so TechSmith can gage the number of folks who feel the same way. I'm glad we finally figured it all out.
Photo of ed.crabtree

ed.crabtree

  • 4 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1491 Posts
  • 383 Reply Likes
Hi,

I'm guessing what you were seeing before with the delay was that Mojave showed your screenshot down in the lower right corner of the screen for a few seconds before actually saving it. This can be turned off such that you can use Shift-Command-4 and still get it into Snagit right away.

If you do a Shift-Command-5 and click on the options dropdown, uncheck Show Floating Thumbnail

Photo of ed.crabtree

ed.crabtree

  • 4 Posts
  • 0 Reply Likes
Hi Luke,

Thanks! That does sound like the problem. Sadly, over the past month of troubleshooting the issue with the support team, somehow, Shift-Command-4 no longer opens the image in the Snagit editor--with or without Show Floating Thumbnail enabled. I don't know when Shift-Command-4 stopped working, but it was some time this week--and I don't know what I did to make it stop working. (Any ideas?)

I'm trying to get used to using Shift-Control-C. But it's slow going.

Thanks again. (And if you know what I did to stop Snagit from opening with Shift-Command-4, I'll be forever in your debt.
Photo of Tony Coty

Tony Coty

  • 141 Posts
  • 22 Reply Likes
I use Control-Z (my customized keys)  and have no trouble. Could you change your key selections? I'm asking because I wonder if the keys are in conflict with other shortcut  uses for the same keys.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1491 Posts
  • 383 Reply Likes
Hi,

Check to see if this setting is enabled:

Photo of rob

rob

  • 6 Posts
  • 0 Reply Likes
Hi
Did you try turning off the default Apple keyboard screen capture key shortcut?  I found this worked very well for me.  This is one of the settings in the Preferences panel under the Keyboard settings.  Could show the panel if I could figure out how to paste from Snagit into this window (-:
Cheers,
Rob



Photo of Tony Coty

Tony Coty

  • 141 Posts
  • 22 Reply Likes
Rob
Photo of ed.crabtree

ed.crabtree

  • 4 Posts
  • 0 Reply Likes
Thanks, everyone. Suddenly, today, things are acting more like I expect them to. I have no idea what happened, other than a reboot. Weird, really... especially since it's not the first reboot I've tried throughout the month or so I've been having the issue.

Thanks again!

(Edited)