Snagit Changes Screen Resolution - Can't Capture Parts of a Screen

  • 1
  • Problem
  • Updated 5 months ago
I use Snagit 2018 on a laptop connected with an external monitor.
Of late when I try to capture a screenshot, Snagit lowers the resolution of both the screens - everything on the screens look large.
Because of this, I'm unable to use Snagit to capture parts of a screen - the original intention behind buying Snagit was for this.


I've checked for updates and can confirm that there are no pending updates to be installed.
Photo of Rakesh

Rakesh

  • 3 Posts
  • 1 Reply Like

Posted 5 months ago

  • 1
Photo of Ed Covney

Ed Covney

  • 1050 Posts
  • 524 Reply Likes
What are the native / recommended resolutions of the monitors? What resolutions are they set to? Their scale?


Photo of Rakesh

Rakesh

  • 3 Posts
  • 1 Reply Like
Hi Ed,

Both the monitors are set to their recommended resolutions.

Laptop Monitor



External Monitor
Photo of davidlambert

davidlambert

  • 416 Posts
  • 155 Reply Likes
Snagit has no control over screen resolution. As Ed has pointed to, it is probably the Windows setting for display scaling.
Photo of Joe Morgan

Joe Morgan

  • 9167 Posts
  • 4822 Reply Likes

https://support.techsmith.com/hc/en-us/articles/203731388-Snagit-Windows-Snagit-UI-Appears-Too-Large...


Snagit (Windows): Snagit UI Appears Too Large or Too Small on the Screen, or Capture Magnifies the Screen

Last Updated:

October 08, 2019 06:13

Problem

  • The Snagit interface looks very large compared to other applications.
  • The Snagit interface looks very small compared to other applications
  • When starting a capture, the entire screen magnifies and zooms in.

Solution

This behavior is caused by either high DPI settings, or different DPI settings for different monitors. Before trying the suggestions below, make sure to have the latest update for the version of Snagit that is installed by clicking Help > Check for updates.

  Snagit 13 and Later

Set the DPI of all monitors to the same setting.

Windows 10

  1. Select Settings > System > Display.
  2. Set the scale size to the same setting for all monitors.
  3. Log out of Windows, and log back in for the changes to take effect.

Windows 8 & 7

  1. Press Windows+R on your keyboard to open the Run window.
  2. Type the following and click OK: control panel
  3. Select Display.
  4. Set the scale to the same setting for all monitors.
  • Windows 8: Select the box to Let me choose one scaling level for all my displays, and set the scale setting to the same setting for all monitors.
  • Windows 7: Set the scale to the same setting for all monitors.
  • Log out of Windows, and log back in for the changes to take effect.
  • ¬†

    Regards,Joe

    Photo of Rakesh

    Rakesh

    • 3 Posts
    • 1 Reply Like
    As suggested in the above responses, I tried to set the scaling to 100% on both the screens.
    This made the text on the laptop too small to read.
    Then restarted the laptop.
    Then changed the scaling on the laptop monitor to 125% (Recommended).
    This made the text readable again and the issue with Snagit seems to have gone too.
    So all sorted for now.

    Thanks, everyone!