Snagit does not support GIF or MP4

  • 6
  • Problem
  • Updated 1 month ago
I am using Windows 10 Pro version. After the last update, I am facing this difficulties of record video. It keeps telling me that Cannot open file, Snagit does not support GIF or MP4.... I uninstalled the software, and installed the new one. But still No Luck. Anyone know how to resolve this?
Photo of Wei Tan

Wei Tan

  • 1 Post
  • 0 Reply Likes
  • sad

Posted 1 year ago

  • 6
Photo of Rick Stone

Rick Stone

  • 4507 Posts
  • 2013 Reply Likes
Are you referring to the dialog you might encounter upon opening a file?



Assuming that's the case, have you checked the media to ensure it is within the dimensions specified in the dialog?

Cheers... Rick :)
Photo of andre

andre

  • 3 Posts
  • 1 Reply Like
I'm having the same issue. It happens every time I try to export any screen captured video as animated gif.
Yes, the video is definitely within the specified dimensions. Any thoughts?
Photo of Robert R.

Robert R., Online Community Admin

  • 1465 Posts
  • 414 Reply Likes
Hi Andre'

What version of Snagit are you running? Please right click on your Desktop and choose "Display Properties;" what options are selected in the Scale and Layout (specifically the Scale)?

-Robert
Photo of andre

andre

  • 3 Posts
  • 1 Reply Like
Version 13.1.4 (32bit) build 8008 - Set 12 2017
Not sure where to set scale and layout, I just click on the GIF button  and optimize for Screen Video.
The video size is usually a part of the screen, but always less than the snaggit maximum.
Photo of Rick Grunwald

Rick Grunwald

  • 1259 Posts
  • 865 Reply Likes
And if you need to shrink a GIF, grab a copy of Jasc Animation Shop. It is on the old version pages and you may have to download an old PaintShoip to get it as Jasc bundled it in with their main program
Photo of Peter Simmering

Peter Simmering

  • 1 Post
  • 1 Reply Like
Try it, I did. Like it, I don't. :-)
I recorded a video of 1044 x 712 in Snagit 13, saved it as mp4, it plays without error, but when I click on the Save as GIF icon, it asks what to optimize for, and no matter what I choose, at the end of the rendering to GIF (progress bar -> 100%), Up comes this errormessage that Rick Stone posted above.
Photo of Rick Grunwald

Rick Grunwald

  • 1259 Posts
  • 865 Reply Likes
Animation shop is old and not as intuitive as it could be although it is used to make some brilliant GIFs. It will load MP4s if I remember correctly and give you a gazillion frames. THe only thing I was suggesting is load it and then without mastering anyu editing, just save it as a GIF and be done with it

If it is choking a\with a smaller  resolution that advertised, it might be time to open a support ticket and let the staff help you deal with it. I have had "iffy" success with GIFS. over time

If you still have animation shop, be aware that it has a "frame culling" features that removes every 4th frame (configurable) to make the GIF much smaller often with little noticeable results. I am not touting Animation shop other than as a one horse tool for things that Snagit does not handle
Photo of nodarnspam

nodarnspam

  • 1 Post
  • 0 Reply Likes
why does it always open the editor? Won't it simply "stop" recording when i finish and save the mp4 to library? I cant get rid of this message
Photo of Almighty1

Almighty1

  • 11 Posts
  • 2 Reply Likes
It's caused by KLite Codec from what I read except is there a workaround?
Photo of Almighty1

Almighty1

  • 11 Posts
  • 2 Reply Likes
For me, like I read before when doing a search, the problem lies with SnagIt editor not working properly with K-Lite Codec installed.  When K-Lite Codec is uninstalled, Snagit editor will open the video correctly without the issue.  Uninstall and reinstall of Snagit doesn't fix the issue whether with version 13 or 2018. 
Photo of Scott

Scott

  • 1 Post
  • 1 Reply Like
In my case, it was having the LAME codec installed (used for Audacity).
Photo of rick

rick

  • 1 Post
  • 0 Reply Likes
I got this problem after the latest windows update. I don't see the k-lite codec on my system. I used this feature extensively and need it to work.
Photo of Rick Grunwald

Rick Grunwald

  • 1207 Posts
  • 808 Reply Likes
You can download it here
https://codecguide.com/download_kl.htm
USUALLY all you need is the basic pack
Photo of Joshua Talley

Joshua Talley

  • 5 Posts
  • 0 Reply Likes
Uninstalling LAME worked for me on build 2018.2.2 (64 Bit) (Build 2240)
Photo of firarottico

firarottico

  • 3 Posts
  • 0 Reply Likes
As a update, I figured out the problem and found the solution.
Basically, when one installs the K-Lite Codec pack, it will automatically open a page with tipss in the web browser saying for Windows 10, one should disable their codec for .mp4 and .mkv files which is what I did and it breaks playing back .mp4 files with the Movies & TV app as it will show some error instead of playing the file.  Once I reverted the changes so the .mp4 and .mkv is enabled instead of disabled, Movie & TV app works and I no longer see the error in Snagit Editor and the video is there for me to edit and playback.
I got this issue after the most recent windows refresh. I don't see the k-lite codec on my framework. I utilized this component widely and require it to work.
FetLife IMVU Canva
(Edited)