Snagit Editor 2019 - Hanging/Crashing ***FIX***

  • 6
  • Problem
  • Updated 3 weeks ago
  • (Edited)
Environment:

Dell Precision 5510
Windows 10 v1803
Snagit 2019.0.1
Plugable DisplayLink Docking Station
3 Monitors + Laptop Screen
Upgraded from Snagit 13 > Snagit 2019

Snagit Editor was hanging and crashing constantly. I could successfully capture a screenshot but when trying to view in Snagit Editor would crash the application. Loading Snagit Editor ad hoc produced same hanging and crashing symptoms. Uninstalled/Reinstalled/Repair did not resolve the issue. Also tried the following :

* Created DWORD registry entry - ForceSoftwareRendering to 1
* Compatibility Mode - Windows 7, Windows 8
* Windows Updates
* Run As Administrator
* Disable fullscreen optimizations
* Change high DPI settings
* Restarted computer
* Deleted/Re-named Datastore

The FIX:

Force Snagit Editor to use Integrated Graphics processor in lieu of High-performance NVIDIA Processor

Instructions:

1) Close Snagit and Snagit Editor
2) Open NVIDIA Control Panel (in systray). Under [Select a Task...] > [3D Settings] > [Manage 3D settings] > [1. Select a program to customize:]
3) Select: [Add]
4) Browse to and select snagiteditor.exe (C:\Program Files\TechSmith\Snagit 2019\) then click [Open]
5) Under [2. Select the preferred graphics processor for this program:] click the down arrow and select Integrated graphics
6) Click [Apply]

Done. No need to reboot. I spent many hours perusing the web trying to find a solution to no avail. The above worked for me. No crashes or hanging since. 

Hope this helps someone else. 
Photo of cpubuff

cpubuff

  • 1 Post
  • 0 Reply Likes

Posted 10 months ago

  • 6
Photo of Rick Grunwald

Rick Grunwald

  • 1418 Posts
  • 979 Reply Likes
Thanks for posting this for others to find
Photo of Ed Caggiani

Ed Caggiani

  • 1 Post
  • 1 Reply Like
Didn't work for me. SnagIt Editor 2019 still won't open on my Surface Book :-(
Photo of vevans

vevans

  • 1 Post
  • 0 Reply Likes
Same here. I'm using a Surface Book. SnagIt will open for a second and then close. I'd love to follow these instructions but not sure how to do step 2. I'm stuck on "open NVIDIA control panel (in systray)."
Photo of scott.thompson

scott.thompson

  • 1 Post
  • 0 Reply Likes
I was getting extremely frustrated with 2019 until I read this post.  Thank you so much for sharing your experience.  Seems to be working great now, after this "fix"!!!
Photo of msmith1789

msmith1789

  • 1 Post
  • 0 Reply Likes
I have also been having the same problem, but I dont have Nvidia graphics card. Mine is Intel.

So for those on Intel, follow these steps on Windows 10

  1. Right click desktop
  2. Click Intel Graphics Settings
  3. The Intel Graphics control panel will now appear - you should see 3D - Click 3D
  4. Click Browse
  5. Navigate to C:\Program Files\TechSmith\Snagit 2019\Snagiteditor.exe - Click OPEN
  6. Do the same for Snagit - C:\Program Files\TechSmith\Snagit 2019\Snagit.exe - Click OPEN
  7. Within the Intel Graphics Control Panel - click SCAN
  8. I also turned off Multi Sample Anti-Aliasing for both Snagit executables (The 2 mentioned above)

So far, I have seen instant improvements where before the Snagit Editor was crashing.

Thanks to Original Poster for sharing their experience. Hopefully my edit helps people with Intel graphics card.