Snagit Editor dialogue box too small to use

  • 1
  • Problem
  • Updated 1 year ago
Has anyone had the problem of dialogue boxes appearing in a frame too small to use? I don't know how to rescale them to show the contents and input fields.

I am using Snagit 10 with a Windows 8.1 touch screen laptop. I have tried to change my screen resolution from the recommended 3200x1800. It did not work. (And it would not have been a good solution anyhow!)


Photo of tino_go

tino_go

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of Robert R.

Robert R., Online Community Admin

  • 1639 Posts
  • 526 Reply Likes
Hi tina_go and welcome to the community!

Unfortunately the issue most likely stems from Snagit 10 not being compatible/supported on Windows 8 (you can see here for a list of versions and what operating systems they are compatible with). Given the age of Snagit 10 vs. modern hardware (like high-DPI screens) and modern operating systems it will likely be difficult to have Snagit 10 look/behave as it did on a supported/compatible OS like Windows 7 or Windows XP. With that in mind, have you tried the Snagit 2019 trial yet?

To confirm, did you set the resolution to 3200x1800 or did you set the DPI scaling to 100%? The issue looks more like a DPI scaling issue than a straight resolution issue. If you right-click on the desktop and go to Display Settings (Windows 8 may read as "Properties") then set the Scaling to 100%, then restart/re log in to the computer, do you have the same issue?

-Robert
Photo of jasons

jasons

  • 331 Posts
  • 103 Reply Likes
Have you tried zooming in until you can work with them?