Snagit Editor opens every time I logon to my Mac

  • 2
  • Problem
  • Updated 4 years ago
For some reason the Snagit Editor opens every time I log on to my Macbook Pro.  The version of Snagit is 3.2.0 although it happened with whatever was the previous version for the Mac, too. 

I suspect it's probably related to the fact that I selected to 'Always keep Snagit running in the background'.  Even so, I think it's reasonable to expect that it wouldn't open the Editor window every time you log on.  Maybe I'm missing something or maybe my installation is broken?  I don't recall it doing this before the last version or 2 but I can't be 100% sure what version was the first I installed on the Mac.
Photo of jproos

jproos

  • 6 Posts
  • 1 Reply Like

Posted 6 years ago

  • 2
Photo of Glenn Hoeppner

Glenn Hoeppner, Employee

  • 1884 Posts
  • 370 Reply Likes
Hi jproos,

Even with "Always keep Snagit running in the background" enabled, this is not the behavior you should be seeing.

Unfortunately, I don't have any ideas for you, but I'm confident our Tech Support could help. You can open a ticket at https://support.techsmith.com. We are generally able to respond within one business day.

-Glenn
Photo of Aespire

Aespire

  • 1 Post
  • 0 Reply Likes
I am having this problem as well, since version 3.3.5 was installed.
Photo of Glenn Hoeppner

Glenn Hoeppner, Employee

  • 1884 Posts
  • 370 Reply Likes
Please see this support topic:
https://support.techsmith.com/hc/en-us/articles/205336768-Snagit-Mac-Start-at-login-with-Editor-mini...

If that doesn't help you out, open a ticket at that same site. Be sure to mention what you've already tried.

-Glenn
Photo of brianmt68

brianmt68

  • 26 Posts
  • 8 Reply Likes
I noticed when I installed Camtasia that in the installation window it shows a option that says " open camtasia upon start up." I thought it was a useless thing to even ask so I left it unchecked. Not sure if this is the same issue but I just remembered it. The same option appeared for the "camtasia player"
Brian.

This conversation is no longer open for comments or replies.