Snagit editor running in background with high CPU usage

  • 2
  • Problem
  • Updated 5 days ago
I have Snagit automatically starting when Windows starts (Windows 10). Without even using Snagit, Snagit Editor starts running in the background and is using around 20% of my CPU. I have to run the task manager and end the program to stop it from running. I am using the latest 2018 version of Snagit. Snagit Editor also fails to load up properly when I open it not showing all the icons that would normally be available. 


 
Photo of cdfildes

cdfildes

  • 3 Posts
  • 1 Reply Like

Posted 2 months ago

  • 2
Photo of jasons

jasons

  • 156 Posts
  • 47 Reply Likes
Photo of thohun

thohun

  • 1 Post
  • 0 Reply Likes
We have seen this issue on our Windows 10 VMs since version 2018.1.0 and have upgraded a few times since then with no luck. Are you still seeing this?
Photo of kuchar

kuchar

  • 4 Posts
  • 1 Reply Like
I'm getting the same issue.... running version 18.2.2 build 2240 (64 bit). The process is constalty using around 30% CPU causing fans to spin up, as long as the editor window is open somewhere. When I close the editor window, the usage drops to normal (nothing).
Photo of cdfildes

cdfildes

  • 3 Posts
  • 1 Reply Like
I am afraid tech support couldn't fix my issue - they did try really hard though. My workaround was to change the scale override under properties and apply the scale override to the "system" setting, not the application setting. This has fixed my problem. I run a 4K Lenovo Yoga 920 laptop and I believe it is the 4K that is causing the problems, well that's my theory. 
Photo of kuchar

kuchar

  • 4 Posts
  • 1 Reply Like
Thanks for the suggestion. I changed the setting and tried again, sadly it didn't help...



I'm running two screens (built in 1920x1080 and external 1680x1050), using a Lenovo Thinkpad T480.
Photo of cdfildes

cdfildes

  • 3 Posts
  • 1 Reply Like
Just out of interest what happens if you minimise the Snagit Editor window so you can still it but not full screen?
Photo of kuchar

kuchar

  • 4 Posts
  • 1 Reply Like
Thanks for all the suggestions! It didn't help either.either :( 
Photo of David Howell

David Howell, Employee

  • 97 Posts
  • 31 Reply Likes
In Task Manager, if you open up the Snagit Editor process (click on the arrow to the left of the name), it will show any child processes (i.e., any applications which were internally started by the Editor itself). When the CPU is running at 20% or so, is there anything else listed? It may be the updater process (tscupdclt.exe) which is checking for updates. There was reported as a problem a while back: https://console.getsatisfaction.com/techsmith/conversations/why-is-techsmith-updater-using-so-much-m...
I think there was a maintenance release of Snagit 2018 that fixed this. I wonder what exact version of Snagit you have...
Photo of kuchar

kuchar

  • 4 Posts
  • 1 Reply Like
I'm running 2018.2.2 64bit Build 2240. 

The CPU usage stopped to happen.... I also just got an extra 8GB RAM stick installed (like 1 hour ago).

So either it was the scaling setting or the extra RAM (somehow?), but I'm not getting the high CPU usage anymore. It was consistently happening for the past weeks.

I'll report back if it starts to happen again :)

Thanks for the help and suggestions!