SnagIT editor will NOT Maximize

  • 4
  • Problem
  • Updated 2 months ago
  • Acknowledged
I have owned SnagIT for several versions now and in the past several versions clicking the maximize button will NOT maximize the editor.  This is a standard Windows function for all windows/applications and I can't understand why this particular feature has been broken for so long.

When working on large screenshots, it is natural to want to maximize the editor and not being able to do that originally was just an annoyance but now that it has been uncorrected for several versions of the application, it is becoming a frustration.

One would think that it wasn't corrected in the second version to have the issue because folks might have provided feedback at the end of a development cycle but by the third and fourth version releases it is becoming all too clear that the developers are not intending to fix the issue at all.  :(

I love this product as do many other folks who continue to pay for it and the upgrades.  It only seems fitting that the developers would show their appreciation of their customers' loyalty by fixing the damn thing so it works as it should.

Thanks
Photo of Edward D Stevens

Edward D Stevens

  • 1 Post
  • 0 Reply Likes

Posted 7 months ago

  • 4
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2894 Posts
  • 647 Reply Likes
Hi Edward,

I'm sorry things aren't working as expected.


Since this seems to have been a consistent issue, have you submitted a ticket at any point to our Technical Support team to see if they can find out what is going on?

I haven't heard that this has been an ongoing issue, in general.

Overall, at this point, it seems your best course of action would be to get with our support team and get their take on it.

This is a free service:

https://support.techsmith.com/hc/en-us

Kelly
Photo of rsporn1014

rsporn1014

  • 17 Posts
  • 9 Reply Likes
Maybe I'm the odd case but, I have not had any issue with maximizing the editor window on any Snagit version I've had
Photo of Ed Covney

Ed Covney

  • 398 Posts
  • 257 Reply Likes
Ditto.
Photo of Rick Grunwald

Rick Grunwald

  • 1418 Posts
  • 981 Reply Likes
This has been a chronic issue for a whole now. I brought it up but no traction and for me it is a moderate annoyance 
But @Kelly ... it has been an issue for quite a while
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2894 Posts
  • 647 Reply Likes
Hi,
So, I inquired about this issue with our Technical Support team and learned:
This is a bug currently on our backlog. The team sees this issue come up once in a while and they are currently investigating whether this has to do with multi monitor setups. In particular:

1. It could be Editor won't maximize on one of the monitors but works on the others.

2. Or, if a setup with multiple monitors that has the Windows Task bar set to auto-hide is causing the issue.
Overall, we don't have a lot of data to go on right now to find out why this is happening.

If you are having this trouble, perhaps give us your information pertaining to multiple monitors so we can see a pattern.
You can also try to testing to see if you can maximize on any of your monitors OR turn off the task bar setting in #2 above to see if this fixes the issue for you.

Thanks.
Kelly
Photo of Rick Grunwald

Rick Grunwald

  • 1418 Posts
  • 981 Reply Likes
Single monitor here and it is a constant issue ... every time I start up.
Photo of kelzipan

kelzipan

  • 7 Posts
  • 1 Reply Like
Dual external monitors (laptop lid closed.)  Just noticed today.  Editor maximizes on main monitor but not secondary.  Also had taskbar set to auto hide in desktop mode on Win 10 laptop.  Turned off auto hide and the window maximizes on secondary monitor.  I'm keeping auto hide on but it is annoying I can't maximize on my secondary monitor just because I like my taskbar auto hidden.  Hope they fix this.  I'm on v13 so I'm at least 1 version behind.  I can also maximize on primary monitor, use Win key + Shift + left arrow to move maximized window to secondary monitor.  Once the editor is on the secondary monitor, I can double click the title bar to restore it down to a smaller window size but now it cannot be maximized unless I move it back to my primary monitor.  -_-  Please fix.  I can use the workaround but it's a little annoying.  Thanks for listening.  Glad I found this article.