Snagit Freezes Whole PC "Lately"

  • 1
  • Problem
  • Updated 4 days ago
Snagit on my PC suddenly has changed behavior. Now, after I select the entire screen I want to video, initiate capture, and the screen darkens, I lose all function and a little circle of dots saying "Initializing" perpetually is shown on my screen. I even let it go all nite once to see if it was having trouble updating or something. That didn't change what its behavior was. So I deleted and reinstalled the program. I was asked to select from a list of Serial Numbers, chose the first one thinking it must be the most recent and ended up activating an older version. That didn't have the problem for several days, but today it is freezing my compute. I can't use Task Manager to clear the program but all I can do is "Sign Out" to unfreeze my entire PC, but upon signing back in and starting the capture over, the same thing happens. What am "I" doing wrong?
Photo of Bill

Bill

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 week ago

  • 1
Photo of jasons

jasons

  • 172 Posts
  • 53 Reply Likes
You are obviously using a nulled or cracked version which I'm sure Techsmith is not going to support or even approve of.

When mods read this thread the entire thread should be deleted.
Photo of Bill

Bill

  • 3 Posts
  • 0 Reply Likes
Nope. Bought three of them last couple years. I have a list of serial numbers in my TechSmith account and was asked to choose from the list when I reinstalled it. The 2018 version is the only one I had the problem with. My PC at home is version 13-something and is working fine. I'm not sure what made you leap to the conclusion you did, but you're way off base and should apologize for calling me a thief.
Photo of jasons

jasons

  • 172 Posts
  • 53 Reply Likes
O... OK .

My apologies.

You could note which versions go with which number for future reference and try reinstalling with one of the other numbers (making note of version of course) o see if it is the latest

Again, my apologies.


Photo of Paul

Paul

  • 1200 Posts
  • 933 Reply Likes
If you look at your account online, it tells you which version is related to which licence
Photo of Bill

Bill

  • 3 Posts
  • 0 Reply Likes
Thanks. At the time I didn't see that connection.
The version I installed is working "fine" so far...
Like I say, I admit this one is weird because I've had no problem getting Snagit to be dependable now for years...I'll keep working and thanks to you both for trying to help out.