Snagit helper problem after upgrade to 2019.1.1

  • 8
  • Problem
  • Updated 7 months ago
every time i open my laptop I have a window that wants  me to give some security access to snagit helper, asking for a password ( my  computerlogin doesn't work, so maybe snagit account?). When I select 'deny' button, I  the same screen repeats numerous times and I keep clicking deny, and it reappears.  maybe 6 or more times before finally disappearing.  What is this trying to access and why?  obviously buggy.  
Photo of wheel

wheel

  • 3 Posts
  • 0 Reply Likes

Posted 10 months ago

  • 8
Photo of george

george

  • 106 Posts
  • 22 Reply Likes

Do have a different password for your Snagit account?  Perhaps that is what it is expecting.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
Hi,

Sorry about this, do the alerts mention HockeyApp? If so, you can disable this 3rd party library by turning off "Send anonymous crash reports" in Snagit's general preferences. 
Do you know what version you upgraded from? Nothing was changed with this in 2019.1.1 so I'm curious if you upgraded from a somewhat older version.
(Edited)
Photo of wheel

wheel

  • 3 Posts
  • 0 Reply Likes
I upgraded from 2019.1 I'm pretty sure.  i'm attaching the pop-up window.  I restarted and finally was able to enter my laptop login password and choose allow and the window closed.  I still don't know what it is trying to do and why it needs a password.  is this just a help app, like the ' microsoft paperclip' ?  why does it need my login password?  thank you



Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
Hi,

MacOS has a security feature called the Keychain that allows apps to store passwords securely. What this dialog is there for is the app's code has changed, so macOS is asking you if you want to allow this new version of Snagit to access all the passwords that the previous version had stored in the keychain. I hope this helps!
Photo of merlinEU

merlinEU

  • 3 Posts
  • 0 Reply Likes
in my case i went into the keychain and deleted all keys with labeled snagit, buena suerte
Photo of wheel

wheel

  • 3 Posts
  • 0 Reply Likes
Why does Snagit need access to passwords.  I only have the on-line snagit account that I would make sense that the softneeds, and it should already know it.  ?  biggest problem is that if I enter my mac login password and click 'allow',  the windows keeps appearing.  IF i select 'Deny',  the window keeps appearing multiple times, up to 6 or more.  this is definitely some BUG, I think. 
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
When an application quits, it has to save all of the information it needs to remember, including passwords. If these are not stored in the keychain, anyone can read that information. As for the dialog appearing multiple times, there appears to be something wrong with how macOS handles this, but we'll take a look and see if we can streamline how we access this information to hopefully eliminate those dialogs.
Photo of iomarnix

iomarnix

  • 2 Posts
  • 0 Reply Likes
Same problem here. Am I right that the dialog is not asking for a user password (such as the mac login or the apple-ID) but for a password generated by the Snagit program itself? In the Keychain login folder I can find two such login password items, both created on the day that I upgraded to Snagit 2019.
I'm using Snagit 2019.1.1 (94025) on Mojave 10.14.3 
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
So the password that you type into the dialog would be your Mac login, but that gives Snagit access to your previous Snagit password that it had stored (and does not give Snagit your Mac password). If you enter your password and choose Always Allow, then the dialogs should stop showing up. I hope this helps!
Photo of biyahero

biyahero

  • 2 Posts
  • 0 Reply Likes
That works!  I kept trying to figure out how to access my keychain, but when I saw what you wrote I just entered my Mac Login Password and chose Always Allow and that dialog box hasn't appeared since!  Thanks.
Photo of iomarnix

iomarnix

  • 2 Posts
  • 0 Reply Likes
Luke, I did as you suggested (enter my mac's login and choose Always Allow) and there was no more SnagitHelper dialog at startup this morning. Thanks!
Photo of biyahero

biyahero

  • 2 Posts
  • 0 Reply Likes
Luke, I thought it worked too, and it seemed to for awhile, but the next time I shut down the computer and restarted it, the problem was back!  So I figured out how to access my keychain (in Mojave Launchpad, Other, Keychain) and found there  were many entries from old versions of Snagit:

So I deleted all of them except 3 lines that referred to Snagit 2019 and the problem seems to have really gone away for good now.

In my case I left these entries:
com.techsmith.snagit.capturehelper2019.HockeySDK
com.TechSmith.Snagit2019.dropbox.authv2
com.TechSmith.Snagit2019.HockeySDK

Now it works fine qnd no more dialog boxes!
(Edited)
Photo of wetherington13

wetherington13

  • 4 Posts
  • 0 Reply Likes
Luke, I also did the Always Allow and it worked until I did a reboot. Then the annoyance was back, and possibly worse. I'm trying what @biyahero did now. 
Photo of wetherington13

wetherington13

  • 4 Posts
  • 0 Reply Likes
Deleting keychain files, except those referring to Snagit 2019 did not work for me either. Any other suggestions?
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
Hi,

I would open a ticket with our Tech Support team, they should be able to walk you through some other options.
Photo of smillion

smillion

  • 1 Post
  • 0 Reply Likes
Also seeing this issue on mac running 10.14. Opened a ticket. This is super annoying, please fix!
Photo of gwebb88

gwebb88

  • 3 Posts
  • 1 Reply Like
I'm getting the same thing dialog box every time I connect to the internet. I just upgraded to 2019.1.1.
Photo of gwebb88

gwebb88

  • 3 Posts
  • 1 Reply Like
This is getting real annoying. Now I have to either enter my password 5 times or deny my password 5 times every time I connect to the internet. I deleted the program and reinstalled it and that's when it changed from 2 times to 5 times.

Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
Official Response
Hi all,

We're working on tracking down what caused this.
In the mean time, here are a couple of things you can do to reduce the number of dialogs that show:

1. sign out of Snagit
2. turn off sending anonymous crash reports

Photo of pintveld

pintveld

  • 1 Post
  • 0 Reply Likes
Hi Luke, I also have the same problem. All of the given options by Snagit team members unfortunately do not solve the issue. Is there any outlook on a solution for this? It really becomes to be a big annoyance now and I'm quite close to uninstalling an app which I otherwise use with pleasure.
I get the pop-up every 20 minutes or so and I keep hitting 'deny' on average 3 times before it actually stops prompting for that moment.

I'm running Snagit 2019.1.2 for Mac. (No problems at all when running Snagit 2019 on my Windows machine for work btw). 

Hope this gets fixed soon. 

/Peter
(Edited)
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
Hi,

We do hope to have a fix out soon, in the mean time if you enter your password and hit "Always Allow", then it should hopefully not ask quite so many times in the future. This is safe to do, you're basically telling macOS that Snagit is allowed to access passwords that an older version of Snagit stored.
Photo of debra

debra

  • 3 Posts
  • 0 Reply Likes
Hi Luke

I did do what you suggested and it does keep coming back still.   It might not be as often though.   At least your team is aware of it and working on it.
Photo of gwebb88

gwebb88

  • 3 Posts
  • 1 Reply Like
The dialog box shown above has three options: Always Allow, Deny, and Allow. By clicking on "Always Allow", no more dialog boxes have popped up. Yay!

Photo of jim

jim

  • 1 Post
  • 0 Reply Likes
Also running SnagIt 2019.1.1 and getting these popups every time I start my mac. Very annoying. Can't even locate the entry in Keychain Access, so I relly do not know what password to enter in the box.

Any solution for this coming soon? Otherwise i'll just have to uninstall SnagIt and go with the built-in capture functionality in mac.

(Edited)
Photo of symphonix

symphonix

  • 1 Post
  • 0 Reply Likes
This is over a month old. Have you not figured out what needs to happen to fix this? I just bought snagit on Friday, rebooted and this AM I can't get the damn box to go away. What will fix this?
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
Hi,

A few posts up I have an official reply that has some steps to reduce the number of dialogs you're seeing. We are working on a fix, but it's not quite ready yet.
Photo of debra

debra

  • 3 Posts
  • 0 Reply Likes
Happening to me also.   Originally I didn't have the current MAC version needed and it installed NFTS.   I upgraded and deleted the NFTS app, still getting popups for that and Snagit 2019.    Very annoying.     I bought the Camtasia Snagit bundle and had the annoying popups since then.    On the plus side,  Camtasia is really nice and reliable.  Hope the annoying popups are fixed soon.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1255 Posts
  • 320 Reply Likes
Hi,

We just released a 2019.1.3 update that should greatly reduce the frequency of these dialogs. You may still see 1 or 2, but if you enter your password and choose "Always Allow", then they shouldn't come back at all.