SnagIt screen capture takes 10+ seconds to trigger

  • 2
  • Problem
  • Updated 3 weeks ago
Over the past couple weeks, I've no idea what's changed.

But when I run Print screen trigger or issue a screen capture from the system tray icon, it takes over 10 seconds, sometimes like 50 seconds, before the screen capture comes up.    
Then after I actually take the screenshot (drag the box over a region), it takes just as much time to then bring up the palette that has me confirm to capture the image or record a video or cancel, etc.

I've had to resort to using Snipping Tool just to get through the day. My job is heavily reliant on screen capturing and this is losing me so much time and money for my business and clients. 

A month ago I reformatted my computer completely to fix the issue and it resolved but then it's back to normal. SnagIt was the last thing I installed as well to be sure I wasn't conflicting with anything (I have basic apps like Office). I don't have any other screenshot or recording software on my computer. 

Snagit 2019.11 (64 Bit) (Build 2860) - 2-11-2019
Photo of John Quile

John Quile

  • 2 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 2
Photo of JL1

JL1

  • 291 Posts
  • 131 Reply Likes
Did you submit a ticket to TechSmith Tech Support? This is just a users' forum.
Photo of Ed Covney

Ed Covney

  • 413 Posts
  • 263 Reply Likes
John - When the capture window opens, check below and just to the left of the capture button, do you have "Time Delay" turned on?
Photo of John Quile

John Quile

  • 2 Posts
  • 0 Reply Likes
Hi Ed,
No there is no time delay on. I've used that for Camtasia on a separate computer but not for Snagit. It's just a lag that's going on that's random. My resources are fine. SSD plenty of speed and plenty of RAM/CPU. 
I have 2 other third-party screenshot tools that I tried separately that are working instantly as well in addition to the Windows snipping tool. 
(Edited)
Photo of KTurkes

KTurkes

  • 6 Posts
  • 0 Reply Likes
I have the same issue with 2019.1.3 version. Video capture starts around after 30 seconds, counter is not counting time properly too. Screen capture takes around 10 seconds or more.

I have no issues with Onenote clipping or Windows snap tool.
Photo of Rick Stone

Rick Stone

  • 5583 Posts
  • 2646 Reply Likes
Have you tried temporarily disabling any malware or anti-virus software?
Photo of KTurkes

KTurkes

  • 6 Posts
  • 0 Reply Likes
Yes, even tried disabling Windows Defender services. I have latest graphic drivers and all Windows updates too.

Windows default capture (Windows key + Shift + S) does it instantly, but Snagit is unresponsive. 

While writing this message I took a screenshot, still Snagit didn't show my capture...
Photo of Robert R.

Robert R., Online Community Admin

  • 1592 Posts
  • 493 Reply Likes
Hi KTurkes!

How many monitors do you have connected to the computer? If you open Snagit 2019's Capture Window then go to File - Capture Preferences - Capture tab and set it to "Simplified Crosshairs" does that help with performance?

See:



-Robert
Photo of KTurkes

KTurkes

  • 6 Posts
  • 0 Reply Likes
Hello

I have only one monitor, ASUS PG278QR, running 2k resolution with 165hz. Simplified cursor made process a bit faster but not good enough.
Photo of Robert R.

Robert R., Online Community Admin

  • 1592 Posts
  • 493 Reply Likes
Hi KTurkes,

As a test, can you switch the 165Hz monitor down to 60Hz then restart Snagit and see if that helps the performance at all?

-Robert
Photo of KTurkes

KTurkes

  • 6 Posts
  • 0 Reply Likes
On 60hz it is a lot faster, it took like 2-3 seconds to get a screenshot and open editor but when I turn it back to 165 wait times were back.
Photo of Robert R.

Robert R., Online Community Admin

  • 1592 Posts
  • 493 Reply Likes
Hi Kturkes;

Thanks for testing that; I'm reaching out to some internal teams to see if we can recreate the issue on the higher hertz monitors and will get back to you as soon as I hear back from them on the subject. While I personally believe the issue is related to your higher hertz monitor at the higher resolution, I cannot say for certain that is the cause (it's simply a theory). Once I know more, I'll let you know.

-Robert
Photo of Ed Covney

Ed Covney

  • 378 Posts
  • 242 Reply Likes
This will sound like it came from left field, but . . .

One problem that I see often especially with the advent of SSDs, is hung "caches". Windows doesn't flush SSDs, so its up to the drive to flush itself. Mark Russinovich, of Microsoft has a utility "sync.exe" (or sync64.exe) among his "SysInternals" suite (all free), which flushes drives for you. Two caveats, you must run it as administrator and from a drive other than the one you're flushing. Running it from a thumb drive or SD card would be fine

To make sure its always run as administration, rt. click the exe file name, then properties tab and X in the "Run as ad..." box. If you run it from more than one location, fix all copies.
I keep a shortcut on my desktop, to flush all my SSD drives and one mechanical - just for reference.

I just did mine and it took about 3 seconds to flush C:\, then D:\, E:\ and F:\ were instantaneous.  Repeated it and all were done in a flash (I had a flash flush!).
Photo of KTurkes

KTurkes

  • 6 Posts
  • 0 Reply Likes
I have Samsung 970 Pro 1TB SSD, I don't think a flush is necessary. There is also weekly trim going on. Crystal Disk Mark says I have 3,2GB/s read, 2,7GB/s write speed.

It is supposed to be a simple screenshot taking. It should run on simple machines too.
(Edited)
Photo of KTurkes

KTurkes

  • 6 Posts
  • 0 Reply Likes
More than a month passed and still Snagit is very slow and unresponsive. I think I will switch to Windows 10's Snip & Sketch. It doesn't matter which resolution or refresh rate or hardware I have, it responds very quickly, unlike paid program Snagit.
Photo of Robert R.

Robert R., Online Community Admin

  • 1599 Posts
  • 500 Reply Likes
Hi KTurkes;
Have you opened a ticket with our Technical Support team as they would be the best method of addressing performance issues with Snagit?

-Robert