SnagIt Spotlight effect no longer working with multiple selections?

  • 3
  • Question
  • Updated 8 months ago
Hi everyone,

I've been using Snagit on a daily basis for more than 10 years now and kept upgrading quite regularly my software. This morning, I took a screenshot where I needed to highlight few areas and went naturally selecting several areas (using Shift + rectangle selection tool) and went to use the Spotlight effect... willing to blur the non selected area and dim it as well.

For some reasons I really have the feeling that this was working with multiple selections since quite some time now... but this morning, I got suprised to see that the entire image was getting dimmed and blurred entirely and ignoring my selection...

I could not believe my eyes.

Could someone from TechSmith reply here and confirm this is indeed expected behavior, confirm that indeed, multiple selection within SnagIt Editor does not allow the "Spotlight" effect and only works on one single selection?
As this always been the case? Have I dreamed about this feature and finally always made a single selection without really noticing it?

I was about to create an incident but I'll wait for more feedbacks on that one.

Thank you guys.
Kind regards,

PS: Windows 10 (Professional 64 bits), SnagIt 13.1.5 (32 bits) (Build 8014) - Nov 3 2017
Photo of Nicow

Nicow

  • 16 Posts
  • 5 Reply Likes
  • confused

Posted 2 years ago

  • 3
Photo of Mark

Mark

  • 23 Posts
  • 4 Reply Likes
@Rick Stone: What version are you checking with?  Is it also SnagIt 13.1.5?

I get the same problem as @Nicow and I'm on the same version - I know how it should work, but it's not working like that.  I have found that if you change/tweak the 'zoom' slider a couple of points and then change back the multiple selection is recognized which avoids restart processes etc. and hence is slightly better.  Demo video here:
Photo of Rick Stone

Rick Stone

  • 5359 Posts
  • 2534 Reply Likes
Yeah, my bad. I must have spaced off before getting to the bit where the version was mentioned. After seeing the comments about always regularly upgrading, I kind of assumed that Nicow was using the latest 2018 release. My bad.
Photo of Nicow

Nicow

  • 16 Posts
  • 5 Reply Likes
@Rick, indeed, I could have... but I did not upgrade to the latest version yet... I usually take my time before upgrading.

@Mark THANK YOU SOOOO MUCH ! So I was not dreaming, it used to be working but in a way or another, it got screwed at some point. Thanks for the tip.

@TechSmith, to me, this seriously looks like a glitch it would be good to fix for those still on the same version as I am, don't you think?
Photo of ScottLufkin

ScottLufkin

  • 4 Posts
  • 0 Reply Likes
Thanks @Mark this seems to be a workable solution for now!