SnagIt takes ages to load

  • 1
  • Question
  • Updated 4 months ago
I think every time I open Snagit, it is downloading from iCloud. And then when it finally opens (after an hour or so) the screen capture works as expected, but then the Editor takes another 1-2 hours to open. Presumably again downloading from the Cloud. Any ideas on how to resolve?
Photo of Malcom Brown

Malcom Brown

  • 4 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of SactoBob

SactoBob

  • 165 Posts
  • 61 Reply Likes
By default, Snagit files are saved locally. As far as I know, iCloud could only get involved if the save path was changed to save to iCloud. Please check your Snagit prefs to see what path you have set.

It's under the Advanced tab. Part way down, your current save path is displayed. You can change it by selecting the Choose button. See the screen shot. (The blurred part is just HD name.) The popdown message appears when you select the Choose button.

(Edited)
Photo of Malcom Brown

Malcom Brown

  • 4 Posts
  • 0 Reply Likes
Thanks SactoBob - I'll try this once SnagIt loads again. So far it has been 2 hours waiting for the Editor to open. :(

Photo of SactoBob

SactoBob

  • 165 Posts
  • 61 Reply Likes
I assumed you are on a Mac since you mentioned iCloud. Question: Do you have Snagit in the Menu Bar? It shows as a capital "S"...  If yes, click on the S and select the More Preferences choice. The Preferences panel, as far as I know, should open up for you (and bypassing the editor). 
Photo of Malcom Brown

Malcom Brown

  • 4 Posts
  • 0 Reply Likes
Yes I am on a Mac and yes I have the Snagit S appearing on the menu bar. Clicking through to the More Preferences choice is again subjected to a spinning wheel that doesn't resolve for a few hours. All of this has only started happening when I upgraded to Snagit 2019. I've uninstalled and reinstalled twice.

Photo of Malcom Brown

Malcom Brown

  • 4 Posts
  • 0 Reply Likes
The Editor finally opened and I was able to review the Autosave location - and yes, it is on my local desktop. I'll check again tonight to see if it has resolved itself, somehow.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1172 Posts
  • 288 Reply Likes
Hi Malcolm,

Yikes! That's way longer than I've ever heard about. Even if all of your captures were stored on iCloud, the editor should only take a few seconds to load. I would open a ticket with our Tech Support so they can look into what's causing this delay for you.