Snagit trial won't open

  • 2
  • Problem
  • Updated 7 days ago
I downloaded the free trial of Snagit for Mac and installed it without issues.  However, when I open the program, it asks me to sign in to start my trial.  I sign in on the website and it says, "You've successfully signed in.  You may now close this window."  When I go back to Snagit, that sign in window never disappears and I can't use the program.  Any ideas?
Photo of caldorisio

caldorisio

  • 1 Post
  • 0 Reply Likes
  • annoyed

Posted 2 years ago

  • 2
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1118 Posts
  • 273 Reply Likes
Hi,

What web browser are you using? Can you change your default browser and see if that helps?
Photo of 1

1

  • 1 Post
  • 0 Reply Likes

Absolutely ridiculous, I have had and used snagit for years (v9-v11). I wanted to try the newest 2019 version. I created an account, downloaded, installed and launch it. It keeps saying to “Sign In to Start Trial”. I click the button which launches a browser, I sign in, it asks me why I want to try it, I answer and it says “You’re signed in!   Close this tab to return to Snagit.” But when I do it just goes back to “Sign In to Start Trial”. I have confirmed my account email, I have change default browser from Chrome to IE. Clearly authentication testing wasn’t high on the release list.
Photo of Luke Griffioen

Luke Griffioen, Employee

  • 1118 Posts
  • 273 Reply Likes
Hi,

I would open a ticket with our Tech Support for this. I'm not sure how this works on Windows, but on Mac if you have 2 copies of Snagit 2019 that can cause login issues.
Photo of aurelp

aurelp

  • 1 Post
  • 0 Reply Likes
Same problem here.
Windows 10 --> tried with (set the default browser):
Chrome: I see "You're signed in!" page but then in the application it says that I need to login and it closes 
IE: I get "page cannot be displayed" for final confirmation page (the "You're signed in") 
Edge:  I get "page cannot be displayed" for final confirmation page (the "You're signed in")
-----------
I uninstalled the app & I will try other alternatives. 
If the DEVs didn't test/fix such a simple bug  I can imagine how the rest of the application is developed. 
(Edited)
Photo of Nicholas Rich

Nicholas Rich, Employee

  • 21 Posts
  • 18 Reply Likes
Simply put, that is a horrible experience aurelp. I'm sorry you're experiencing this and thank you for reaching out to us.

We have heard reports of some users experiencing similar behavior to this. The common denominator appears to be their utilization of web filtering services or being behind a proxy while attempting to utilize a Snagit trial. We're currently looking into options to resolve issues like this for users in this situation.

It would be helpful for our troubleshooting efforts if you could:
  • Confirm if this sounds like it could be the root of the problem you're experiencing and any details about your setup you can provide
  • Confirm none of the solutions in our trial sign in support article resolve your problem (I think you've covered some of these)
  • Provide us with a copy of the Snagit logs located at %LocalAppData%\TechSmith\Logs

In the meantime, users in this situation can contact Tech Support to discuss a workaround so they can give the trial a try. Please reference this issue when reaching out to support.

Please let me know if I can be of further help.
(Edited)