SnagIt v11.4.x - Screen capture - mouse freezes for a few seconds (sometimes a few times)

  • 2
  • Problem
  • Updated 1 year ago
  • (Edited)
This is a bit complex to explain: I don't know the exact English words for it.

When starting making a screen capture, the crosshairs show up.
Then, when I move them to the desired location, e.g. left hand top corner, they freeze for a few seconds and then jump to the position of the mousepointer.

Whilst selecting the area, often the crosshairs freeze again.
I need to wait for some 5 seconds before I continue.
Regularly, when capturing a part of the screen, it take some 3-4  freezes' / 'stops' , each time wait in between.

If I am lucky, it is just one 'freeze' / 'pause' only.

Yes, I confess, I still user good old 11.4

Thing is, there is hardly anything in the newer versions that persuades me to using them...
OTOH there are a lot of things that is holding me back (don't need to sum them up here)


I found "Snagit (Windows): Crashes or the crosshairs are sluggish when trying to take a capture"

Regretfully the solutions there are applicable for 12/13/2018 only.
My 27"screen resolution 2560x1440 - not sure if that falls within 4K
Photo of Mike62


  • 598 Posts
  • 167 Reply Likes

Posted 3 years ago

  • 2
Photo of Joe Morgan

Joe Morgan

  • 9141 Posts
  • 4814 Reply Likes
2560x1440 falls short of 4K by quit a bit.

 However, 1920 x 1080 may be all that SnagIt 11 can handle.

 Is the 2560x1440 your new monitor, so this is a new problem?

I would Right Click my Desktop and select Display Settings. Go into the resolution settings and set the resolution to 1920 x 1080 and see how SnagIt performs.

You will need to Restart SnagIt 100%. That's means closing it from the system tray. If you shut down the editor and one click, it will still be running in the system tray.
Photo of Rick Grunwald

Rick Grunwald

  • 1422 Posts
  • 990 Reply Likes
And if it is a resolution issue Techsmith need to know
You can Submit a ticket

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Chat Support Hours.

You can reach the “CHAT” Support Team for assistance from

 6:00 AM to 9:00 PM ET, Monday-Friday

 Saturday from 12:00 PM to 4:00 PM ET.
Photo of Mike62


  • 598 Posts
  • 167 Reply Likes
Rick/Joe - as always - many thanks for your reply. Truly appreciated.
Rick: I did try to submit a ticket. However, the ticket form, whilst selecting the version number, shows that there is no support for anything before 12.0, reason why I posted here.

Just discovered there is something new now... 

when I take a screen capture of anything else than my Internet browser, desktop, Office, whatever, there are no such kind of hick-ups / stops. Capturing goes smoothly. I can see whilst selecting a area, e.g. a square from top left to right bottom, there is 1 delay for a split second. This is so short, normally one would not notice it.

When taking a capture of a website, there are these delays.
Also I have compared Chrome and Firefox, taking a capture of a website visited using both browsers.
Firefox has less delays and shorter. E.g. Firefox 1 sec and Chrome when pointing left top corner, roughly 4-5 seconds before I can proceed selecting.


I have tried using a 'competitive' product to take a screen capture: no delays at all, nothing.

Joe: I tried the other resolution, same problem.
BTW, until now  I wasn't aware I could set the monitor to a higher resolution. I can set it to 4096x2160, but the native resolution is 2560x1440.

To both
Please .. would you do me a favor: would you be so kind as to shortly check the performance when capturing a website at your end?
Is it smoothly, or are you also seeing a short delay of 1 or a few seconds just before and/or whilst selecting an area?
What browser and what version are you using?
(oh, last but not least, an off-topic, have you been using the newer SnagIt product side-by-side with an older version)

Many thanks for your help!
Photo of Joe Morgan

Joe Morgan

  • 9039 Posts
  • 4778 Reply Likes
I run  duel  1920 x 1080 monitors.
 I don't have any discernable delay problems. I even stretched out the browsers to fill both monitors.
I tested 
Microsoft Edge 41.16299.15.0
Firefox                  56.0.2
Photo of Randy Wilson

Randy Wilson

  • 21 Posts
  • 10 Reply Likes
I can verify this same issue happens with 13.1.5, on Windows 7, with a 27" Dell monitor running at 2560x 1440 resolution.
Photo of Mike62


  • 598 Posts
  • 167 Reply Likes
I may, repeat may.., have found the reason for this sluggish mousepointer behaviour.
Whilst using v2018 it was gone. However, I noticed that, after capturing a website, or part of it, the 'right-click->properties->details' in SnagItEditor did not show the website URL anymore, i.e. it was unclear from which website the screenshot was taken.

Re-enabling this feature requires enabling some or all, let's say, 'experts'-settings in Chrome (not available under normal 3-dots settings). At least two out of 6 settings should be enabled:
1) Web accessibility: Accessibility support is enabled for web content.
2) HTML:  Exposes HTML tag names and attributes via accessibility APIs.

Other items items that may be enabled are:
3) Native accessibility API support:  Allows Chrome to be controlled via native accessibility APIs specific to this platform
4) Text metrics: Enables support for querying line breaks and the bounding box of arbitrary character ranges
5) Screen reader support: Exposes accessibility APIs typically needed only by screen readers
6) Internal: Show internal accessibility tree instead of native

I did not enable items 3-6.

Now, when capturing a website the mouse-pointer was showing small 'hick-ups' again. Much, much smaller than with v11.x

I guess the SnagIt's retrieving website info is causing these small delays.

These delays are gone when all items are disabled again (default settings)

Photo of mike.south


  • 3 Posts
  • 2 Reply Likes
Thanks Mike

where do I go to enable/ disable those  features


Photo of juricek


  • 1 Post
  • 0 Reply Likes
Ancient by now, but I was wondering the same thing. I can't find those options in Chrome.