Snagit 11.2 editor does not work at all! Help!

  • 28
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Inactive threads; archiving to prevent necroposing

I received the email today to upgrade from Snagit 11 to 11.2. I installed it and the installation appears to be fine but snagit editor does not run at all and when i take a print screen the image disappears into cyberspace instead of neatly popping up in Snagit Editor. How can i uninstall and go back to one that worked?
Photo of Mark Throssell

Mark Throssell

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 28
Photo of Mark Throssell

Mark Throssell

  • 2 Posts
  • 0 Reply Likes
I tried the new snagiteditor.exe and it works! Well done.
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey everyone,

Certain customers upgrading to Snagit 11.2 have encountered a crash where Snagit Editor does not open properly. The Snagit development and technical support teams have been vigorously investigating the problem. Currently, we have identified a possible resolution to the problem and are in the process of testing a fix with a small number of users. We will post another update when we are ready to release the fix more broadly. We sincerely appreciate your patience.
Photo of David O'Neill

David O'Neill

  • 4 Posts
  • 0 Reply Likes
Could we get an update on the progress?

After all, this isn't just some failure of an outlying feature like my "unicorn" stamp doesn't size correctly or something!
Photo of Trevor Lestor

Trevor Lestor

  • 1 Post
  • 0 Reply Likes
Installed update 11.2 on Windows 7. Restarted - System failed to reboot and required regression to previous restore point. Even then system hangs, and SnagIt uninstalled.
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Official Response
Hey Guys,

Sorry about the delay! You can download a patched version of 11.2 that should work to fix everyone's Editor crash errors here: http://bit.ly/YKxxKm

If anyone has any problems with this patched version, let us know! Thanks!

Here is the MSI, for anyone that needs it: http://bit.ly/14cjx3R
Photo of Ed

Ed

  • 13 Posts
  • 0 Reply Likes
We need the MSI install so we can configure and package the install.
Photo of David O'Neill

David O'Neill

  • 4 Posts
  • 0 Reply Likes
Although I assume great effort is being expended to resolve this problem, the rush to solution is not a solution. The file referenced above does not come with sufficient instructions for installation ergo Ed's comment about an MSI package.

Please advise... soon.
Photo of Mike62

Mike62

  • 575 Posts
  • 166 Reply Likes
Thanks for all the efforts.

However, agree with Ed, appreciate a MSI file.

Thanks again!
=
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey guys,

MSI is included in the post at the top. Hope that works for everyone!
Photo of Frank Edwards

Frank Edwards

  • 10 Posts
  • 0 Reply Likes
Nope.

Just installed the patch but Editor is crashing every time I make a capture.

I'm on Vista Home Premium.

Plus, what is an MSI? Please explain this stuff to us non-techies. So hate it when you talk in geek-speak.

Frank
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey Frank,

Can you open a ticket here so we can help you out a bit more? http://techsmith.custhelp.com/app/uti...

Thanks!
Photo of Frank Edwards

Frank Edwards

  • 10 Posts
  • 0 Reply Likes
Hi Logan,
All seems to be working now.
I reinstalled with the MSI file and things have settled down now.
Many thanks for your help and directing me to the MSI info.
Frank
Photo of Ed

Ed

  • 13 Posts
  • 0 Reply Likes
Hi Frank,

You shoold be able to follow this link for information in regards to what is an MSI. http://lmgtfy.com/?q=what+is+an+msi

Regards
Photo of David O'Neill

David O'Neill

  • 4 Posts
  • 0 Reply Likes
Just reinstalled using the msi file, Editor seems to be working correctly.

Yahoo!
Photo of Mike62

Mike62

  • 575 Posts
  • 166 Reply Likes
Many thanks, things are fine now!
Photo of flyingdutchman

flyingdutchman

  • 7 Posts
  • 0 Reply Likes
I have a problem with the latest version as well. It takes a long time for the capture crosshairs to appear. Once I create a capture, there is a lot of disk activity, but the editor never appears.

@billhughes Losing your captures -- or anything else -- is terrible, but how did you manage to use a computer for at least 3 years without doing any backups? That's just courting disaster.
Photo of flyingdutchman

flyingdutchman

  • 7 Posts
  • 0 Reply Likes
@Logan,

The patched version works well.
Photo of David

David

  • 22 Posts
  • 14 Reply Likes
Well, that hours I can't get back.

Using Camtasia 7 because so many features removed to make it 'simpler' in v. 8.

Can't capture in SnagIt at my resolution, still have some SnagIt box/button whatever on my screen, 11.2 install took hours to figure out.

Whoever is guiding your vision these days - shouldn't.
Photo of Paul Schroeder

Paul Schroeder

  • 2 Posts
  • 0 Reply Likes
After installing the latest update to Snagit (11.2.0), Snagit Editor no longer works (won't open). A quick check on the web shows that many, many others are having the same problem. Is there a fix?

This reply was created from a merged topic originally titled
Upgrade 11.2.0 has BIG problems.
Photo of Ed

Ed

  • 13 Posts
  • 0 Reply Likes
This recent release seems to have resolved the issue with the editor crashing.
GL

Official Fork Logan Schultz (Employee) 4 days ago
Hey Guys,

Sorry about the delay! You can download a patched version of 11.2 that should work to fix everyone's Editor crash errors here: http://bit.ly/YKxxKm

If anyone has any problems with this patched version, let us know! Thanks!

Here is the MSI, for anyone that needs it: http://bit.ly/14cjx3R
Photo of flyingdutchman

flyingdutchman

  • 7 Posts
  • 0 Reply Likes
Alright... an update.

The patched version works well -- once you get it running.

I have selected to have Snagit run when Windows starts, but it does not do so. I have to run it myself.

At times that goes well. At other times it takes the program a l-o-n-g time to start, and then it does so only after lots of disk churning.

I'm running a high-end machine with Windows 7 Pro.
Photo of Michael Deutch

Michael Deutch

  • 10 Posts
  • 0 Reply Likes
The new MSI does not fix my problem. Please help! It looks like I can take a screenshot but nothing is captured in the clipboard.
Photo of Michael Deutch

Michael Deutch

  • 10 Posts
  • 0 Reply Likes
When I don't do the preview in editor, it appears to capture in the clipboard. At least that's a start! Still, I'll need to edit my images!
Photo of Ed

Ed

  • 13 Posts
  • 0 Reply Likes
Did you uninstall and reinstall from scratch? If you did i'm not sure what the issue is. I have installed the MSI installer onto a windows 7 64 bit workstation and everything works as expected.
Photo of Michael Deutch

Michael Deutch

  • 10 Posts
  • 0 Reply Likes
Yes, I uninstalled and reinstalled from scratch. I'm also on a windows 7 64 bit workstation.
Photo of David

David

  • 22 Posts
  • 14 Reply Likes
After 4 hours of uninstalling other programs I recently installed - not knowing then 11.2 was the culprit - everything is working properly.

I used Revo to uninstall earlier v11 SnagIt - it does a secondary deep-cleaning of the registry. I used the Pro version - base version free. Turned off Norton and Malwarebytes and Hitman Pro - and installed.

SnagIt and my other recent installs now coexist peacefully.

David
Photo of bob.cleaveland

bob.cleaveland

  • 2 Posts
  • 0 Reply Likes
Thanks Logan !

The fixed Version 11.2.0.102 from your links
http://bit.ly/YKxxKm and
http://bit.ly/14cjx3R

works just Fine and Dandy !

And LIGHTNING FAST !!!!
compared with prior installations.

For curiosity's sake:
1) What did you do for the fix ??
2) How did you get SnagIt 11.2 going so fast(!!!) ??

Best Regards and Thanks again,
Bob Cleaveland
Physician - Radiology
Witten, Germany

(Satisfied TechSmith-SnagIt customer since SnagIt 7 in Feb. 2005)
Photo of Bill Hughes

Bill Hughes

  • 4 Posts
  • 0 Reply Likes
This one works perfect and yes it does appear faster ... what did you do?
Photo of Keith Anderson

Keith Anderson

  • 2 Posts
  • 0 Reply Likes
Okay it doesn't crash now, but it still changes my Windows color scheme to "basic" mode which defeats the purpose of capturing the screen the way I've got it setup.

Snagit v5 was a great product. All of these additions have done nothing but make the basic function of the program less and less useful.

This conversation is no longer open for comments or replies.