Snagit 12 Preview in Editor

  • 2
  • Question
  • Updated 4 years ago
  • (Edited)

Hi, so i updated my existing Snagit 11.4 installation to 12.0 today.

I created an "image" capture profile with share options: Clipboard Only. (Preview in Editor) is disabled. Now when i create a capture it still starts the Snagit Editor.

Am i missing something or is this a know problem with the 12.0 version?

Also, if i need to make a lot of screenshots in a row i'd prefer not to see the new dialogue upon creating a capture. Is there a way to turn this off? (With the dialogue i mean the 4-button dialogue upon taking a capture.)

thanks,

Bart


Photo of automatisering

automatisering

  • 2 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 2
Photo of Rick Stone

Rick Stone

  • 5958 Posts
  • 2840 Reply Likes
Hi there

When you open the new SnagIt preferences and look at the General tab, there is an option that you likely need to disable. It's named "Make Editor the active window on capture".



Cheers... Rick :)
Photo of Dave Fighting Tiger Jackson

Dave Fighting Tiger Jackson

  • 65 Posts
  • 1 Reply Like
Rick, how did you do the cool spotlight and magnify? I spend a little too much time creating ones like that and am hoping yours is a simpler, speedier process. ;)
Photo of Rick Stone

Rick Stone

  • 5958 Posts
  • 2840 Reply Likes
See if this little screencast helps!

In reality, it now takes me about 30 seconds or less to accomplish this.

http://www.screencast.com/t/D8bc96JVRTHy

LOL, tried to paste the link into the video section. Odd, that ScreenCast isn't among the supported sites, given this is a TechSmith forum!

Cheers... Rick :)
(Edited)
Photo of Cory Lasky

Cory Lasky, Employee

  • 13 Posts
  • 0 Reply Likes

Thanks Rick,


Another thing to consider, Bart, is the new 'big red button' and print screen key (or whatever you set as default) will always start the same capture type and do not take any of your preferences into account. It will always initialize the new capture workflow where you select your area, and then choose Image or Video.

If you set up your profile without the preview in editor turned on, you would need to select that profile from the Capture window:

Or you can set a hotkey for the profile in the Manage profiles window and initiate the capture using that new hotkey.

We have a great tutorial here showing the new profile creation process: http://www.techsmith.com/tutorial-snagit-12-save-capture-settings.html


Hope that helps!

Kind Regards,
Cory
Technical Support Specialist

 

Photo of jos

jos

  • 1 Post
  • 0 Reply Likes

Another question (almost the same) is it possible to assign a profile to the red button also? i'm a fan of the red button....


Photo of Rick Stone

Rick Stone

  • 5953 Posts
  • 2838 Reply Likes
Hi Jos

As I understand it, presently all the red button will do is to instigate a capture where you must then choose whether the capture is video or image.

So no, no "profile" may be assigned. At least, to the best of my knowledge.

Personally, I really liked the way the red button worked in version 11 because it would have the ghosted image of the camera or video to alert you.

Cheers... Rick :)
Photo of Sandy Kotes

Sandy Kotes

  • 37 Posts
  • 26 Reply Likes
I agree witih this statement about 11.x red button. However, I do like the option to choose video or image capture AFTER taking the capture. Very handy. A compromise would be great
Photo of gpeck

gpeck

  • 3 Posts
  • 4 Reply Likes
Is it possible to disable the option to choose Image or video? I never use video, therefore this new option has added an extra step when I capture an image. This should be an option in Editor Options (if it is - I can't find it). New features in new versions/releases like this that impact the User should always default 'Off' or work as they did in the previous version - and allow the User to decide to enable them. 
Photo of Manny Carvalho

Manny Carvalho, Champion

  • 1171 Posts
  • 185 Reply Likes
I just created a profile to send captures to the clipboard only and it works. The problem might be that the Preview in editor is enabled. It needs to be white not blue to be turned off. There is a buit in clipboard only profile. Have you tried that?

[@ Rick - that option is to make the editor pop to the top of other windows when a capture goes to the editor. I like it as its kind of nice of have the editor visible.]

Here's what my working clipboard profile looks like:

Photo of automatisering

automatisering

  • 2 Posts
  • 0 Reply Likes

Hi all, Thanks for all the suggestions/help.

I've been able to configure a profile which almost does what i want.
For some reason it still activates the Editor in the background (as not-on-top) when doing Clipboard only captures.

I guess it's behaviour as intended with v12. I'll try to adapt to this new way of working :)

Thanks,

Bart






Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
Hi Bart, 
I think you should be able to achieve your desired workflow. My hunch is the confusion lies in that there are sort of two places where the Editor option shows up. Take another look at Manny's image. Is that disabled? And then make sure you're using that profile either with a hotkey or selecting as in Cory's screenshot. The default red button just launches the default capture workflow. 

I think we're close, and I might be misunderstanding, but if you're willing, I suppose I can share a profile that can be imported by you if you want to try that. 

Sincerely,
Mike Curtis

Photo of Tye Holmes

Tye Holmes

  • 3 Posts
  • 1 Reply Like
I have been trying to figure this out for version 11.4 and just may be the reason I try v12. In v11, is there any way to create a profile that puts a capture on the Clipboard AND the Editor without having to go to the Editor to complete the profile? I'm ok with the Editor in the background, and I want to access my capture there later, but I really just want the capture to go directly to the Clipboard as well.
Photo of Manny Carvalho

Manny Carvalho, Champion

  • 1171 Posts
  • 185 Reply Likes
Do what Rick suggested above.
Photo of Tye Holmes

Tye Holmes

  • 3 Posts
  • 1 Reply Like
If I'm tracking the thread correctly, Rick suggested turning off the "make Editor the Active window" setting. I have done this and with each capture the Editor is in the background. I'm trying to understand if you can have a capture go to the Editor in the background and the clipboard without having to go to the Editor to click "Finish Profile." I guess I'm looking for a Share Multiple Destinations option where the Clipboard and the Editor are selectable choices. Just validating, does your v12 screen shot above allow this?
Photo of Manny Carvalho

Manny Carvalho, Champion

  • 1171 Posts
  • 185 Reply Likes
Remember that when you change a profile that change will not stick if you use another profile in the meanwhile.  Changes to profiles have to be saved directly.
Photo of Earl

Earl

  • 4 Posts
  • 1 Reply Like
Hi,

I would like to add to this dialog string.  I installed Snagit v12 just a few days ago.  I'm a long time fan who just upgraded to Win 7.  I went ahead and upgraded to v12 shortly after finding the built in Win 7 captured to be too lacking.

I had the same problem described above.  Initially, I was able to select and/or de-select toggle the "Editor" button under the profile options and I thought successfully turn the Editor on / off following a capture.  That only seemed to work for a day.

I've tried to reset and toggle everything I can find.  Even with the reset and trying to directly use the out of the box "Send to Clipboard" profile, I still always get the editor.  

I have spent several hours trying to find a combination.

I always used my hot keys.

I just tried to start captures using my mouse and selecting the profile under the big red button.  It felt like it reset something.  Now after several hours of aggravation, it seems to be working as expected even the hotkeys way now works.

One key regarding the Editor, before when I could not stop to editor from opening, I noticed the the "Finish Profile" on the far right of the Editor toolbar was not appearing.  I believe that is probably an indicator of what was not toggling.

I put it out there for others....no reason for others to be aggravated.  Overall, I'm a big fan of Snagit.

Photo of Sandy Kotes

Sandy Kotes

  • 37 Posts
  • 26 Reply Likes
I just purchased the upgrad to 12.x today. I absolutely HATE the black ground on the Ribbon. It is SO hard to see the ribbon options.

Before I upgraded, I read about the changes. I was concerned that the black ribbon bar and menu options were black, but I thought/hoped there would be a way to change the color. So...

Is there any way to configure the color on the ribbon. I don't want to extort an option, but I might request a refund because the black ground is distracting.

I create design specifications and images are a huge part of my work. I really cannot look at the darkness all day.

Please advise. I hope there is a solution.

Thanks!
Sandy
Photo of Rick Stone

Rick Stone

  • 5958 Posts
  • 2840 Reply Likes
Hi Sandy

All I can say is "hang in there". TechSmith have advised that the very next update will have a different UI color for the ribbon. Not sure how far off it will be, but I'd just guess another two or maybe three weeks? Only TechSmith can say for sure.

Cheers... Rick :)
Photo of Sandy Kotes

Sandy Kotes

  • 37 Posts
  • 26 Reply Likes
Rick! Thanks so much for letting me know. I am using 11.x for now. I look forwrd to that change. Just knowing that a change is on its way is good enough. Sandy P.S. I work for a software developer and am VERY familiar with this process from A - Z. 
Photo of Per+Olav Svendsen

Per+Olav Svendsen

  • 1 Post
  • 0 Reply Likes

Hi,

I'm using SnagIt 11.4.1 on Windows PC.

I am unable to make SnagIt NOT open the preview in editor. I have set it up to share to Clipboard, and I have disabled the "Preview in editor" option. I have also disabled the "Make editor active on capture"-option in Program Preferences.

Yet, every time a make a capture, it opens up in the editor. From there I have to click "Copy all" or "Share" to make it available on the clipboard.

It seems that the first capture I make after opening the software does what it is supposed to do (goes directly to Clipboard), but after that all captures goes to editor. I have tried reinstalling the software.

Any hints? It's getting really annoying. I do hundreds of snags every day. I especially use "repeat last capture" a lot. Having to go through the editor every single time is getting really annoying...

This conversation is no longer open for comments or replies.