Why is SnagIt is a LOT slower than Jing?

  • 1
  • Question
  • Updated 7 years ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Inactive threads; archiving to prevent necroposing

I am a Jing Pro user and love what it can do. I'm bummed that it will be phased out, but was not averse to paying for a better, more capable SnagIt.

But when I try SnagIt, it is very sluggish and slow. MUCH slower than Jing. I realize that SnagIt does a lot more than Jing, but SnagIt is so slow it borders on being unusable.

I am running a fairly high power Windows 7 desktop with 3 monitors.

My trial with SnagIt has run out so I haven't paid for the upgrade. If the performance issues can be resolved, I would be more than happy to upgrade to SnagIt.

Please help!
Photo of Jay Garnett

Jay Garnett

  • 6 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
Hello Jay,

Thanks for taking the time to post your findings and observations. I wanted to inquire as to if you've noticed any patterns. For example, is Snagit slow the first time you make a capture, or every time? Do you notice a difference whether you captured images or videos? Did you usually capture video? Do you remember what part seemed slower? For example, was it waiting for the cross hairs to appear or the act of dragging and selecting?

I realize it might be hard to answer since it's expired, but I did want to say thanks for letting us know about your experience and see if we could get a little more detail so we can try and replicate this.

Sincerely,
Mike Curtis
Photo of Jay Garnett

Jay Garnett

  • 6 Posts
  • 0 Reply Likes
Mike-

Would it be possible to get a trial extension so we can work on this issue? As I mentioned, if Snagit works for me, I want to buy it, but I don't want to buy it if we can't fix the speed issues.

The slowness I'm referring to is the capture "crosshairs". When I invoke the capture mode and move the mouse around, the crosshairs lag. This behavior appeared to be constant and was always slow.

Thanks,

Jay
Photo of Jay Garnett

Jay Garnett

  • 6 Posts
  • 0 Reply Likes
More info regarding your question... I almost always capture images and not videos. It was slow for the cross hairs to appear and they lagged when I move the mouse around.
Photo of Mike Curtis

Mike Curtis, Employee

  • 2204 Posts
  • 216 Reply Likes
Jay, I'll contact you offline with some options regarding how we might be able to troubleshoot this past the trial expiration.

Have you seen this article with some troubleshooting for Snagit 10? Multiple monitors, hardware acceleration, and disabling Aero are some things to try. I wouldn't say this is a real solution, just might help with finding clues. http://techsmith.custhelp.com/app/ans...

Thanks for the added detail too. It might be worth opening up a case with our support team. They are the best at discovering any hardware or 3rd party-related issues. Here is where you can create an account and open a case: http://techsmith.custhelp.com/app/uti...

Sincerely,
Mike Curtis

This conversation is no longer open for comments or replies.