SnagItEditor: Sandboxed Browser no website URL

  • 1
  • Question
  • Updated 6 years ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Inactive threads; archiving to prevent necroposing

When capturing a (part of) a website using a browser that is running within Sandboxie, the website URL (Editor->Tags) is not displayed.

On the other hand, when I click on 'properties' of the preview thumbnail, it does show the "Window title". The [#] at the beginning and end of the window title shows that this capture was taken from a browser running in a sandboxed.

Why not at the URL of the website then ?

Thanks
=

=
Photo of Mike62

Mike62

  • 576 Posts
  • 166 Reply Likes

Posted 6 years ago

  • 1
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
Hey Mike,

Try this:

Then this:
Photo of Mike62

Mike62

  • 576 Posts
  • 166 Reply Likes
Thanks.

Okay, but eh.. then what?

=


=
Photo of Logan S.

Logan S.

  • 2813 Posts
  • 153 Reply Likes
When you attempt to capture the page again, it's still not capturing your url?
Photo of Mike62

Mike62

  • 576 Posts
  • 166 Reply Likes
Sorry, no....

As said, the webbrowser (Firefox) is running within Sandboxie.
I may run a sandboxed session of SnagIt, thén there is no problem, that is to say, not with the URL thing.
However, I stopped doing so (running SnagIt in a sandbox) because one of the things that did not work anymore was dragging a saved file from the editor into email as an attachment, something I regularly do. Had to use Explorer to drag and drop the file into Outlook.

Note: I did not go any further, possibly some other features aren't working properly.anymore either - I don't know.

However, SnagIt does capture info from the sandboxed browser, so why not the url then

=

=
Photo of Mike62

Mike62

  • 576 Posts
  • 166 Reply Likes
Guess impossible to solve?
Photo of Manny Carvalho

Manny Carvalho, Champion

  • 1171 Posts
  • 185 Reply Likes
It may be. I've had this problem for years because I use Maxthon. This works fine in IE and some other browsers. I think fundamentally it's that the browser doesn't allow this to happen or that TS can't easily figure out how to acquire the data.

If you really need that data then, right now and perhaps for the long term, use IE where it works. I live with it and forgot about it a long time ago.

Photo of Mike62

Mike62

  • 576 Posts
  • 166 Reply Likes
The thing is : when you visit this page, the tab at the top says "SnagItEditor: Sandboxed ... "bla bla. i.e. the title of my posting.
This tab is linked to an URL.

SnagIt can retrieve the title of the tab, but not the URL that is attached to it.
(When running in Sandboxed mode, using Sandboxie).

Outside Sandboxie, everything works fine.

Firefox add-in like copy URL expert, can easily copy the URL behind the tab (also when running in Sandboxie)
=



=

This conversation is no longer open for comments or replies.