System sound recording is improved when headset is plugged in. Why?

  • 1
  • Question
  • Updated 2 years ago

I am sure this is not a CS8 issue but I’m hoping someone here knows how to make recorded system sounds sound as good when cheap headsets are plugged in.  Specifically, sound recorded by CS8 is higher pitched than they sound over the speakers; voices are noticed most.

My workaround is to plug in a cheap pair of headsets which brings up a “Realtek High Definition Audio” application.  Now recorded sounds are better in CS8. The settings in the Realtek manager appear to be the same whether the headset is plugged in or not.

Too many changes have been tested, and backed out, to list.  Some from Google searches and some from the forum.  Obviously I don't know what I'm doing so type slowly!

Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

Posted 2 years ago

  • 1
Photo of Dubie

Dubie

  • 967 Posts
  • 746 Reply Likes
Here are some things you might try if you already haven't done them.

In the Camtasia Recorder Audio Settings, turn OFF system sound and only use speakers as your audio input.



I do not know your setup, but on my system I adjust the recording volume (up or down) from my keyboard and them manually turn down my speakers as to not blast me out of the room.

Secondly try adjusting your systems audio (speaker) settings.  Control Panel>> Sounds
Select your speakers and then Properties.




I mostly work in Windows 7 so the images below are the settings I have found work best on my system.

See if any affects  under the Enhancement tab are active and turn them OFF.




Under the Advanced tab, try changing the sample rate and bit depth.




For me 16bit, 4800 Hz works best. It may be different for you.

Dubie :)
(Edited)
Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

Dubie,

Thank you.  I think the first solution is what I used to use.  It has been replaced by "Microphone (Realtek High Definition Audio) regardless of the headset being attached or not.  Most of my editing is done while the family watches TV so I normally use the headset avoiding the issue.  I don't want to reinstall CS8 because my build is not likely to be available and not ready to install C9 (although purchased and downloaded) so another solution will be researched.

In addition, all other suggestions were tried.  Thank you for taking the time to help and for helping others.

In Win10 there is no "disable" checkbox but all selections were disabled.  Sound Effect Properties were also missing but show up if any sound effect is enabled and remains if disabled.  I did try disabling Immediate Mode.

In the Advanced tab the default is 24 bit, 48000 Hz.  Earlier, I tried 16 bit, 41000 Hz based on another post and 16 bit 48000 Hz was just tried.

To err is human but to really foul up requires a computer.  I'm a human using a computer.  what more can I say!  :D

Photo of Dubie

Dubie

  • 967 Posts
  • 746 Reply Likes
Is you system default playback sound set to your speakers?

In Control Panel>> Sounds >> Playback tab,  it should be set to use your speakers as the default



 And under the "Recording tab" you should have your microphone headset as the default
unless you are using something else for recording sounds

In Camtasia recorder you should have both your speakers and mic/headphones listed unless
they are disconnected from your system or not set as the defaults on your system

Not sure what else might be giving you this issue. Sorry

"To err is human but to really foul up requires a computer"

Got that right :)
(Edited)
Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

Yes, speakers are chosen.  I tried the Realtek Digital Output earlier; having nothing better to do!

In the recording tab the microphone enabled is Microphone: Realtek High Definition Audio.  Stereo Mix: Realtek High Definition Audio was enabled and tested but that didn't help either.

The headset is a CHEAP, non-USB headset with a boon microphone.  However, it only has one plug.  It came with a splitter to allow using the microphone (which I may use someday), but when the splitter was used headset sound was limited to one earpiece.

thanks for trying.  I do remember using that entry you first showed me a LONG time ago.  It was forgotten until you displayed it.  I will research more on how to get it back.  If successful, this post will be updated to help others later.

Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes
As stated in the recording devices list the first entry is  "Microphone (Realtek High Definition Audio)".  That probably doesn't have anything to do with the issue as the issue I'm having is with recording system sounds; no microphone being recorded.  (Wasn't thinking earlier...
Photo of Bob Lewis

Bob Lewis

  • 353 Posts
  • 174 Reply Likes
Since it is recording System Sound to get good audio I simply  click the speaker icon on the lower right of the task bar and set the System Volume to 60% and it records good quality sound.
If I forget to do this, the sound is very over modulated and sounds terrible.
You may need a different setting. This has worked for me on 2 different computers.
 50% works also but sometimes I have to up the volume in post processing.
Of course make sure you are Not recording any microphone, unless that is what you want.
Mine is off. I do voice over later.  Maybe this will work for you.
(Edited)
Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

Thanks for the thoughts.

So, I checked the volume with and without the headset plugged in.  49% without and 100% with. 

So, with the headset unplugged, volume turned up to 100%  and another screen recording was taken from a Camtasia YouTube demo.  The pitch is still higher.  Bass turned into tenor.

It is like playing a song centered around middle c on a piano but the recording sounds one octave higher.  Plugging in the headset lowers the pitch making it sound closer to what is heard over the speaker.


no microphone is being recorded.

(Edited)
Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

Just an update to the first reply by Dubie.  The first screenshot showed "Stereo Mix (Realtek High Definition Audio)" which was not listed on my system.  Here is how to restore that option as a microphone source in Camtasia when recording the screen.

Right-click the Sound icon in the system tray
Select Recording devices
If "Stereo Mix" is missing, right click in the center of the dialog box and enable "Show Disabled Devices"
In my case "Stero Mix" was a listed entry and enabling it added it as a selection in Camtasia.

This didn't help with my issue but it might help others find the connection between Camtasia's audio inputs and a Win10 system.

Photo of Dubie

Dubie

  • 967 Posts
  • 746 Reply Likes
Hey ExpertNovice

Couple of questions

Have you tried recording your system audio in another program such as Audacity and played it back?

What are you using for playback? Windows 10 player, Windows media player, VLC ?

Your system setup:

Do have actual speakers hooked up?

Are you using a usb headset?

Have you checked for a driver issue?

1. Press Win+R (Windows key and R key) at the same time. A Run dialog will appear.

2. Type devmgmt.msc in the run box and click OK button. 

 3. In Device Manager, expand category Sound, video and game controllers. Under this category, you will see Realtek High Definition Audio. If there is a yellow mark ( most probably an exclamation mark or a question mark) next to the device name, there is problem with the driver. Then you need to update the driver.

Have you check your settings in the Realtek High Definition Audio?

Click image to enlarge







(Edited)
Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

Dubie,

I assume that you rest, sometime.  Right?  :D

Have you tried recording your system audio in another program such as Audacity and played it back?

Nope.  Good test I failed to perform, having assumed this was not a CS8 issue.  I used the Win10 default of "Voice Recorder" with the results.

What are you using for playback? Windows 10 player, Windows media player, VLC ?

CS8


Do have actual speakers hooked up?

No

Are you using a usb headset?

No


Have you checked for a driver issue?

Yes.  Device Manager does not indicate an issue.  It was allowed to update the driver (probably only looks at MS) and reports the driver is up-to-date.  (Of course, this is not always the case.)  However, Realtek has not been checked for an updated driver so none have been manually downloaded and installed.

Have you check your settings in the Realtek High Definition Audio?

Yes, and compared with and without the headset with only the volume level being different.  That was changed earlier  in another test.  Based on other, older, threads the settings have even been changed to multiple formats.

I am unable to find those advanced settings min my version of the manager.  That will have to wait as the HDD in the church computer (used to record the sermons) died Monday and must be rebuilt.

Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

I'm unable to find that latter option.  Google found a thread that suggested that option is not on later versions.

I will stumble upon the answer at sometime.  For now, I just have to remember to plug in the headset prior to recording a webinar.

Photo of Dubie

Dubie

  • 967 Posts
  • 746 Reply Likes
Ok I'm digging at the bottom of the barrel here now.

Piecing together info from your posts I have concluded you do not have any speakers plugged in,  and plugging in your headset improves the sound.

You state:

"Stereo Mix (Realtek High Definition Audio)" which was not listed on my system.

In my case "Stero Mix" was a listed entry and enabling it added it as a selection in Camtasia.

The headset is a CHEAP, non-USB headset with a boon microphone.

I recall one time a colleague I worked with that reviewed audio clips did so with headphones he had plugged into the audio plug on the front of the computer and also had a "dummy plug" plugged into the rear audio plug.

A dummy plug is nothing more than a 3.5 "stereo' plug with nothing connected to it. just taped off wires.

He did this to "trick" the sound card in to thinking there was a audio device using the plug. Again on the rear audio plug.

I figured what the heck, let's test this.

Below are my test results using Camtasia 9 recorder and the audio settings



I unplugged my powered speaker system  then recorded a Youtube video.

P.S. I also use a usb headphone/mic combo plugged into the front of my computer
mostly only for recording narration

Note the Levels indicator in the recorders UI
Volume level remained the same on all tests

Nothing plugged in the rear audio plug



With dummy plug



With speakers plugged in



As you can see

nothing in the rear plug,  No sound

with dummy plug,  good sound

with speakers,  even slightly better sound

Point of this comment...

Your headphones make the sound better but may not invoke the stereo and
may only give a mono output thus the higher pitched sound

Maybe try using a "Stereo" 3.5 dummy plug (Double rings)


or some computer speakers

Good luck with your quest :)

Hope this works !!
(Edited)
Photo of ExpertNovice

ExpertNovice

  • 352 Posts
  • 105 Reply Likes

Thanks for trying!


To test the stereo suggestion a "1-Minute Audio Test for Stereo Speakers & Headphones" test was found on YouTube with and without the headphones plugged in.

While recording both heard in stereo.
While playing back both were still stereo whether the headphone was plugged in or not.  The recording made without the headphone was higher pitched whether the headphone was plugged in or not.

It seems to me the "RealTek HD Audio Manager" must be changing the sound but I can't find a difference in settings between with and without headphones.

<sigh>

This is apparently a strange issue that will be solved by stumbling on the answer or by someone who stumbled on it.  I will keep researching and testing, as time permits, and report back if a solution is found.

(Edited)