the thumbnail to .trec files is not showing up.

  • 1
  • Question
  • Updated 8 months ago

It was a windows blank icon, but i tried to select a different app to open the file and ended up with this. 
it is usually a red reel. How do i fix this? 
I already tried repairing camtasia and it did not do anything to it. 
I'm thinking of unstalling camtasia but how do i make sure that all my existing project don't end up deleted ?
Photo of liz.g.lewis

liz.g.lewis

  • 3 Posts
  • 0 Reply Likes

Posted 8 months ago

  • 1
Photo of Rick Stone

Rick Stone

  • 4501 Posts
  • 2010 Reply Likes
If this is the icon you are seeing:



My TREC files have that association. They seem to be associated with Camtasia 9. You might need to browse to the executable. I found mine here:

C:\Program Files\TechSmith\Camtasia 9\CamtasiaStudio.exe

Cheers... Rick :)
Photo of liz.g.lewis

liz.g.lewis

  • 3 Posts
  • 0 Reply Likes
I reinstalled camtasia 8 and the red reel showed up as the icon.. I'm not sure why it would be associated only with the camtasia 8 though.. and do i have to keep it installed for the proper icon to show?
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1423 Posts
  • 377 Reply Likes
Both Camtasia 8 and 9 use the red reel icon for .trec files.  The icon association is created when you install, and deleted when you uninstall.  Yes, you do need Camtasia to be installed for the icon to show up correctly.  If the icon is not showing up correctly, and you have Camtasia installed, then a reboot will usually force Windows Explorer to refresh its icon cache, which can sometimes fix a broken icon.

Hope this helps.
Photo of liz.g.lewis

liz.g.lewis

  • 3 Posts
  • 0 Reply Likes
Hi Dave,

It hasn't fixed the problem. I have camtasia 9, and used camtasia 8 (the one that was downloaded from TechSmith after I registered cam7... ) I used cam 8 to update/upgrade the cam7 file, then used cam9 to update/upgrade the cam8 files to cam9. I have no need to keep older versions of camtasia, so I unisntalled cam7 and cam8. Now the red reel is gone. 
So, if the red reel is associated with both versions, why is it still not showing up for cam9? I rebooted several times thinking it would work.  It did not. 

I have opened the .tscproj file and the .trec file all open up in cam9, so I save it again as is and close cam9 out. I was hoping this would "reset" to the missing icon issue, but it did not work either. At this point it doesnt even matter, as long as the files open up for me as they are supposed to. But I just don't understand why the icon disappeared. 
Photo of Dave O'Rourke

Dave O'Rourke, Senior Software Engineer

  • 1423 Posts
  • 377 Reply Likes
It sounds like one of the uninstalls took out the icon association for the .trec file.  That can be repaired.

Please try running the 9.x installer.  You do not need to uninstall.  Just re-run the installer.  When prompted, choose Repair.  This should repair the missing registry entries that associate the icons with the file extensions.