timeline dosen't display its playhead needle

  • 2
  • Problem
  • Updated 2 weeks ago
I upgraded to the latest version of Camtasia (105533) today and am starting to have issues. Im am also using Mac OS Mohave. I noticed that the Timeline needle has vanashed.
Photo of jbavar

jbavar

  • 1 Post
  • 0 Reply Likes

Posted 1 month ago

  • 2
Photo of Leif

Leif, Employee

  • 110 Posts
  • 64 Reply Likes
We've never seen that before on any OS.  Are you on the released version of Mojave (a lot of folks were using early beta versions of Mojave)?  If not, could you update to the released version of Mojave and see if that helps. I have no idea how this would happen.
Photo of Leif

Leif, Employee

  • 110 Posts
  • 64 Reply Likes
Did you download the 2018.0.6 update to see if it fixes the issue (see Stephens note below)?
(Edited)
Photo of Dan Z

Dan Z

  • 3 Posts
  • 0 Reply Likes
Hi,
I'm encountering this issue as well.  The issue started occurring immediately after installing the latest Mojave release.  I'm currently on Mojave v 10.14, and Camtasia v 2018.0.5 (105533).  When I close and reopen the Camtasia file, then the problem will go away temporarily.
Photo of Leif

Leif, Employee

  • 110 Posts
  • 64 Reply Likes
Mojave (10.14) seems to be trying to squeeze out a little more battery life by attempting to avoid what it thinks is unnecessary rendering.  It turns out that we'll need to be a little more aggressive with letting the 10.14 OS know we need to repaint than we've ever had to be on previous OS's.  We're working on several of these rendering issues and hope to have a fix out shortly.  In the meantime, if you have a way to run Camtasia on an older OS, you can avoid this issue until a fix is released.  If not, perhaps resizing the application or the timeline, or minimizing and restoring it may possibly force the OS to go ahead and repaint.
Photo of davemillman

davemillman

  • 453 Posts
  • 134 Reply Likes
Since @lief identifies it as a battery issue, does it go away when running on AC power? 
Photo of Dan Z

Dan Z

  • 3 Posts
  • 0 Reply Likes
Thank you Leif!  I'll try those workarounds.
@Dave - Nope, unfortunately the issue persists when plugged in
Photo of Stephen Wagner

Stephen Wagner, Employee

  • 610 Posts
  • 149 Reply Likes
We released Camtasia 2018.0.6 today and hopefully it fixes this issue.  This was a tricky one, because we could not reliably reproduce it.  Mojave made a lot of changes to how things are redrawn, which resulted in a number of subtle bugs such as this.

-Stephen
Photo of Dan Z

Dan Z

  • 3 Posts
  • 0 Reply Likes
Thank you for the update!  I'll monitor and let you know if the issue persists.