transparency in png showing as solid white

  • 1
  • Problem
  • Updated 4 months ago
I have 2 pngs created in Snagit 20181.1 that have a transparent background. In fact the 2nd one was created as a copy/paste of the first. The first shows up correctly in Camtasia 2018. However in the 2nd png the transparent area shows as solid white. I cannot use the eyedropper to replace the white with transparency since I need some actual white in the image. I'd rather not have to go to the trouble of a workaround of changing transparent to purple in snagit and then re-importing into Camtaisa, especially since it comes in correctly in one pngand not the other.
Photo of Michelle Sharron

Michelle Sharron

  • 14 Posts
  • 2 Reply Likes
  • frustrated

Posted 4 months ago

  • 1
Photo of Dubie

Dubie

  • 962 Posts
  • 742 Reply Likes
I'll just take a stab here but did you paste the copy of the 1st png to a new image in Snagit ?

If so was the canvas of the new image set to transparent before you pasted to it ?




:)
(Edited)
Photo of Michelle Sharron

Michelle Sharron

  • 14 Posts
  • 2 Reply Likes
I did a Save As, not a copy and paste. In Snagit both pngs have a transparent background. When I import to Camtasia, only one has the transparent background.
Photo of Dubie

Dubie

  • 942 Posts
  • 716 Reply Likes
Ok I may have misunderstood, I was just going off of what you posted.

"In fact the 2nd one was created as a copy/paste of the first


So was the first image created in Snagit and then saved as a .png with transparent background?

Did you make any edits to the second  image before saving as ?


It's possible Snagit's Save As .png settings are wrong.

To check... with the editor open click the blue share button and then the gear icon
and select "Save As Preferences..."



Then select the png format click the options button.



Make sure Colors is set to transparency.




:)

(Edited)
Photo of Michelle Sharron

Michelle Sharron

  • 14 Posts
  • 2 Reply Likes
Yes, the first image was created in Snagit and then saved as a .png with transparent background.
I edited the already existing text box on the 2nd image. 
I checked SnagIt's Save As .png settings and they correspond to your screen shots.

Photo of Michelle Sharron

Michelle Sharron

  • 14 Posts
  • 2 Reply Likes
I just went back and resaved everything and now the transparency shows as intended. Not sure what happened there but thanks for your help.
Photo of Dubie

Dubie

  • 942 Posts
  • 716 Reply Likes
Awesome !!


Snagit must have just felt like jok'in with ya :)