Transparent background not saving as transparent.

  • 1
  • Question
  • Updated 9 months ago
Using Snagit 13.1 I click Image, choose Canvas Color.. and choose transparent background. The background appropriately changes to the checkerboard. I save the image, close it and open it again. The background is no longer transparent. What do I do to make it stay transparent?
Photo of Diane Fallier

Diane Fallier

  • 3 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Rick Grunwald

Rick Grunwald

  • 1249 Posts
  • 856 Reply Likes
What are you saving it as? SNAG PNG GIF and PSD are ones that support transparency (there are probably a couple of others that I never use. I think ICO also respects transparency)
JPG will tunt the transparency to white. Try saving in a PNG if you have not already done so
Photo of Diane Fallier

Diane Fallier

  • 3 Posts
  • 0 Reply Likes
I'm saving as a PNG. I was able to make the background transparent and save it in paint.net but it would be nice if Snagit worked for this.
Photo of Rick Grunwald

Rick Grunwald

  • 1249 Posts
  • 856 Reply Likes
I just imported a cut out into snagit, saved it out as a PNG and it came up in Affinity Photo with a transparent background. 
Is this what you were doing?
Here is my export from Snagit to PNG.. If it is not coming up with a transparent background for you then the problem may be further down the line such as a setting somewhere 9I was not finished with this cutout so it is rough) I detached the pic below and it came up in Affinity with a transparent background
(Edited)
Photo of Diane Fallier

Diane Fallier

  • 3 Posts
  • 0 Reply Likes
I was working on a logo setting the background to transparent. The logo looks fine as long as it's in Snagit. But when I save it and bring it back in to Snagit it's no longer transparent. I haven't tried it on any other graphic. 
Photo of Rick Grunwald

Rick Grunwald

  • 1249 Posts
  • 856 Reply Likes
I have no idea of what happened but that did not have a transparent background
This one does. I tubed out the white in the dingbat at the top right ...
Save this and see if it does what you want
I don't know to what extent you play with graphics but bringing the white background on top of a transparent base gives you a white background. All the white has to be removed. You should be able to use the bucket to "pour" the color "transparent" into the major white spaces
Photo of Lee

Lee

  • 1 Post
  • 4 Reply Likes
Hi I had the same problem. After much frustration I've found the solution. I figured that when you save you need to select Options in the Save As dialog and select the True color + transparency (32-bit) option from the Colors droddown list in the File Format dialog each time you save. I clicked on the Default to try and make this selection the default so that you don't need to do this every time you save. But it appears, the Default function is not working.
Photo of bpepin

bpepin

  • 1 Post
  • 2 Reply Likes
Thanks so much, Lee, for this post!  I lost WAAAAAY too much time trying to figure this out and finally came up with the right search terms to find this article. Hooraaaay!
Photo of mkrajewski

mkrajewski

  • 1 Post
  • 2 Reply Likes

Thank you - I don't know why that made a difference but it did...was tearing my hair out!

Photo of Rick Grunwald

Rick Grunwald

  • 1249 Posts
  • 856 Reply Likes
Try going into the editor and from the menu SHARE / SAVE AS PREFERENCES / ALWAYS SAVE AS and choose the PNG format. The options button will light up and from there choose the tru color option and then ok
Go back in and select last used it yo want that but the PNG depth should be set

Someone may come up with something else but if not and mine does not work then You can Submit a ticket
       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday