tunnel sound effect from midi source...

  • 1
  • Question
  • Updated 7 years ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Inactive threads; archiving to prevent necroposing

Hello. I bought Camtasia studio some time back and I use it for recording music scores as they progress across the screen. The sound from the sequencer is a midi sound source. Most of the time it works very well and then suddenly in the middle of a piece the sound gets distorted - almost as if you hear it down a tunnel. Are there things i can try in Camtasia to beat this?
I should say that from the beginning I can't record any sound unless I choose another option for th sound and then "rechoose" the default option! I've learned to live with that but I don't know if this new phenomen is linked to it.
Thanks in advance
Keith Braithwaite
Photo of Keith Braithwaite

Keith Braithwaite

  • 7 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Randy Schott

Randy Schott

  • 396 Posts
  • 47 Reply Likes
Hi Keith,

Are you hearing this issue *during* recording, or when playing back the recording afterwards? Also, does this happen for all scores that you try to record or just a particular song?

It's possible that the combination of recording the screen and generating sound from the midi score is causing glitching in the audio, either because Recorder misses a few audio buffers while capturing, or because your composing software loses out on a few cycles and generates a glitch in the audio it is sending out.

I know it's not a perfect workflow, but you could try just recording the video, then exporting the audio track from your midi composer and syncing them up in the Camtasia Studio editor. I guess that assumes that your score software allows you to export to a wav/mp3 file, but it might work if we can't get the distortion issue solved.

Randy
Photo of Keith Braithwaite

Keith Braithwaite

  • 7 Posts
  • 0 Reply Likes
Thanks for getting back to me. No problems during the recording - the playback in the sequencer is more or less perfect (I use Finale 2012 with either midi sounds or Garritan sounds). The problem appears when I playback the MP4 file immediately afterwards in Camtasia Sudio or on playback from my site. A typical example is here, especially after the 10th bar:

http://www.kb-muse.com/S/jubilemus-2-...

Strangely enough this didn't happen when using the 2011 version of my sequencer as you can hear on this page:

http://www.kb-muse.com/S/bach-aria-s-...

I suspect there's something wrong with the sequencer output though it's not detectable on normal sequencer playback. Unfortunately I don't have much access to midi controls in this sequencer.
I'll try syncing the MP3 ouput but this would add a lot of time to an already fairly heavy process making these practice files for choir singers and musicians.

You can hear the same effect here in a file I made to help a concert band conductor to conduct a difficult passage:

http://www.kb-muse.com/LC/

It goes really funny in thethird bar after the letter F (there are four recordings of the same thing in the file for practice purposes.)

Odd this thing about having to select a different sound source and then reselect the original sound source for the recording to work...

Any help gratefully accepted - and once again thanks for getting back to me

Keith
Photo of Randy Schott

Randy Schott

  • 396 Posts
  • 47 Reply Likes
I listened to one of the recordings, and I think I know what you're talking about.

A few questions:

I notice you mentioned an MP4 file. Recorder doesn't produce mp4s, just AVIs and CAMRECS. So, are you talking about the produced MP4 from Camtasia Studio?

In the video you linked to, it sounds like typical audio compression artifacts. Do you hear the audio issues when playing things back in the Camtasia Studio editor?

If you do, then you could try adjusting the audio settings in Camtasia Recorder to use a higher bitrate. I think the default is intended for voice capture, so it doesn't do so well with broader-spectrum audio.

If things sound fine in the editor, it might be the production settings. I think our default presets are also optimized for voice content.
You could try using the "Custom Production Settings" path in the production wizard, going to MP4, using the "No controls" option and adjusting the audio bitrate to a higher value. The audio bitrate is found under the "Flash Options" dialog.

Here's a quick screencast to show you what I'm talking about:
http://screencast.com/t/AjgbiL1bc
Photo of Keith Braithwaite

Keith Braithwaite

  • 7 Posts
  • 0 Reply Likes
You're right - in talking about the MP4 file I was referring to the web output from Camtasia, however the strange effect is already there in the recorder.
I did try boosting the bit rate from 11000 to 22000 (approximate figures from memory) but it didn't change things.
I'll look at the screencast and I'll try the "No controls" option unless that only affects the web output. (The strange sounds are already there in the editor so I suppose the problem is either in my sequencer output or in the Camtasia Recorder capture.

I'm going to do a few short sequencer files to see whether different midi input methods change the output. For instance I have the impression that when I copy notes from one line of music to another rather than typing them in directly from my piano keyboard the result is different in the Camtasia output. I can't really consider that the problem is in the capture without making sure that there are no glitches in my sequencer output.
Unfortunately as I already said I haven't got access to the midi elements in my sequencer so I can't really analyse the output except by ear, and playback from the sequencer is normal without any real changes.in the sound.
Photo of Randy Schott

Randy Schott

  • 396 Posts
  • 47 Reply Likes
If you already hear the issue in the editor, then it's definitely not the production settings, so I wouldn't bother messing with that.

You could also try switching the audio encoding in recorder to use PCM instead of MP3. The file size will be larger, but if the problem still persists with PCM, then it at least isolates the cause to the Recorder or the sequencer, not the encoding parameters.
Photo of Keith Braithwaite

Keith Braithwaite

  • 7 Posts
  • 0 Reply Likes
I'm already on PCM...
Photo of Randy Schott

Randy Schott

  • 396 Posts
  • 47 Reply Likes
Answers that question then :-). I'm running out of ideas here. You might have to get in touch with tech support. They have more options for helping to diagnose the exact problem.

You can create an account and submit a ticket here:
http://techsmith.custhelp.com/app/uti...

I'm sorry I couldn't help you figure it out, let me know if support is able to solve the problem for you

Randy
Photo of Keith Braithwaite

Keith Braithwaite

  • 7 Posts
  • 0 Reply Likes
I'll get in touch with tech support but just one more thing...
I wanted to make a series of video captures to go along with the score I recorded for Back to the future - the difficult passage - and lo and behold, I got the tunnel effect again as you can see on this extract (no careful screen organisation, just a test recording...)

http://www.kb-muse.com/BTTF/

That seems to mean that my sequencer is not at fault. What's left? My sound card - unchanged since the "good" recordings of which I gave you an example...
Choice of sound source "volume CD" - doesn't seem to want to accept anything else. How could I change this? It's a Realtek high definition card.

I'll put the problem to tech support also
Many thanks once again
Keith

This conversation is no longer open for comments or replies.