Two audio tracks camtasia bug.

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
I have a .mp4 video file with two audio tracks (microphone and system sound).
When i paste the file in camtasia, camtasia dont show/reproduces the system sound audio track, camtasia only show and reproduces the microphone track.
Have some solution for this?
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 0 Reply Likes
  • sad

Posted 3 months ago

  • 1
Photo of David Demyan

David Demyan

  • 74 Posts
  • 51 Reply Likes
To keep system sound synchronized with the video recording, the system audio is embedded into the same clip so only one shows on the timeline. The microphone audio displays as a separate track. You can edit the audio within the video clip (system audio) the same way you would if it were separate. Right-click video clip on timeline and select Edit audio. If you want to see them separately, you split them out by right-clicking and selecting Separate Audio and Video. If you do, system audio may be come un-synchronized with video when / if you make edits.
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 0 Reply Likes
"Right-click video clip on timeline and select Edit audio". it's returning a empty audio (but in original file, its not empty, just in camtasia). That's the problem.
https://imgur.com/4NSbJOv
(Edited)
Photo of David Demyan

David Demyan

  • 74 Posts
  • 51 Reply Likes
My apology. I assumed (and you did say it was an MP4) that your file was a screen recording. My comments only apply to screen recordings. Without seeing the original files and Camtasia project files, I cannot imagine why it's not working the way it is supposed to. I suggest submitting it to Camtasia support.
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 0 Reply Likes
Yes, its a screen recording, the speakers in image are part of the video (recorded with NVIDIA ShadowPlay).

Here is a mp4 file that i recorded: https://drive.google.com/open?id=18IpSDoluE1ajK-56Nxmw5DTIUGW9pWD1

It is just a example video, camtasia cant read/reproduce any the videos I record with ShadowPlay.

When i paste this file in camtasia, camtasia cant read/reproduce this sound.
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 6655 Posts
  • 3660 Reply Likes
Try updating your Nvidia drivers. Make sure Camtasia is fully updated.

Camtasia has no problem reading and playing back audio from my Shadow play recordings. This includes Camtasia 8,9,and 2018.

Regards,Joe
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 0 Reply Likes
The driver is up to date, this problem only occurs when I use the audio recording in the "separate the two tracks" option, it seems that there is no way. I'll need to convert the audio to another application and then edit it on camtasia.
Photo of Jack Fruh

Jack Fruh, Champion

  • 552 Posts
  • 174 Reply Likes
Hi Pedro, Is the file something you can share? I would love to take a look at it with mediainfo to see what it's track layout is.
Photo of Joe Morgan

Joe Morgan

  • 6611 Posts
  • 3641 Reply Likes
I stand corrected Jack Fruh,
I was sure Shadowplay gave you a separate audio file for system audio when you separated the 2 audio streams. Nvidia support wasn't much help, they tried for almost an hour to figure out where that audio track was being saved to and are still looking.LOL

I re-read this thread, opened a test video in Adobe's Auditions and there was both of my audio tracks. So I deleted my incorrect post.

I don't use the Shadowplay recorder much. I don't record game play to share online. I record some to run tests.That's about it.

Camtasia is my preferred recorder for screen recordings.

 

(Edited)
Photo of Jack Fruh

Jack Fruh, Champion

  • 552 Posts
  • 174 Reply Likes
Thanks Joe, I think this is still valuable feedback - Pedro's sample file had 4 tracks but I only heard audio on 2 of them, Your research confirms the MP4 Nvidia spits out 4 active tracks.

As far as I know, Camtasia has never dealt with anything more than 2 channel audio per clip/track, so I don't even know if this is fair to consider a 'bug'.

Pedro, please let us know what workflow you end up with!
Photo of Joe Morgan

Joe Morgan

  • 6611 Posts
  • 3641 Reply Likes
Yeah, this is not Camtasia's fault.
Extracting the audio in Audition and importing it would be my go to move.
I'm not sure why I thought Nvidia would record a separate audio file?

I don't know if Audacity imports videos or not? That seems like the easiest solution.

Shadowplay is a good 30 or 60 fps video recorder because it runs 100% off the graphics card.

Any Program or Game that puts a crushing load on the CPU can really benefit from this recorder for recording purposes. The CPU is left alone to do its job. 
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 0 Reply Likes
Well, the problem is solved when I record the videos in single track with ShadowPlay. But with videos already in two tracks, the only way out is to convert the audio using another application? It would take a long time, because i have a lot of files.
Photo of rg

rg

  • 197 Posts
  • 132 Reply Likes
Re Joe's comment "I don't know if Audacity imports videos or not" -- Audacity will import the audio from a video stream (e.g. the audio from an MP4) as long as the corresponding plug-in is installed.  After importing, I recommend outputting in WAV format to retain as much of the quality as possible (although if you're starting with MP4, the audio has already been pre-mangled).