Two audio tracks camtasia bug.

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)
I have a .mp4 video file with two audio tracks (microphone and system sound).
When i paste the file in camtasia, camtasia dont show/reproduces the system sound audio track, camtasia only show and reproduces the microphone track.
Have some solution for this?
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 1 Reply Like
  • sad

Posted 8 months ago

  • 1
Photo of David Demyan

David Demyan

  • 83 Posts
  • 56 Reply Likes
To keep system sound synchronized with the video recording, the system audio is embedded into the same clip so only one shows on the timeline. The microphone audio displays as a separate track. You can edit the audio within the video clip (system audio) the same way you would if it were separate. Right-click video clip on timeline and select Edit audio. If you want to see them separately, you split them out by right-clicking and selecting Separate Audio and Video. If you do, system audio may be come un-synchronized with video when / if you make edits.
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 1 Reply Like
"Right-click video clip on timeline and select Edit audio". it's returning a empty audio (but in original file, its not empty, just in camtasia). That's the problem.
https://imgur.com/4NSbJOv
(Edited)
Photo of David Demyan

David Demyan

  • 83 Posts
  • 56 Reply Likes
My apology. I assumed (and you did say it was an MP4) that your file was a screen recording. My comments only apply to screen recordings. Without seeing the original files and Camtasia project files, I cannot imagine why it's not working the way it is supposed to. I suggest submitting it to Camtasia support.
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 1 Reply Like
Yes, its a screen recording, the speakers in image are part of the video (recorded with NVIDIA ShadowPlay).

Here is a mp4 file that i recorded: https://drive.google.com/open?id=18IpSDoluE1ajK-56Nxmw5DTIUGW9pWD1

It is just a example video, camtasia cant read/reproduce any the videos I record with ShadowPlay.

When i paste this file in camtasia, camtasia cant read/reproduce this sound.
(Edited)
Photo of Joe Morgan

Joe Morgan

  • 7305 Posts
  • 3995 Reply Likes
Try updating your Nvidia drivers. Make sure Camtasia is fully updated.

Camtasia has no problem reading and playing back audio from my Shadow play recordings. This includes Camtasia 8,9,and 2018.

Regards,Joe
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 1 Reply Like
The driver is up to date, this problem only occurs when I use the audio recording in the "separate the two tracks" option, it seems that there is no way. I'll need to convert the audio to another application and then edit it on camtasia.
Photo of Jack Fruh

Jack Fruh, Champion

  • 575 Posts
  • 197 Reply Likes
Hi Pedro, Is the file something you can share? I would love to take a look at it with mediainfo to see what it's track layout is.
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 1 Reply Like
to explain my problem, i recorded a sample video.

here is the mediainfo from video file: https://imgur.com/GvpbAR8
here is the audio returned from camtasia (camtasia returns empty audio BUT is not empty): https://imgur.com/4NSbJOv

after edit the video file in camtasia, camtasia remove/dont read his audio.

videos: 
original video (without camtasia): https://youtu.be/kevXl6Z9bP8
edited video with camtasia: https://youtu.be/Anxo1oJt-Ls
Photo of Jack Fruh

Jack Fruh, Champion

  • 575 Posts
  • 197 Reply Likes
Hi Pedro, this is what I suspected, you have two different audio streams in your mp4 container. Camtasia only supports one stream per file, and in this case it seems it's picking up the 2nd stream, which in this case is silent.

There are two ways you can fix this:

1) For new content, try recording in Camtasia instead of using NVidia Shadowplay, Using this method you'll capture 4 audio tracks, 2 from the application and up to 2 from a microphone. The timeline will look like David described one track will have both audio and video and one will have audio only.

2) For existing content, or if you find a recording advantage with NVidia Shadowplay, use a converter tool to extract the 1st audio stream to a stand alone audio file.
Then import both the original MP4, and the stand alone audio file into Camtasia.

Notes on converter tools:
I tried a bunch and ran into a ton of roadblocks
Handbreak will let you choose the audio track, but it always exports video to - this is not desirable.
VLC - opens the file but it's export functionality didn't let me choose which audio track.
    Thinking the first track is what we want, I tried it anyways, but the resulting file was unusable (2x longer and audio was messed up.
FFMPEG - Would likely work but is a command line utility.
REAPER - This worked for me, I dropped the track in reaper, "rendered" as a wav file and imported into Camtasia and it was perfect.
Audacity - Would not import the AAC file (I tried on Windows)
  Audacity by default doesn't support AAC files (On windows), but it is possible to get it to work by adding FFMPEG




(Edited)
Photo of Jack Fruh

Jack Fruh, Champion

  • 575 Posts
  • 197 Reply Likes
Pedro, one more thought, In GeForce Experience, on the far right is a gear,  If I click that, and then go down to Audio, there's an option for Audio tracks "Create a Single Track" - while not ideal, I presume the resulting MP4 would have only one audio track as shown in mediainfo, and would import properly into Camtasia. (By not ideal, I presume there's some value in having a separate mic vs app track and you'd lose that with this method)
Photo of Joe Morgan

Joe Morgan

  • 7429 Posts
  • 4061 Reply Likes
I stand corrected Jack Fruh,
I was sure Shadowplay gave you a separate audio file for system audio when you separated the 2 audio streams. Nvidia support wasn't much help, they tried for almost an hour to figure out where that audio track was being saved to and are still looking.LOL

I re-read this thread, opened a test video in Adobe's Auditions and there was both of my audio tracks. So I deleted my incorrect post.

I don't use the Shadowplay recorder much. I don't record game play to share online. I record some to run tests.That's about it.

Camtasia is my preferred recorder for screen recordings.

 

(Edited)
Photo of Jack Fruh

Jack Fruh, Champion

  • 575 Posts
  • 197 Reply Likes
Thanks Joe, I think this is still valuable feedback - Pedro's sample file had 4 tracks but I only heard audio on 2 of them, Your research confirms the MP4 Nvidia spits out 4 active tracks.

As far as I know, Camtasia has never dealt with anything more than 2 channel audio per clip/track, so I don't even know if this is fair to consider a 'bug'.

Pedro, please let us know what workflow you end up with!
Photo of Joe Morgan

Joe Morgan

  • 7429 Posts
  • 4061 Reply Likes
Yeah, this is not Camtasia's fault.
Extracting the audio in Audition and importing it would be my go to move.
I'm not sure why I thought Nvidia would record a separate audio file?

I don't know if Audacity imports videos or not? That seems like the easiest solution.

Shadowplay is a good 30 or 60 fps video recorder because it runs 100% off the graphics card.

Any Program or Game that puts a crushing load on the CPU can really benefit from this recorder for recording purposes. The CPU is left alone to do its job. 
Photo of Pedro Duarte

Pedro Duarte

  • 6 Posts
  • 1 Reply Like
Well, the problem is solved when I record the videos in single track with ShadowPlay. But with videos already in two tracks, the only way out is to convert the audio using another application? It would take a long time, because i have a lot of files.
Photo of rg

rg

  • 236 Posts
  • 165 Reply Likes
Re Joe's comment "I don't know if Audacity imports videos or not" -- Audacity will import the audio from a video stream (e.g. the audio from an MP4) as long as the corresponding plug-in is installed.  After importing, I recommend outputting in WAV format to retain as much of the quality as possible (although if you're starting with MP4, the audio has already been pre-mangled).