Unable to apply italics or bold to existing text in an Annotation

  • 1
  • Problem
  • Updated 12 months ago

When editing text within an Annotation callout, you cannot apply bold or italics with certain fonts while with others, it seems to work OK. I'm currently using Camtasia v9.0.1 (build 1422). When I reported it to TS tech support, agent JimmyB said, "I just talked with my senior adviser on this. The bug (not fixed) is that in Camtasia, it shows all the font options like bold and italics for all fonts, however, not all fonts support all those options at the moment"

Steps to replicate the issue:

  1. Start a new project.
  2. Add an annotation to your project (I chose the red box-cornered speech bubble)
  3. Double-click the ABC text in the annotation, and type "This is a test"
  4. Now, select the word "is" and press the Ctrl+I keyboard shortcut. "is" should be italicized now, but it doesn't appear italicized in the callout/annotation. The style of the font in the Properties tab shows "Regular Italic", yet the word "is" is not italicized as expected. Same problem occurs if you try to apply bold.

Camtasia 9 appears to use the "Monserrat" font by default in these callouts; but apparently Camtasia 9 doesn't yet support bold/italics with this font. I tested Arial, and it works with Arial font just fine.

Ideas for fixes that TechSmith should consider to resolve this issue are:

  • Camtasia should default to a font for which bold/italics is actually possible. Use Arial, not Monserrat, for example
  • Allow bold/italics to be applied regardless of the font being used in a callout.




Photo of jake.d

jake.d

  • 1 Post
  • 0 Reply Likes

Posted 12 months ago

  • 1
Photo of Fred Grover

Fred Grover, Champion

  • 2335 Posts
  • 333 Reply Likes
jake.d ot sure if this will help you or not but have you updated to the latest version of Camtasia Studio 9.1.1 that was released on November 16th, 2017 ? The link for the updated versions if you did not already have this information is below. It will tell you what has been updated and fixed. Just something for you to check out and maybe someone from TechSmith will also pop in here or another user and give their opinion or view if it now works for them. Thanks for posting and have a great day/night. Hope this helps a little and let us know by posting back. Thanks.

https://support.techsmith.com/hc/en-us/articles/115006443267-Camtasia-Windows-9-Version-History

This is a great link that I have bookmarked for reference and checking things out. Great resource in my opinion.