Unable to Connect to Quiz Service (with Solution)

  • 1
  • Problem
  • Updated 3 months ago
I had been working on a video with a quiz (actually two) all week. Several times I had published a trial version and uploaded to screencast.com. Then, when I had the 50 question quiz entered and everything finalized, I tried to produce a video with Smart Player. I got an error message, "Unable to Connect to Quiz Service". My internet connection was fine, and I had been able to produce Smart Player videos earlier.

Quick answer:  There were several ampersands (&) in my quiz.  Camtasia did not like that.  I removed them and it worked fine.

Longer answer: The .tscproj files are just text files.  You can open them with a text editor like Notepad or notepad++.  BE CAREFUL POKING AROUND.  MAYBE USE A COPY.  THIS IS YOUR PROJECT FILE AND A STRAY COMMA OR BRACKET COULD RUIN EVERYTHING.

The file is a JSON file, mostly. Down near the bottom, you'll see something like:
   "parameters" : {
      "quiz" : {
        "type" : "string",
        "keyframes" : [
          {
            "time" : 270,
            "value" : "<Quiz id=\"1001\" name=\"Test\"><Options feedback=\"0\" graded=\"1\"/><Questions>...</Questions></Quiz>",
            "duration" : 0
          }
        ]
      }
    }, 
The part after "value" : is the quiz and it's actually XML.  All of your questions and answers will be in one long row between the <Questions></Questions> tags.  If you have more than one quiz, there will be a time/value/duration element for each one.

Since this is all just text, I got the idea that it might be a simple wrong character like a comma or bracket in the wrong place.  At first I thought it was a stray backslash causing problems, but I only had forward slashes in my quiz.  I used the process of elimination by deleting half the questions and saving the text file.  Then I would open it in Camtasia and try to produce the video.  If it didn't work, I would eliminate half of that half.  I quickly got down to a few questions and once I saw the ampersand, I knew what it was.  I could have used a search and replace, but to be on the safe side, I opened my original project file and edited the actual quiz questions.  Worked like a charm.

I hope this helps anyone else that has the same or a similar problem.

Photo of GaryB

GaryB

  • 1 Post
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of davemillman

davemillman

  • 710 Posts
  • 252 Reply Likes
Thanks GaryB!