Unable to initialize the audio. If the problem persists, select another microphone or contact Tech. Support. V13.1 I did not have this prob.

  • 3
  • Problem
  • Updated 1 month ago

Unable to initialize the audio. If the problem persists, select another microphone or contact Tech. Support. V13.1 I did not have this problem in the earlier version..

It has so many bugs in the version though there so many nice features are relased in this version..

but I am here unfortunately to tell you the things are not working;

The most critical one is the one about audio..I have followed below link the instruuctions

https://support.techsmith.com/hc/en-us/articles/211117907-Snagit-Windows-Troubleshoot-Audio

but it simply does not help at all . I totally disabled all my microphones and audio devices

Photo of Volkan Gündoğdu

Volkan Gündoğdu

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 3
Photo of bobbykey

bobbykey

  • 1 Post
  • 0 Reply Likes
Did you find out anything? I have the exact same problem, have tried the troubleshooting with no luck.
Photo of troy.scott

troy.scott

  • 1 Post
  • 0 Reply Likes
This software is a joke now, i'm going too be doiong a credit card chargeback tomorrow.  They have been aware of this issue for nearly a year and havnt bothered to fix it.
Photo of Danilo Quintiliano

Danilo Quintiliano

  • 1 Post
  • 0 Reply Likes
im with the same problem!!! Some one have a solution?
Photo of andrewjens

andrewjens

  • 1 Post
  • 1 Reply Like
I was getting the same error when I tried to video capture a piece of the screen on my laptop. Here are some things that I tried:
  • I've disabled the microphone on my laptop.
  • I turned off "Record Microphone" in SnagIt's preferences.
  • I also tried it in airplane mode (to see if there were any Bluetooth audio issues).
  • I updated the microphone drivers.
  • I don't have the "Enable Audio Enhancements" option, so I couldn't try that.
  • I tried unchecking the "Allow applications to take exclusive control" option.
  • I tried setting AllowMfAudioCapture to 0 in the registry.
  • I'm using an MSI laptop so I killed all the Nahimic drivers.
None of that worked.

Here's the thing I changed to make it work:
  • The microphone's Default Format was set at "DVD Quality" (48000 Hz) so I changed it to "CD Quality" (44000 Hz).
Video screen capture worked fine.

Hope it helps someone.

Photo of nordwest.voviy

nordwest.voviy

  • 2 Posts
  • 0 Reply Likes
Fixed for me.
Photo of florent bouix

florent bouix

  • 1 Post
  • 0 Reply Likes
Snagit 2018 - Tried everything mentionned before and tech support but problem still there. Will ask to my company to remove this software and look for another one. Just one thing my company is about 60.000 users. If techsmith is reading, hope it will convince you to issue a patch and fix this problem. Configuration win 10 on hp spectre x360. BTW will propose alternatives to my IT department.
(Edited)
Photo of Derek C

Derek C

  • 3 Posts
  • 0 Reply Likes
I've also run into this problem with the 2019 version.  Like many that seem to have this problem, I'm on an MSI laptop (GE72 6QF Apache Pro).

What (so far) seems to work for me is to turn off the Nahimic audio driver.

Then  using regedit, go to feature control for Snagit under: Computer\HKEY_CURRENT_USER\Software\TechSmith\Features\snagit

Other posts say to set AllowMfAudioCapture value to 0. 
I tried that and it worked once, but then the problem came back.

But I then set AllowMfDeviceDiscovery also to 0. 
(Edit: Device discovery appears to be the key, perhaps a typo in the support post that people are referencing. Setting this to 0 and it doesn't seem to matter whether AudioCapture is on or not).

Now capture is working every time (so far!).

Also the recording system audio and microphone (I use a USB Blue Snoball) are working properly, so disabling device discovery doesn't seem to affect that (for me).


In Summary:
1) turn off Nahimic Driver
2) set Computer\HKEY_CURRENT_USER\Software\TechSmith\Features\snagit\AllowMfDeviceDiscovery  to 0
(Edited)
Photo of OzNotKansas

OzNotKansas

  • 1 Post
  • 0 Reply Likes
Have had this problem and tried every remedy mentioned in the forum and in the Help, without success. Same issues with version 2018. Eventually returned to version 13 and can now record screen video without audio. Seemed like a great idea at the time - "new features"  "NEW NEW" - so I rushed out and got the latest and not so greatest :-)
Photo of nordwest.voviy

nordwest.voviy

  • 2 Posts
  • 0 Reply Likes
I was able to find a workaround.

1) Here's the thing I changed to make it work:
The microphone's Default Format was set at "DVD Quality" (48000 Hz) so I changed it to "CD Quality" (44000 Hz). 
2) start Snagit as Administrator

If you want Snagit being started on system logon then you can create the corresponding task in Scheduler which will start snagit automatically after login. Just make sure that "Run with highest privileges" checkbox is selected.