Unable to produce a video as an mp4 and still have smart player options. I need this quiz in my video.

  • 1
  • Question
  • Updated 2 months ago
Help. I am producing my first video , it has a quiz and a timeline however I get the message that says unable to locate the lms's api and I am not getting any of the smart player options. I did produce this as an mp4.
Photo of dkarels

dkarels

  • 4 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 1
Photo of johnw

johnw

  • 3 Posts
  • 2 Reply Likes
dkarels, where is the video being posted?  I think you might have to use Relay or Screencast to get that functionality.  A few years ago I had a screencast account with Techsmith and embedded an assignment in the video - worked like a charm!  There might be some LMSes that offer the functionality, too.
Photo of Ben Rhodes

Ben Rhodes, Employee

  • 421 Posts
  • 152 Reply Likes
@dkarels,

When you produced your video you must have checked the SCORM option.  This will wrap your video and our TechSmith Smart Player in a SCORM package.  A SCORM package is designed to integrate easier into a LMS (Learning management system).  The TechSmith Smart Player will display that error message you described when viewing the video outside of a proper SCORM environment.

You will need to produce the video again.  This time in the production wizard look for the SCORM checkbox and make sure it is unchecked.  Camtasia will produce a folder with the video and HTML that will allow you to playback the video without that error.

Let me know if you have any other questions,
Ben