Unable to sync captions due to lag time when clicking words to match up with audio.

  • 5
  • Problem
  • Updated 6 years ago
  • Solved
I'm trying to sync captions imported from Powerpoint with my audio and video. However, when I use the "sync captions" feature there is a several second "lag" every time I click on a word to mark the caption. As a result I can't properly sync the captions. I don't know what to do! Any help is appreciated.
Photo of heatherbblades

heatherbblades

  • 1 Post
  • 0 Reply Likes

Posted 8 years ago

  • 5
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2899 Posts
  • 653 Reply Likes
Hello,
I'm sorry you are having trouble.

I don't know what would be causing the lag time. Have you tried saving your project then exiting out of Camtasia Studio and reopening it?

Nevertheless, each caption is an independent object on the timeline. So, you are able to drag the edges of the captions to change their location and duration so as to sync up correctly with the audio.

If you open the help file, do a search for "Manually Add and Sync Captions". On that help page you will find both written instruction and a video tutorial showing you how to manually sync your captions.

Let us know if this works for you!
Kelly
Photo of crmussels

crmussels

  • 2 Posts
  • 0 Reply Likes
I found the same problem in Camtasia 7.1.1. If I try to sync captions, the interface lags so much that I am unable to click on a word and have it display correctly.

The problem seems to be a bug that was introduced for 7.1.1, when I uninstalled and went back to 7.1 (which has the new caption system) it works fine.

Hopefully the Techsmith will be able to test and fix this problem for the next release because doing captions manually and having to re-install software is very time-consuming.
Photo of Heather

Heather

  • 2 Posts
  • 0 Reply Likes
I have been working with a project for several days and just started to have this problem yesterday. I have tried restarting with no success. I am on a limited time budget for the project so I will just have to put it on hold until a solution is found.
Photo of Cameron Flint

Cameron Flint

  • 253 Posts
  • 17 Reply Likes
Heather,

I'm very sorry that you are experiencing this issue!

In my experiments, Camtasia Studio 7.1 can perform badly with significantly large scripts (a large amount of text in the Captions view). Here's a workaround you can try: before syncing captions, right-click in the caption area and choose Select All and Cut, then open Notepad and right-click > Paste the entire script. Then, try syncing your captions in smaller chunks by copying three or four paragraphs at a time back into the Captions view and clicking "Sync captions."

I know this isn't an ideal workaround, but hopefully it will get you farther along.
Photo of Heather

Heather

  • 2 Posts
  • 0 Reply Likes
Thanks for the idea, unfortunaly I was doing this in the first place since I am slowly inserting the text from a powerpoint slide by slide. Another interesting note is that I am not having this problem on other presentations I am working on. I am going to continue to work on those until the same things happens and then perhaps I will know the point that it slows down.
Photo of Guido Leenders

Guido Leenders

  • 12 Posts
  • 1 Reply Like
I am having the same problem on version 7.1.1. The size of the accumulated captions is approximately 13Kb. Delays vary between 2 and 15 seconds. Video keeps running, but creating a new caption seems to have been implemented inefficiently. Camtasia has some nice features and is definitely more usable than the Creatve Suite of Adobe which we use on Mac. But such features make me unhappy. I hope a new version will be released soon, this one is one year old.
Photo of kayakman

kayakman, Champion

  • 7177 Posts
  • 2388 Reply Likes
These workarounds might help [?] ...

Instead of clicking on words to create the caption point, select some caption text, then, with focus on timeline, use the A key shortcut to add the caption point, then ctl-V to paste the [copied] text.

Or, if your captions are identical to narration, try using the speech-to-text ffunction; select a short narrated section, then right click to use the STT function for only the selection. This works excellently for me.
Photo of Guido Leenders

Guido Leenders

  • 12 Posts
  • 1 Reply Like
With the workaround, I was able to get the captions synced.
Photo of Steven Garske

Steven Garske, Employee

  • 61 Posts
  • 13 Reply Likes
Official Response
Hello Everyone,

I may have some good news about your problems with lag while using sync captions. We just released Camtasia Studio 8 and you might be happy to learn that we improved some performance bottlenecks that may have been the cause of the lag.

First, captions in Camtasia Studio 8 should now perform much better when they contain a lot of text such as the case of pasting in a large script. You should notice improvements in how much faster it is to paste, edit, and split captions with that much text.

Second, if the lag you were witnessing was more of an issue of the playback, our new rendering engine in Camtasia Studio 8 should result in less playhead jumpiness and stuttering, allowing you to be more accurate with your timing.

It’s possible some lag may still occur on slower systems or cases with a complicated timeline or lots of caption objects. In that case, many of the workaround posted here should still help. Hopefully the new caption workflow allows a much smoother experience when correcting any potential timing problems as well.

You can learn more about what's new in Camtasia Studio 8 here: http://www.techsmith.com/camtasia-wha...

You can even download and try the fully functional trial for 30 days without having to uninstall your previous version of Camtasia Studio.

Thanks again for your feedback. We hope you will try Camtasia Studio 8, and let us know what you think about the new Captions workflow or any other feedback you may have!

-Steven
Photo of mdala

mdala

  • 1 Post
  • 0 Reply Likes
Imported a 40 minute audio to caption and after editing about 8 minutes of it the playhead became jumpy. Do I need to split the lecture into 8 minutes segments? Other options?
Photo of Steven Garske

Steven Garske, Employee

  • 61 Posts
  • 13 Reply Likes
Hi mdala,

It's possible a heavily edited timeline could be the result of the slowdown.  This is common when cutting out little chucks of audio (such as um's or ah's) which leaves behind a lot of little media.  However, there are a number of other factors including your editing dimensions, type of source content, hardware capabilities, etc. that could affect playback performance. 

It is a good idea to clean up your timeline as much as you can.  If you have a section that is done being edited you can make a range selection with the playhead and produce just that section out (File -> Produce Special -> Produce select as... or right click the selection area).  Then import that media and place it on the timeline to replace your edited clips so you'll be working with just a few media instead of tens to hundreds.

If you're still having performance issues, it might be best to talk to our excellent support staff who can help diagnose it further: https://support.techsmith.com/home

Hope this helps,
- Steven

(Edited)
Photo of Deb Reynolds

Deb Reynolds

  • 28 Posts
  • 0 Reply Likes
Unfortunately I am having difficulties with editing speech-to-text in Cam8, particularly when I have the Preview pane *undocked*. (It does seem to go better in Cam8 when the pane is *docked*.)

Here is a bit of information that might help quantify the number of changes that ad-libbed speech-to-text editing required, in case that is helpful to anyone.

Unfortunately I honestly can't share the before-editing and after-editing text that I output to MS Word files, as the content is copyrighted by the SME, but Word document compare of before and after files gave this summary:

1770 changes
1039 insertions
729 deletions
2 moves

...For an 30 minute, 3 second video

This conversation is no longer open for comments or replies.