unwanted white border around graphics in Camtasia

  • 1
  • Problem
  • Updated 5 months ago
Using Camtasia 2018.0.7 and Snagit 2019.1 on a PC.
I create a png graphic in Snagit, and add it to the Camtasia media bin. When I drag it onto the canvas a white border appears around the edges, which I do not want.
I have tried making the canvas color in Snagit clear, and I've tried making it the same color as the image. Neither makes a difference. Sounds like this was a fixed bug about 4 years, but maybe the bug has regressed?


Photo of Michelle Sharron

Michelle Sharron

  • 17 Posts
  • 2 Reply Likes

Posted 1 year ago

  • 1
Photo of Michelle Sharron

Michelle Sharron

  • 17 Posts
  • 2 Reply Likes
Ive also tried cropping the edges in Camtasia. No luck.

Photo of Joe Morgan

Joe Morgan

  • 9080 Posts
  • 4786 Reply Likes
Maybe try updating your graphics card drivers.

I'm not sure what exactly you're doing? I'm no artist and my stick people struggle to look like stick people.
However, I drew a smile in SnagIt 2019.1 on a small rectangle.I used the color picker to match the colors of the Camtasia 2018.0.7 png person.

I saved it as a 32 bit color png, 24, 8 and even 4. None of the images displayed the halo/border that yours has. I remember that bug from the past.
But I can't reproduce it.



Regards,Joe

You may need to reach out to tech support.
Photo of Ed Covney

Ed Covney

  • 1042 Posts
  • 524 Reply Likes
2018.0.7 and Snagit 2019.1
I just snagged a dark picture and placed two copies on the time line (see below):
When I shared it to screencast and played it, no border exists. See:

https://www.screencast.com/t/wQbwFcWLl

If you do a test recording, is the border present in the play back?




Photo of Rick Stone

Rick Stone

  • 6632 Posts
  • 3190 Reply Likes
In addition to what others have suggested, have you confirmed that there is not, actually, a border in what is being produced by SnagIt? It sounds to me as if you need to first determine where and how it's manifesting. It could be SnagIt and it could be Camtasia somehow.

I might think an easy way to tell would be to create a new image in SnagIt that is actually larger than the one you are using in Camtasia. Then configure a really different background color for the new image. Then copy the one that seems to have the border and paste it on top of the new image. If you do that, does the border then show? If so, that would seem to suggest something is going on with SnagIt that you need to address. If not, it seems to suggest there is some aspect of Camtasia causing it.

Cheers... Rick :)

Photo of Michelle Sharron

Michelle Sharron

  • 17 Posts
  • 2 Reply Likes
I have furthered narrowed the issue. When the Snag it image is resized in Camtasia to anything less than 75% of the original, the border appears. I was able to fix the problem by resizing the image in snag it first, then importing into Camtasia. Still seems like a bug though. 
Photo of Joe Morgan

Joe Morgan

  • 9080 Posts
  • 4786 Reply Likes
It appears to be some sort of a Luminosity display issue.
In the image below, I have 4 squares of pure Black,White, Yellow and Red. Sized down and showing no border issues.
One skin tone like yours Michelle Sharron and a toned down Green, Yellow and Red. All showing a border to some degree.
Not nearly to the degree you experience. I just get a light edge on the right and bottom edges. I keep my monitors calibrated.That helps. Have you tried updating your graphics card drivers or talking to tech support this?


When I exported that screen shot. The image looks fine.


But I couldn't live with the issue you've encountered. I'm sure its resolvable. You shouldn't have to jump through hoops to work around it.

This is a Free Service............... Submit a ticket

       https://support.techsmith.com/hc/en-us/requests/new

Or call, >>>

 Toll Free: 800.517.3001 (U.S. & Canada Only)

8:00 AM to 7:00 PM EST Monday through Friday

Regards, Joe

Photo of circuitbasics

circuitbasics

  • 1 Post
  • 0 Reply Likes
This is a bug, and hopefully Tech Smith will fix it in the next version... The problem is caused by a conflict with your graphics card settings. Go to Edit > Preferences > Advanced and change your graphics card settings to “software only mode” and the white outline should be gone after you restart Camtasia.

This bug is annoying because it also renders your videos with an ugly gray cast when you render them, and also makes the video effects very hard to work with. For now, I suggest editing with your graphics card, then switching back to software only mode for rendering. But this is an ameteur work around that I hope Tech Smith fixes soon if it hopes to become a professional editing software!
Photo of Murph

Murph

  • 2 Posts
  • 0 Reply Likes
I'm having a similar issue. In the editor and the produced video (Camtasia 2019.09)  I see an orange border. I tried the fix mentioned above to set the graphics card settings to software only mode. No joy. Any ideas aside from cropping every clip? Thanks in advance.
Photo of Joe Morgan

Joe Morgan

  • 9080 Posts
  • 4786 Reply Likes
Can you post a screen shot?