Uploading to YouTube Won't Work

  • 7
  • Problem
  • Updated 1 year ago
I've wasted a total of 9 hours now trying to upload videos from Camtasia Studio 7.1 onto YouTube. Every single time, it doesn't work.

I do this thing that's called a Company of Heroes cast (Company of Heroes is an RTS game). What happens is people send me in their games, and I choose one to commentate. Kind of like a sports commentator.

For the last week it hasn't been working. But before that? It worked like a charm. But now suddenly, for no apparent reason, it doesn't work. The video I've been trying to upload is a 50 minute HD video. Could that be why?

And before you say it, "WUT?!?! FIFTY MINUTES?!?!" Okay, well some other dude that inspired me on YouTube does the same thing and he isn't even a YouTube partner. To top it all off, his videos are in 1080p without a problem.

Can Camtasia not handle fifty minutes of high definition or something? After finishing editing the video, I pass it through an HD renderer to make it 1080p. I do not know why, but this turns the file into a .camproj, which I take and choose the "Upload to YouTube" option.

It finishes uploading the project and all that jazz, and then it fails? What the heck? I've filled out my information correctly, I've given it a title, tags, description, etc. It fails, and it doesn't even tell me why. So I just decide, "No problem! I can upload it from YouTube."

Well, guess what? That doesn't work either. For some reason the little upload bar on YouTube goes instantly from 0-100% on a 50 minute video rendered in HD. How is that possible? To top that off, it also finishes processing instantaneously too. That doesn't make sense, because I remember uploading some Terraria videos with Camtasia the same way, and those took 20 minutes in HD.

So... I'm like, "Maybe it really did work?" *checks* Nope. A little down arrow appears, I click it. It shows three error messages. The sound files aren't recognized, the video files aren't recognized, and the format the video isn't recognized. Help please?

Also, I have a question you also might be able to help me out with, although it is slightly unrelated to Camtasia. At first I thought it was because the videos I was uploading are too long. But this little bar appears above the upload bar (on YouTube) and it says, "Congratulations! You can now upload videos LONGER than 15 minutes!" I don't get it.

Don't you have to be a YouTube partner to upload videos longer than fifteen minutes in length? Did YouTube make me a partner and didn't tell me, or maybe by accident? Because I don't see why they'd make a kid who has 2,000 total upload views, twenty videos, and nineteen subscribers a partner. o.0
Photo of chilitall

chilitall

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 9 years ago

  • 7
Photo of chilitall

chilitall

  • 4 Posts
  • 0 Reply Likes
Better yet, I just managed to upload a video to YouTube that is three minutes in length and in HD, but the audio doesn't work. -.- Also, in the beginning of the video I have a black fade in to this picture of a game (the game the video is about), and then a fade out and into the rest of the video.

Those didn't work either. >:(

EDIT: Okay, I just realized I made a mistake and uploaded the wrong video, which was a rough draft of the final product. I'll let you know what happens, but it seems that Camtasia is lovely when it comes to uploading small videos (15 minutes or under) but anything that exceeds that results in problems, at least for me.

EDIT 2: Okay, I just uploaded a three minute HD video of some Day of Defeat: Source footage and it worked. What the...?
Photo of weinstein4367666

weinstein4367666

  • 1 Post
  • 0 Reply Likes
I'm having the exact same problem too!  Did you ever find the solution?
GL,
Michael
Photo of Wondo123 AJ

Wondo123 AJ

  • 1 Post
  • 0 Reply Likes
This is a HUGE problem and i need help fast, i want to export my video and when i do it says your not connected to the server, my connection is fine and its 5 bars! now that i can't Even upload my videos D:
Photo of Fred Grover

Fred Grover, Champion

  • 2425 Posts
  • 376 Reply Likes
If you are having an issue then I would suggest contacting the Support Dept. which is free. The information is below for doing so.

TechSmith Support Information

http://support.techsmith.com/

Phone: +1.517.381.2300
Toll Free: 800.517.3001
(U.S. & Canada Only)
8:00 AM to 7:00 PM EST Monday through Friday

Sorry to hear of your problem and let us know what they say and how the problem was resolved if there is a solution for others to see and please post it back here. Thanks for posting and have a great day/night. Hope this helps a little.
Photo of KitCattuu AJ

KitCattuu AJ

  • 1 Post
  • 0 Reply Likes
Same its says no internet when i have internet DX well thats a day and a half wasted
Photo of Joe Morgan

Joe Morgan

  • 6611 Posts
  • 3640 Reply Likes
There are sharing permissions within your You-Tube account that must be set properly. This may be behind the error you're receiving.
I never upload directly to you tube myself. I produce my videos as an MP4 and check the video for errors before I commit to an upload.
You could produce the video as an MP4 yourself and upload it manually until you resolve the problem.

Regards, Joe

You can also contact Tech Support.
Photo of Andrew Cool

Andrew Cool

  • 1 Post
  • 0 Reply Likes
Guys i found a solution if you press convert to custom production and then a WMP (windows media player) then when your done go on youtube upload press find video and in your camtasia studio file there should be a file with your video converted to WMP click that done!
Photo of Cameron Flint

Cameron Flint

  • 253 Posts
  • 17 Reply Likes
Hi chilitall,

I'm sorry that you're running into this problem. It's pretty frustrating to have to wait until the upload finishes to find out that it didn't succeed. Thanks for providing such a detailed description of what you're trying to do, though -- it helps us make educated guesses at what might be the underlying cause.

I'm looking through our bug database, and the only thing I can find related is an issue where Camtasia will sometimes (silently) fail to render a produced project correctly if you've nearly run out of disk space on your hard drive -- which is something that is easy to do when you're working with HD video.

Can you check the available space on your primary hard drive? If that's not an issue, we can move on to other troubleshooting. Just want to get the simpler potential causes out of the way first.
Photo of chilitall

chilitall

  • 4 Posts
  • 0 Reply Likes
Thanks for the fairly quick reply! :D

Well, I have 186 GB free out of 465 GB on my hard drive (I only have one hard disk drive, called Local Disk (C:)).

My computer was manufactured by ibuypower, 4.00 GB of RAM, 64-bit operating system, Windows Vista.

Sadly, I've also deleted the FRAPs clips as well as the 50 minute video since then. However, the game that I casted I still have, so I could redo a test version so to speak to see if I can replicate the results.
Photo of chilitall

chilitall

  • 4 Posts
  • 0 Reply Likes
The only reason why it is that low is because I have quite a lot of FRAPs footage. However, it's just sitting around waiting to be used because of this problem I am experiencing.

I just used Windows Movie Maker and it worked. I can upload a 50 minute video with it to YouTube without a problem, and in HD. But I don't want to have to do that. I really love Camtasia, due to the fact you can do some nice editing with it, and I didn't even have to watch tutorials to understand how to use it.

I tried Sony Vegas 9, and it might be better (no offense) but it is very confusing to learn how to use, let alone master it. So I'd really appreciate it if you could help me out with this, or direct me to someone/somewhere else that can assist me. Thank you! :)
Photo of Cameron Flint

Cameron Flint

  • 253 Posts
  • 17 Reply Likes
Hi chilitall,

Just to make sure I understand your workflow correctly, you are:

1. Recording high-motion footage of the screen as you are interacting with games, using FRAPS to do the actual recording.
2. Running this output video through another third-party converter to increase the dimensions of the video to 1080p.
3. Importing the resulting file in Camtasia Studio, making edits, and then attempting to use the "Upload to YouTube" option to complete your production.

Is this correct? If so, there are a few additional things you could try:

- Edit the video from FRAPS directly in Camtasia, *before* you do the conversion to 1080p. This is a shot in the dark, but it is possible that the recording dimensions are too large for Camtasia to handle, or that the third-party converter is otherwise generating a file that Camtasia doesn't handle well.
- Reduce the dimensions that you are recording at.

Keep in mind that these are only educated guesses at this point, though hopefully one of them will provide an adequate workaround for you. My apologies for the delayed response.
Photo of theonetruedominator

theonetruedominator

  • 3 Posts
  • 0 Reply Likes
same here im trying to upload a video that i recorded with camtasia but when i try to upload it to youtube it says rendering project 50% complete and then it closes and it wont work anymore. if you dont know about this problem can you tell me how to convert it to a file that i can upload directly to youtube
Photo of Cameron Flint

Cameron Flint

  • 253 Posts
  • 17 Reply Likes
An alternative to using the YouTube plug-in is to produce to MP4, using the Custom Production Settings preset. The resulting .mp4 file can be separately uploaded to YouTube.

Note that if you want HD viewing dimensions available to your viewers on YouTube, you will want to record and produce at 1280x720 (720p) or higher. More information on encoding for YouTube is available at the links below:

http://support.google.com/youtube/bin...
http://support.google.com/youtube/bin...
Photo of theonetruedominator

theonetruedominator

  • 3 Posts
  • 0 Reply Likes
thank you
Photo of gabrielplayroom

gabrielplayroom

  • 10 Posts
  • 0 Reply Likes
i have a probelm were it uploads but its only one minute when its supposed to be like 13
Photo of Cameron Flint

Cameron Flint

  • 253 Posts
  • 17 Reply Likes
If you produce to MP4, is the video truncated when you play it back? Or is it only after uploading?
Photo of gabrielplayroom

gabrielplayroom

  • 10 Posts
  • 0 Reply Likes
in the preview i record 30 FPS minecraft! FRAPS
Photo of gabrielplayroom

gabrielplayroom

  • 10 Posts
  • 0 Reply Likes
and uploading
Photo of gabrielplayroom

gabrielplayroom

  • 10 Posts
  • 0 Reply Likes
basically not all the time just mostly and only pretty much MPEG4 files the rendering gets to a lowish number then it says uploading to youtube O_o so it renders like 3 seconds cameron flint it sounds like you know what to do please help
Photo of gabrielplayroom

gabrielplayroom

  • 10 Posts
  • 0 Reply Likes
cameron flint please help me :(
Photo of gabrielplayroom

gabrielplayroom

  • 10 Posts
  • 0 Reply Likes
i tried that and it didnt render thats my probelm not that it freezes it just literally renders about 3 seconds and starts upload and its only with MPEG4 files because i want to custom settings and made it a .avi and it would fully render so cameron that cant help me please make sure you have progammed this correctly no offense because soon im going in there with Notepad++ if i dont get an answer soon better yet ill delete it and get sony vegas pro 11 i like camtasia but now its gone faulty with its mp4 files I FUCKING HATE IT to put it simply.
Photo of gabrielplayroom

gabrielplayroom

  • 10 Posts
  • 0 Reply Likes
oh yeah my fraps spilts the videos every 4gb is that a probelm?
Photo of Love Autumn

Love Autumn

  • 1 Post
  • 0 Reply Likes
This is very annoying I know. When I was getting started with my YouTube videos before they became popular I couldn't upload because of this, but now I just cut my videos in half, upload one part and upload the other making sure that the time limit never exceeds 15 minutes otherwise they don't upload.

Once you get the hang of this they upload like a dream!

Hoped this helped.
Photo of Luítame

Luítame

  • 1 Post
  • 0 Reply Likes
this problem isn't in the Camtasia. And yes in the Youtube. Is only to do the confirmation of your account. Problem successfully!
Photo of rek600

rek600

  • 2 Posts
  • 0 Reply Likes
I'm a bit confused on all of this. I posted about 14 videos each about 20 minutes long to youtube, and now I can't post a 20 minute video any more. All that it is changed about this video, is it has two background songs. It stops at 50% and fails to upload. I tried this many times and because of my slowish internet, I learnt that I can't use too much internet items like a bunch of wedsites up or playing a multiplayer game or it will fail. It usually takes about 2 hours uploading my videos because again, of my slow internet, and it goes faster the less you use the internet during the upload. When uploading the video, I used no other thing that uses the internet and it still fails to upload. I have a 1 TB hardrive with 186 GBs out of 931. So does this means it failing to upload because of my memory? I also have 8GB of RAM.186 GB left is quite low and none of my videos where uploaded that low, mebay one, but it was a shorter, less than 10 minute video. I really love making videos very much and I don't want to give this up. So is this about memory or something else? On some videos I just cut in half, because it's not right or it won't be a well video. Should I just do is create it into a mp4 file and uploaded on youtube that way?
Photo of rek600

rek600

  • 2 Posts
  • 0 Reply Likes
Hello again! This video helped me clear the confusion for me, hopes it helps for other people! https://www.youtube.com/watch?v=9y5MBIpnGaQ It takes a lot longer to upload these videos though, like a couple hours, but not like 2 hours as before for an avg. of 20 minutes. I uploaded a couple videos using the other way to upload videos in the youtube link above and it works well. . I need better internet, but if it worked before, why not now? I keep wondering why, and i wonder if it has to do with the memory posiablely?
Photo of Bob

Bob

  • 4 Posts
  • 0 Reply Likes
I tried uploading a 1 minute video that was created using the YouTube editor. I starts to upload and gets to the 90% mark and goes no further. I've tried different browsers but to no avail. I've waited for over an hour but it still doesn't move.
Photo of Ira Caullene Gatan

Ira Caullene Gatan

  • 1 Post
  • 0 Reply Likes
There are different problems you may encounter when uploading videos in Youtube: The server has rejected the file, an error has occurred while sending the data over the network, an error was occurred while reading the uploaded file, and a security error has occurred. Making changes to your video settings can solve common audio and video issues.To do this, here are the steps to follow: Open the video in a video editing program, verify video settings and save/export. If you have uploaded videos in Youtube, you can use the BeUpon online tool. This system tracks your videos 24/7. It has an easy to navigate dashboard. It alerts you in times of video suspensions and set up back up videos too. To find out more, visit their website: http://www.beupon.com.
Photo of Richard Franklin

Richard Franklin

  • 6 Posts
  • 2 Reply Likes
same here im trying to upload a video that i recorded with camtasia but when i try to upload it to youtube it says rendering project 50% complete and then it closes and it wont work anymore. if you dont know about this problem can you tell me how to convert it to a file that i can upload directly to youtube
Photo of Kelly Mullins

Kelly Mullins, TechSmith Employee & Helper

  • 2931 Posts
  • 690 Reply Likes
Hi Richard,
Can you just produce the MP4 video then log in to YouTube and manually upload it?

Kelly
User Assistance
TechSmith
Photo of Robert Bob Malenko Jones

Robert Bob Malenko Jones

  • 3 Posts
  • 0 Reply Likes
You can do that, but it used to work, so why would it all of a sudden stop working?

One of the best features for me was being able to upload to Youtube straight from Camtasia after the video was done being edited.  NOW, I have to input all the information to upload it to youtube twice (once to produce the video, just in case it works, then a second when I manually upload to youtube).  Why would the option to upload from Camtasia stop working all of the sudden?
(Edited)
Photo of Robert R.

Robert R., Online Community Admin

  • 1659 Posts
  • 539 Reply Likes
Hello;

There could be any number of reasons for Camtasia to stop uploading to YouTube; to start what is the exact version number that you are currently running? Have you opened a support ticket and talked to our free Technical Support team?

-Robert
Photo of Robert Bob Malenko Jones

Robert Bob Malenko Jones

  • 3 Posts
  • 0 Reply Likes
I just did.  Didn't know how to, found this page through a search.  Using Version 7.1.1 (Build 1785).
Photo of Robert R.

Robert R., Online Community Admin

  • 1659 Posts
  • 539 Reply Likes
Hi;

If you are on Camtasia 7 that would explain the issue; the YouTube API and sign-on requirements have changed drastically since Camtasia Studio 7 was last being worked on (note, Camtasia Studio 7 is no longer supported, see: https://support.techsmith.com/hc/en-us/articles/203732728-End-of-Product-Support ). There will be no additional patching done on Camtasia Studio 7.

Camtasia Studio 8.6.0 and Camtasia 9 both use updated API / programming and do not exhibit this behavior.

-Robert
Photo of Robert Bob Malenko Jones

Robert Bob Malenko Jones

  • 3 Posts
  • 0 Reply Likes
Why would it stop working since last month though?  I've NEVER had a product go EOL and stop functioning.  So now my $200 program is worthless and you are expecting me to go spend another $200??
Photo of Robert R.

Robert R., Online Community Admin

  • 1659 Posts
  • 539 Reply Likes
Hello;

My apologies if it came off that in order to continue producing content that can be stored on YouTube would require you to update to Camtasia 9; it will not. I would not call Camtasia Studio 7 worthless, even if it is no longer supported, since you can continue producing to MP4 locally and then uploading via the YouTube web portal. The issue is that Camtasia Studio 7, which we stopped development on in May of 2011, used a different method to upload to Youtube, one that is quite old and it is well within the realm of possibility that Youtube simply disabled that upload method in entirety. We have no control over what upload methods YouTube continues to support. Note though, that if you did want to purchase an upgrade to Camtasia 9, being a valid keyholder for a previous version yields you a significant discount from the new user pricing (to the tune of 50% off of new user prices).

-Robert
Photo of Helmut Licht

Helmut Licht

  • 2 Posts
  • 0 Reply Likes
I have the same problem with Camtasia 9.  It will simply not let me upload my video to youtube.  I have attached two images showing the problem. My alternative has been to save the video (that's one of the options the error message gives you and then go into PowerDirector and upload it from there WITHOUT ANY PROBLEMS.
Photo of calatrello

calatrello

  • 1 Post
  • 0 Reply Likes
This worked for me and came from Aaron at Techsmith this morning.  
Please do the following to see if it corrects the issue in Camtasia:

*** Close out of Camtasia completely ***

1.) Open a Finder window and then click the Go menu at the top left of your monitor and then choose Go to Folder... at the bottom.
2.) Type in: ~/library
3.) Click on Go
4.) Navigate to the Preferences folder.
5.) Locate all com.techsmith.camtasia2.plist files and move them to your trash bin. Empty your trash bin.
6.) Confirm that com.techsmith.camtasia2.plist and no other Camtasia 2 files are no longer in the Preferences folder.
7.) Restart your computer
8.) Launch Camtasia and see what happens.
 
Photo of Robert R.

Robert R., Online Community Admin

  • 1659 Posts
  • 539 Reply Likes
Hi all!

One thing to note is that calatrello's response is specific to the Mac operating system.

I would also like to point out that we advise caution when doing this; altering or deleting other files in that folder not pertaining to the steps may be problematic and you do so at your own risk.

-Robert
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
Hi guys!!!! im having the same issue. I am uploading a video thats only 3:20 some minutes and its saying an error occured. Ive tried this for over 3 days and its still not working. Im using camtasia 2018.

Can SOMEONE PLZZZZZZZZZZZZZZZZ HELP!!!!!!!!!!!!
Photo of Joe Morgan

Joe Morgan

  • 8420 Posts
  • 4531 Reply Likes
Just do a custom production to MP4. Upload it manually.

Regards,Joe
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
how do i do that?
Photo of Joe Morgan

Joe Morgan

  • 8420 Posts
  • 4531 Reply Likes
What's the size and frame rate of your video.
Is it 1920 x 1080 30fps or what. Because quality settings matter. To high and file sizes are larger than necessary. To low and the video looks bad.The higher the resolution of the video, the higher the setting need to be. A 1920 x 1080 video needs higher settings than a 1280 x 720 video.Stereo audio needs higher settings than Mono.
Photo of Joe Morgan

Joe Morgan

  • 8420 Posts
  • 4531 Reply Likes
You get to Custom Production settings Here.



If you want help with the settings I can help you. Or you can go to you tube and  look them up yourself.
Scroll to the bottom of your you tube page and click "Help"

Type in Upload, you will see... Recommended upload encoding settings.
Follow the guidelines.
(Edited)
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
Can you help me please because u seem to know what your doing

And I dont know how to find my fps
Photo of Joe Morgan

Joe Morgan

  • 8420 Posts
  • 4531 Reply Likes
How did you record your video
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
its a bunch of pictures like a collage with music
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
i just imported the pictures
Photo of Joe Morgan

Joe Morgan

  • 8420 Posts
  • 4531 Reply Likes
So what I need is the project settings then. There above the canvas area. The Canvas Dimensions is going to be the impotent thing at this point. 

See image.




Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
Ok my canvas dimensions says custom and is making me choose between multiple ones. 
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
My width is 1366 and my height is 768 if that helps at all?
Photo of Joe Morgan

Joe Morgan

  • 8808 Posts
  • 4703 Reply Likes
Okay, here you go.
Follow share to Custom Production as in this image.
Then use these settings.

Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
Ok i did that what now??? its rendering after its done rendering what do i do?
Photo of Joe Morgan

Joe Morgan

  • 6744 Posts
  • 3717 Reply Likes
Upload to You Tube manually

Photo of Joe Morgan

Joe Morgan

  • 6744 Posts
  • 3717 Reply Likes
Go to your your tube page and select upload.Follow the instructions.
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
ok thank you can i contact you through this again if im having trouble?
Photo of Joe Morgan

Joe Morgan

  • 6744 Posts
  • 3717 Reply Likes
Sure, I'm on the computer sporadically but I will get back with you.

Photo of Joe Morgan

Joe Morgan

  • 6744 Posts
  • 3717 Reply Likes
Let us know if it all works out and your problem is resolved
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
I got it!!!!!!! My problem is resolved thank you sooooooooooo much!
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
Joe I have another question. I have this game that i play star stable and camtasia 2018 does not record it. Its a full screen game and it has its own little icon at the bottom of my screen. But when I go to record the game all it records is my background and not the actual game. So how do i deal with this and get it to actually record my game?
Photo of Joe Morgan

Joe Morgan

  • 6744 Posts
  • 3717 Reply Likes
If the game has settings allowing you to play in windowed mode you can record it.

Unfortunately, Camtasia cannot record games in full screen mode. That's why your only seeing the background.
(Edited)
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
thats confusing... So it wont record my screen???
it doesnt let me play windowed
Photo of Joe Morgan

Joe Morgan

  • 6744 Posts
  • 3717 Reply Likes
No, it's the way the recorders designed.Windowed mode or nothing. I have no idea how many video games offer windowed mode.I believe most high quality ones do.But I'm not into gaming that much these days.  I have no idea what's considered normal "Feature Wise" any more.


Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
So camtasia has a windows mode???
If so how do I get it into that mode????
Photo of Joe Morgan

Joe Morgan

  • 6744 Posts
  • 3717 Reply Likes
No, that's Medal Of Honor settings being placed in Windowed Mode. Then the game being played in windowed mode and a screen shot of that below.Sorry, didn't mean to confuse the issue
Photo of gallopinggolie

gallopinggolie

  • 17 Posts
  • 1 Reply Like
its ok
Photo of Todd Davis

Todd Davis

  • 2 Posts
  • 1 Reply Like
Hi, I just want to add that I am experiencing the exact same issue as the others here. My videos are very short, usually just a few minutes. Uploading to YouTube used to work last week or so, now it does not. It gets to roughly 50% and then stops. I have a terabyte drive with tons of free space, so that is not the problem. I tried logging out and then back in again. For some reason, I kept getting an error message about need for my YouTube account to be linked to a channel, whch it is. I tweaked some random settings on YouTube in the channel just in hopes that it would "update" things on the YouTube end. It is still failing. 
For now I am uploading manually, but I would really prefer to not have to take the extra steps. I am not on a mac, so those fixes do not work for me. I have the latest version of Camtasia as of this posting.