Very Slow Editing with Camtasia 2019.0.6

  • 2
  • Problem
  • Updated 1 month ago
I am editing a completed Camtasia recording on my C drive (not a network nor a drive connected to my PC via USB). My PC is a relatively new model with plenty of memory, computing power, and a good graphics card. When editing out long pauses between comments on the timeline, I find it takes anywhere from 15 to 30 seconds for the deletion to complete. I see there are other people having this problem. I have talked with tech support already about this and the advice I was given was not helpful. I do not know what the problem is. Anyone out there have any ideas how to improve performance of this software program?

Unhappy user in the upper midwest
Photo of Jay Memmott

Jay Memmott

  • 2 Posts
  • 0 Reply Likes

Posted 10 months ago

  • 2
Photo of kayakman

kayakman, Champion

  • 8011 Posts
  • 2771 Reply Likes
do you have markers in the project?
Photo of Jay Memmott

Jay Memmott

  • 2 Posts
  • 0 Reply Likes
Photo of kayakman

kayakman, Champion

  • 8011 Posts
  • 2771 Reply Likes
OK, thanks for that info
Photo of paulwilliamengle


  • 419 Posts
  • 153 Reply Likes
Do markers make a difference?
Photo of kayakman

kayakman, Champion

  • 8011 Posts
  • 2771 Reply Likes

in Camtasia 2019, if a project has many markers, AND, marker flags are displayed, editor performance can be materially, adversely, affected; most edits are slow/delayed, hangs can be experienced

issue has been reported to TechSmith and confirmed

solution is to keep marker track [and the marker flags] hidden.

if working with a high marker count project, and, marker track is set to show markers before project is loaded,. the load can take a long time; solution is to be sure marker track is hidden before loading the project; with flags displayed, timeline navigation can be very sluggish

I often work with very high marker count projects; issue is noticeable at 50 markers, significant at 100 markers, severe at 500 markers

keep the marker track hidden, and generally there are no issues
Photo of Ed Covney

Ed Covney

  • 1042 Posts
  • 523 Reply Likes
New PCs can come with 4 GB RAM, I think TS recommends at least 8 GBs of RAM and prefer 16. If you have a hidden file in your root directory ( C:\PageFile.SYS ) it can be used as more RAM, but is very slow.  I only mention this because 15 to 30 seconds sounds suspiciously like Camtasia (Windows actually) is using your boot drive as RAM..
Photo of Joe Morgan

Joe Morgan

  • 9069 Posts
  • 4784 Reply Likes
Are you using Ripple Delete?
If so this may be what your looking for.

Photo of David B. Demyan

David B. Demyan

  • 113 Posts
  • 118 Reply Likes
It is good to know there may be a permanent fix for this issue. For years, through successive releases I have used the workaround of closing ALL other applications on my editing/production workstation to improve timeline performance in general, including the speed of editing cuts. I find Microsoft Outlook a particular resource hog for some reason. Sometimes, when I shut down outlook, delays magically disappear, leading me to believe the resource issue is really RAM and disk-swapping.
Photo of David Harrison

David Harrison

  • 14 Posts
  • 5 Reply Likes
Hi Jay,
Have you tried "Use Software-Only Mode"?
I had problems with my cursor disappearing, stuttering in Preview and long ripple delete times when I upgraded to 2019.0.6.
My rig is majorly over built and I still had these issues but I switched to "Use Software-Only Mode" and everything is working better now.

My Rig:
* MOBO: Gigabyte x399 Designaire
* CPU: AMD Threadripper 1950X (16 Cores-32 Threads) @ 4.0 Ghz
  * Water Cooled
* Ram: 32G (4x8G) Quad Channel DDR4 @ 3200Mhz
* SSD: Two Samsung 960 Pro M.2's @  512G
  *Both M.2 cards have 4 dedicated PCIE lanes to CPU each!
* GPU: EVGA Hybrid GTX 1080
  * GPU has 16 dedicated PCIE lanes to CPU
* Windows 10 (64 Bit)
* Camtasia 2019 (Build 5004-v2019.0.6 64 Bit)
* Snagit (v2019.1.3 64 bit)

Photo of Theresa Green

Theresa Green

  • 8 Posts
  • 2 Reply Likes
I set my preferences to "software-only" mode and thought it worked at first but afraid wishful thinking. Did not help.I had not had any problems until recently, so I thought, what changed? I had put in a narration track recorded on another device in m4a. So I used Camtasia to re-render the audio track and that seems to have done the trick. So it seems that Camtasia does not play well with some files made by other software, even compatible ones, so maybe worth looking at some of your files and maybe doing a conversion. Even if they have the same format.
Photo of JasonSTI


  • 5 Posts
  • 0 Reply Likes
Same thing, but working with TechSmith support and we may have found a solution. Added to this thread: